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1 Description of the problem 

An example of a circular cylindrical tank with a conical base resting on elastic foundation using 

Winkler’s model is selected to illustrate some features of ELPLA for analyzing circular cylindrical 

shell elements. 

2 Loads 

A circular cylindrical tank of an inner diameter of d = 15 [m] and a height of H = 6 [m]  

is considered as shown in Figure 7.1. Thickness of the tank wall is t = 0.5 [m]. The tank is filled 

with water. The soil under the base of the tank is represented by isolated springs of stiffness ks, 

which represent modulus of subgrade reaction. Figure 7.1 shows the tank with dimensions,  

while the tank material, unit weight of the water and the modulus of subgrade reaction are listed  

in Table 7.1. 

 

 
Figure 7.1 Circular cylindrical tank on isolated springs with dimensions 

Table 7.1 Tank material, water unit weight and modulus of subgrade reaction 

Modulus of Elasticity of the tank material   Ec = 2×107 [kN/ m2] 

Poisson's ratio of the tank material     νc = 0.2             [-] 

Unit weight of the tank material                           γc = 25  [kN/ m3] 

Unit weight of the water     γw  = 10  [kN/ m3] 

Modulus of subgrade reaction    ks  = 100 000 [kN/ m3] 

 

 

Ec = 2×107 [kN/ m2] 

νc = 0.20    [-] 

γc = 25       [kN/ m3] 

γw = 10       [kN/ m3] H
 =

 6
 [

m
] 

t = 0.5 [m] 

a = 7.5 [m] 

ks = 100 000 [kN/ m3] 

0.85 [m] 
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3 Numerical Analysis 

In the analysis, the height of the tank is divided into 20 equal elements, each of 0.30 [m], as shown 

in Figure 7.2 . The conical base of the tank is divided into 17 equal elements. 

 

 

 
Figure 7.2 Finite element mesh of the tank 

4 Creating the project 

In this section, the user will learn how to create a project for analyzing an axi-symmetrically circular 

cylindrical tank resting on elastic foundation using Winkler’s model. The project will be processed 

gradually to show the possibilities and abilities of the program. To enter the data of the example, 

follow the instructions and steps in the next paragraphs. 

4.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 7.3. This wizard will help the user to define the analysis type and the 

calculation method of the problem through a series of Forms. The first Form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 7.3). 
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Figure 7.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 7.3, as the analysis type is a circular cylindrical tank problem, 

select "Analysis of rotational Shell" button and check "Shell with a raft foundation" option, then click 

"Next" button to go to the next Form. After clicking "Next" button, the "Calculation Methods" Form 

appears, Figure 7.4. 
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To define the calculation method: 

 

- Select the calculation method "2/3 Constant/ Variable Modulus of Subgrade Reaction" 

- To determine the modulus of subgrade reaction, select "Modulus is defined by the user" 

- Click "Next" button to go to the next Form. 

 

 
Figure 7.4 "Calculation Method" Form 
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The last Form in the wizard is the "Options" Form, Figure 7.5. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Select "Additional Springs", then click the "Save" button. 

 

 
Figure 7.5 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 7.6. In this dialog box 

type a file name for the current project in "File name" edit box. For example, type "Conical Tank". 

ELPLA will use automatically this file name in all reading and writing processes. 
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Figure 7.6 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project  

[Conical Tank] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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4.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely 

entered. To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 7.7 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a tank with conical base resting on Winkler's medium" 

- Type the date of the project in the "Date" edit box 

- Type the word "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 7.7 "Project Identification" dialog box 

4.3 FE-Net data 

For the given problem, a cylindrical water container with a conical base of a radius of a = 7.5 [m]  

and a height of H = 6 [m] is considered, the height of the tank is divided into two main segments, 

the main segment of the wall is divided into 20 elements (20×0.3 [m]), while the conical part is 

divided into 17 elements.  

 

To define the FE-Net for this tank, choose "FE-Net Data" command from the “Data” Tab. "Analysis of 

rotational shell" wizard appears as shown in Figure 7.8. This wizard will guide you through the steps 

required to generate a FE-Net, the first Form of the wizard is the "Shell type" Form, which contains a 

group of templates of different shapes of nets. These net templates are used to generate standard nets. 
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Figure 7.8 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 
 

- In the "Shell type" options choose "Irregular shell" button 
- Type 0.6 in the "Radius of the tank base" edit box,  
 
To identify the foundation segment    

 
• Type 0.6 in the "Height" edit box 
• Type 0.6 in the "Upper radius" edit box 
• Type 3 in the "Number of segments" edit box 
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To identify the segment of the conical part 
 

• Type 0.85 in the "Height" edit box 
• Type 7.5 in the "Upper radius" edit box 
• Type 17 in the "Number of segments" edit box 

 
To identify the segment of the tank height 

 
• Type 6 in the "Height" edit box 
• Type 7.5 in the "Upper radius" edit box 
• Type 20 in the "Number of segments" edit box 

- Click "Next" button to go to the next Form 

 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Irregular shell" Form 

containing the data of the segments appears in Figure 7.9, The user can edit the data of each 

segment individually or all of them by using "In Table" button. 
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Figure 7.9 " Irregular shell" Form 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Net of Base" Form 

appears Figure 7.10. 
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To edit the grid spacing in x-direction of the tank foundation, do the following steps  

in "Grid in x-direction" frame: 

- Choose "Constant grid interval" check box 

- Type 10 in the "No. of grid intervals" edit box 

 

 
Figure 7.10 "Net of Base" Form 

Click "Finish" button, the FE-Net of the wall and a sector from the base appears in Figure 7.11 
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Figure 7.11 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 7.11 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 7.11 to close the "FE-Net" window 

and return to ELPLA main window 
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4.4 Shell properties 

To define the tank properties, choose "Shell Properties" command from “Data” Tab. The following 

window in Figure 7.12 appears with default shell properties. The data of shell properties for the 

current example, which are required to be defined, are element groups, unit weight of the tank,  

and the filled material properties. 

 

 
Figure 7.12 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 7.13 appears. 

In this list box, enter E-Modulus, Poisson’s ratio and slab thickness. Then click "OK" button. 
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Figure 7.13 "Defining element groups" list box 

To enter the unit weight of the tank, choose "Unit weight" command from "Shell Properties" menu 

in Figure 7.12. The following dialog box in Figure 7.14 with a default unit weight of 25 [kN/m3] appears, 

click "OK" button. 

 

 
Figure 7.14 "Unit weight" dialog box 
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To define the filled material properties of the tank, choose "Filled material type/Element size" 

command from "Shell Properties" menu in Figure 7.12. The following form in Figure 7.15 appears. 

 

To define the filled material properties of the Tank: 

 

- Select "Liquid container" option  

- Type 6.85 in the "Height of the liquid" edit box 

- Type 9.81 in the "Unit weight of the liquid" edit box 

 

To define the element size of the tank: 

 

- Check the "Constant element sizes in z-direction" check box 

- Type 0.2 in the "Element size in each shell segment" edit box 

- Click "OK" button 

 

 
Figure 7.15 "Liquid properties/Element size" Form 

After defining the shell properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 7.12 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 7.12 to close the "Shell properties" 

window and return to ELPLA main window 
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4.5 Soil Properties 

To define the soil properties, choose "Soil Properties" command from “Data” Tab. The following 

"Soil Properties" form in Figure 7.16 appears, enter Modulus of subgrade reaction of the soil and  

the ground water under the surface. Other data in the example are not required. 

 

Soil data: 

 

Modulus of subgrade reaction    ks  = 100 000 [kN/ m3] 

Ground water depth under the surface   Gw  = 1  [m] 

 

 
Figure 7.16 "Soil Properties" form 

 

 

 

 

 

 

 

 

 

 

 

 

 



Example 7  

 

 

   -7.19- 

4.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 7.17 appears. 
 
In ELPLA, entering loads may be carried out either numerically (in a table) or graphically using the 
commands of "Loads" Tab in Figure 7.17. In this example, there is not applied load, as the vertical 
load has been already defined by the unit weight of the tank, while the hydrostatic pressure on the 
tank wall is defined by the unit weight of water. 
 

 
Figure 7.17 "Loads" Window 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 7.17 to save the load data 

- Choose "Close" command from "File" menu in Figure 7.17 to close the "Loads" window 

and return to ELPLA main window 
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4.7 Spring Supports 

To define the Spring supports, choose "Spring Supports" command from “Data” Tab. The following 
window in Figure 7.18 appears. 
 

 
Figure 7.18 "Spring Supports" Window 

To define the spring supports on the net: 

 

- Choose "Select Nodes" command from "Graphically" menu in Figure 7.18. When "Select 

Nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the node that has the spring support as shown in Figure 7.19 

- After selecting the nodes, choose "Add Spring Supports" command from "Graphically" 

menu (Figure 7.18). The "Edit Spring Support" dialog box in Figure 7.20 appears. 
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Figure 7.19 Selection of the nodes that have the spring support 

 

 
Figure 7.20 "Edit Spring Support" dialog box 
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Figure 7.21 "Edit Spring Support" dialog box 
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Figure 7.22 "Edit Spring Support" dialog box 
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Figure 7.23 "Spring Supports" window after defining the springs 

After defining the spring supports, do the following two steps 

 

- Choose "Save " command from "File" menu in Figure 7.23 to save the data of the springs 

- Choose "Close" command from "File" menu in Figure 7.23 to close the "Spring Supports" 

window and return to the main window 

 

Creating the project of the tank is now complete. It is time to analyze this project. In the next 

section, you will learn how to use ELPLA for analyzing projects. 
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5 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 7.24. 

 

 
Figure 7.24 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 
Commands of calculation depend on the used calculation method in the analysis. For this project, 
the items that are required to be calculated are: 
 

- Assembling the load vector 
- Determining the modulus of subgrade reaction 
- Assembling the slab stiffness matrix 
- Solving the system of linear equations (band matrix) 
- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab Window.  

 

The progress of all computations according to the defined method will be carried out automatically 

with displaying Information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 7.25 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. In addition, a status bar down of the 

"Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 7.25 Analysis progress menu 
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Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 7.26. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 7.26 Menu "Check of the solution" 

Click "OK" button to finish analyzing the problem. 
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6 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through the 

"Results" Tab. 

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

switch to "Results" Tab (Figure 7.27).  

 

 
Figure 7.27 "Results" Tab 

The "Results" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Rotational shell results 

- Sections in shell wall 

- Sections in shell base 

 

To view the radial forces in the shell wall:  

 

- Choose "Sections in shell wall" command from "Section" menu. The following option box 

in Figure 7.28 appears 

- In the "Sections in shell wall" option box, select "Radial forces Nr" as an example for the 

results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 7.29. 

 

 
Figure 7.28 "Sections in shell wall" option box 
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Figure 7.29 Radial forces in shell wall 

To view element groups of the tank  

 

- Choose "Element groups" from "In Plan" command in "Data" menu. The following option 

box in Figure 7.30 appears 

- In the "Data – In Plan" option box, select "Element groups" as an example for the results  

to be displayed 

- Click "OK" button 

 

 
Figure 7.30 "Data – In Plan" option box 
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To view the meridional moments on the FE-Net and any other data 

 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command.  

The "View Grouping" check group box in Figure 7.31 appears 

- In this check group box, check "Meridional moments My" check box  

- The user can choose any other data to be viewed 

- Click "OK" button 

 

 
Figure 7.31 "View Grouping" check group box 

 
Figure 7.32 Element groups of the tank 

 

 

 


