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1 Description of the problem 

An example of an annular plate resting on Winkler's medium is selected, to illustrate some features 

of ELPLA for analyzing shell elements using circular and annular elements. 

2 Geometry and properties 

A simply supported annular plate subjected to a uniform load resting on Winkler's medium is chosen 

as shown in Figure 2.1. Load on the plate, plate radii, elastic properties of the soil and the plate are: 

 

Inner radius of the plate   r1 = 2.5   [m] 

Outer radius of the plate   r2 = 5   [m] 

Thickness of the plate    t = 0.25   [m] 

Uniform load on the raft    p = 200   [kN/m2] 

Modulus of sub grade reaction of the soil ks  = 10000  [kN/m3] 

Young’s modulus of the plate material Ec  = 2.7×107  [kN/m2] 

Poisson's ratio of the plate material  νc  = 0.2  [-] 

 
Figure 2.1 Annular plate subjected to a uniform load  
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3 Analysis of the plate 

The available method "Constant Modulus of Subgrade Reaction /2" in ELPLA is used here to 

determine the vertical displacement and moment of the plate on Winkler's medium.  

Figure 2.2 shows the annular plate with 10 annular regions and supports. 
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Figure 2.2 Annular plate with 10 annular regions and supports 
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4 Creating the project 

In this section, the user will learn how to create a project for analyzing an annular plate  

resting on Winkler's medium. The project will be processed gradually to show the possibilities  

and abilities of the program. To enter the data of the example, follow the instructions and steps 

in the next paragraphs. 

4.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 2.3. This wizard will help the user to define the analysis type and the 

calculation method of the problem through a series of Forms. The first Form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 2.3). 

 

 
Figure 2.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 2.3, define the analysis type of the problem. As the analysis 

type is an annular plate, select "Analysis of rotational shell" button, and check "Shell with a raft 

foundation" option, then click "Next" button to go to the next Form. After clicking "Next" button, 

the "Calculation Methods" Form appears, Figure 2.4. 
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To define the calculation method: 

 

- Select the calculation method "2/3 Constant/ Variable Modulus of Subgrade Reaction" 

- To determine the modulus of subgrade reaction, select "Modulus is defined by the user" option 

- Click "Next" button to go to the next Form 

 

 
Figure 2.4 "Calculation Methods" Form 

The last Form in the wizard is the "Options" Form, Figure 2.5. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Select "Supports/ Boundary Conditions", then click the "Save" button. 
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Figure 2.5 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 2.6. In this dialog box 

type a file name for the current project in "File name" edit box. For example, type "annular plate". 

ELPLA will use automatically this file name in all reading and writing processes. 
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Figure 2.6 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project [annular plate] 

will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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4.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely 

entered. To identify the project, choose "Project Identification" command from the “Data” Tab. The 

dialog box in Figure 2.7 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of an annular plate resting on Winkler's medium" 

- Type the date of the project in the "Date" edit box 

- Type the word "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 2.7 "Project Identification" dialog box 

4.3 FE-Net data 

For the given problem, the shell has an annular shape with an outer radius of b = 5 [m]  

and an inner radius of a = 2.5 m. To define the FE-Net for this plate, choose "FE-Net Data" 

command from the “Data” Tab. "Analysis of rotational shell" wizard appears as shown  

in Figure 2.8. This wizard will guide you through the steps required to generate a FE-Net. 

 

The first Form of the wizard is the "Shell type" Form, which contains a group of templates of 

different shapes of shells. These net templates are used to generate standard nets. 
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Figure 2.8 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 

 

- In the "Shell type" options choose "Cylindrical shell" button 

- Type 0 in the "Height" edit box, as the example is an annular plate 

- Type 5 in the "Radius" edit box, as the outer radius is b = 5 m 

- Click "Next" button to go to the next Form 
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Figure 2.9 "Net of Base" Form 

The next Form of the "Analysis of rotational shell" wizard is the "Net of Base" Form Figure 2.9.  

 

To edit the grid spacing in x-direction, do the following steps in "Grid in x-direction" frame: 

 

- Choose "Variable grid interval" check box.  

- Click "Grid Intervals" button, the following "Grid intervals in x-direction" form appears 

Figure 2.10 

- Define the grid intervals as the following  
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Figure 2.10 "Grid intervals in x-direction" Form 

ELPLA will generate a sector from the annular area with 11 circular elements. The following 

Window in Figure 2.11 appears with the generated net. 
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Figure 2.11 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 2.11 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 2.11 to close the "FE-Net" window 

and return to ELPLA main window 
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4.4 Soil Properties 

To define the soil properties, choose "Soil Properties" command from “Data” Tab. The following 

"Soil Properties" form in Figure 2.12 appears, enter the modulus of subgrade reaction of the soil and  

the ground water depth under the ground surface. Other data for this example is not required. 

 

Soil data 

Modulus of subgrade reaction    ks  = 10 000 [kN/ m3] 

Ground water depth under the surface   Gw  = 1  [m] 

 

 
Figure 2.12 "Soil Properties" form 
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4.5 Shell properties 

To define the annular plate properties, choose "Shell Properties" command from “Data” Tab.  

The following window in Figure 2.13 appears with default shell properties. The data of shell 

properties for the current example, which are required to be defined, are element groups and 

unit weight of the plate. Any other data corresponding to the shell properties in the program menus 

are not required for this example. 

 

 
Figure 2.13 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 2.14 

appears. In this list box, enter E-Modulus, Poisson’s ratio and slab thickness, the thickness of the 

inner ring is eliminated by defining its slab thickness by zero. Then click "OK" button. 
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Figure 2.14 "Defining element groups" list box 

Choose "Group Regions" command from "In table" menu. The following list box in Figure 2.15 

appears. As the inner radius is a = 2.5m, and the elements of the plate differ in thickness,  

Edit the "Group no" value for each element as the following. Then click "OK" button. 

 

 
Figure 2.15 "Group Regions" Form 
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To enter the unit weight of the plate, choose "Unit weight" command from "Shell Properties" menu 

in the window of Figure 2.13. The following dialog box in Figure 2.16 with a default unit weight 

of 25 [kN/m3] appears. Type 800 in the "Unit weight" edit box, note that the unit weight of the plate 

material is used to determine the uniform load q [kN/m2] on the annular area, which is equal to γb × d. 

Click "OK" button. 

 

 
Figure 2.16 "Unit weight" dialog box 

Now the shell properties have been entered and the sector of the plate appears as follows in Figure 2.17. 

 

 
Figure 2.17 "Shell Properties" Window 

After entering the shell properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 2.17 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 2.17 to close the "Shell Properties" 

window and return to ELPLA main window 
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4.6 Supports/ boundary conditions 

To define supports choose "Supports/ Boundary Conditions" command from “Data” Tab.  

The following Tab in Figure 2.18 appears. 

 

 
Figure 2.18 "Supports/ Boundary Conditions" Window 

To define the supports 

- Choose "Select Nodes" command from "Graphically" menu in Figure 2.18. When "Select 

Nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on nodes that have supports as shown in Figure 2.19 

- After selecting nodes of supports, choose "Add Supports/ Boundary Conditions" command 

from "Graphically" menu (Figure 2.18). The "Supports/ Boundary Conditions" dialog box  

in Figure 2.20 appears 
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Figure 2.19 Selection of nodes that have supports 

In this dialog box 

 

- Type 0 in the "Displacement w" edit box to define the vertical supports, as the annular plate 

is prevented from moving in the vertical direction at its ends 

- Click "OK" button 

 

 
Figure 2.20 "Supports/ Boundary Conditions" dialog box 
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Figure 2.21 Supports on the screen 

After entering supports, do the following two steps 

 

- Choose "Save " command from "File" menu in Figure 2.21 to save the data of supports 

- Choose "Close" command from "File" menu in Figure 2.21 to close the "Supports/ Boundary 

conditions" window and return to the main window 
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4.7 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following Window  
in Figure 2.22 appears. In ELPLA, entering loads may be carried out either numerically (in a table) 
or graphically using the commands of "Loads" Tab in Figure 2.22. For this example, there is not 
applied load, as the load has been already defined by the unit weight of the plate. 
 

 
Figure 2.22 "Loads" Window 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 2.22 to save the load data 

- Choose "Close" command from "File" menu in Figure 2.22 to close the "Loads" window 

and return to ELPLA main window  

 

 

Creating the project of the plate is now complete. It is time to analyze this project. In the next 

section, you will learn how to use ELPLA for analyzing projects. 
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5 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 2.23. 

 

 
Figure 2.23 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Determining the modulus of subgrade reaction 

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (band matrix) 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

Carrying out all computations 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab Window.  

 

Analysis progress 

 

Analysis progress menu in Figure 2.24 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. In addition, a status bar down of the 

"Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 2.24 Analysis progress menu 
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Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 2.25. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 2.25 Menu "Check of the solution" 

Ignore the elimination of the negative contact pressure which appears at the inner ring. 

 
Figure 2.26 Menu "Check of the solution" 

Click "OK" button to finish analyzing the problem. 
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6 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through the 

"Results" Tab. To view the data and results of a problem that has already been defined and analyzed 

graphically, switch to "Results" Tab (Figure 2.27).  

 

 
Figure 2.27 "Results" Tab 

The "Result" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Support reactions 

- Rotational shell results 

- Sections in shell wall 

- Sections in shell base 

- Display tables of data 

- Display tables of results 

 

To view the meridional moments in the shell base  

 

- Choose "Sections in shell base" command from "Section" menu. The following option box 

in Figure 2.28 appears 

- In the "Sections in shell base" option box, select "Meridional moments My" as an example 

for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 2.29. 

 

 
Figure 2.28 "Sections in shell base" option box 
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Figure 2.29 Meridional moments in shell base 

To view element groups of the plate 

 

- Choose "Element groups" from "In Plan" command in "Data" menu. The following option 

box in Figure 2.30 appears 

- In the "Data – In Plan" option box, select "Element groups" as an example for the results  

to be displayed 

- Click "OK" button 

 

 
Figure 2.30 "Data – In Plan" option box 
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To draw the thickness of the annular plate  

 

- Choose "Plot Parameters" command from "Setting" Tab. The "Plot Parameters" dialog box 

in Figure 2.31 appears 

- In the "FE-Net" Tab, check the "Draw girder thickness" check box in the "Rotational shell 

system" dialog box 

- Click "OK" button 

 

 
Figure 2.31 "Plot Parameters" dialog box 

To view the reactions of the supports on the FE-Net and any other data 

 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command.  

The "View Grouping" check group box in Figure 2.32 appears 

- In this check group box, check "Supports /Boundary Conditions" and "Supports Reactions RV" 

check boxes 

- The user can choose any other data to be displayed 

- Click "OK" button 
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Figure 2.32 "View Grouping" check group box 

 
Figure 2.33 Element groups of the annular plate 

 

 

 

 

 

 

 

 

 

 

 

 

 


