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1 Description of the problem 

An example of an axi-symmetrically container with irregular shape resting on a layered soil is 

selected to illustrate some features of ELPLA for analyzing shell elements. 

2 Container geometry and properties 

A container having a base radius of a = 5 [m], middle wall radius of Rm = 7 [m] and a height of  

H = 14 [m] is considered as shown in Figure 12.1. Thicknesses of the container base, wall and roof are 

tb = 0.4 [m], tw = 0.3 [m], tr = 0.2 [m], respectively. The container is filled with water and rests on 

layered soil. The container material and unit weight of the water are listed in Table 12.1. 

 
Figure 12.1 Irregular container with dimensions 

 

Rm = 7.00 [m] 

Ec = 2×107 [kN/ m2] 

νc = 0.20    [-] 

γc = 25       [kN/ m3] 

γw = 9.81    [kN/ m3] 

a = 5 [m] 

H
 =

 1
4
 [

m
] 
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Table 12.1 Container material and water unit weight  

Modulus of Elasticity      Ec = 2×107 [kN/ m2] 

Poisson's ratio       νc = 0.2            [-] 

Unit weight of the container material                          γc = 25  [kN/ m3] 

Unit weight of the water     γw  = 10  [kN/ m3] 

 

The geometry and parameters of the container are: 

 

Base: 

- Base radius     Rb = 5 [m] 

- Base thickness    tb = 0.4 [m] 

Wall: 

- Wall thickness    tw = 0.3 [m] 

- The first main segment parameters are: 

• Height    Hw = 10 [m] 

• Middle radius   Rm = 7 [m] 

• Upper radius    Ro = 5 [m] 

• Number of subsegments  Ns = 30 

- The second main segment parameters are: 

• Height    Hw = 4 [m] 

• Middle radius   Rm = 5 [m] 

• Upper radius    Ro = 5 [m] 

• Number of subsegments  Ns = 20 

Roof: 

- Flat roof type 

- Number of subsegments  Ns = 15 

- Roof thickness   tr = 0.2 [m] 

2.1 Soil properties 

The subsoil under the container consists of two layers, sandy clay and sand with gravel. 

 

The soil properties of the sandy clay layer are: 

Modulus of elasticity for loading E  = 35000  [kN/m2] 

Modulus of elasticity for reloading W  = 105000  [kN/m2] 

Poisson's ratio  νs = 0.3  [-] 

 

while those of the sand with gravel layer are: 

Modulus of elasticity for loading E  = 80000         [kN/m2] 

Modulus of elasticity for reloading W  = 240000        [kN/m2] 

Poisson's ratio 

 

 

νs = 0.3     [-] 
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2.2 Numerical Analysis 

In the analysis, the wall height of the container is divided into two main segments, the first one is 

divided into 30 subsegments (30×0.3 [m]), while the second is divided into 20 subsegments (20×0.2 [m]). 

The flat roof is divided into 15 subsegments. The raft foundation is divided into 10 circular intervals 

as shown in Figure 12.2.  

 

pt=0.2[m]

pt=0.3[m]

pt=0.4[m]

 
Figure 12.2 Finite element mesh of the container with a sector from the base 
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3 Creating the project 

In this section, the user will learn how to create a project for analyzing a container resting on  

a layered soil. The project will be processed gradually to show the possibilities and abilities of the 

program. To enter the data of the example, follow the instructions and steps in the next paragraphs. 

3.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 12.3. This wizard will help the user to define the analysis type  

and the calculation method of the problem through a series of Forms. The first Form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 12.3). 

 

 
Figure 12.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 12.3, define the analysis type of the problem. As the analysis 

type is a container resting on layered soil problem, select "Analysis of rotational shell" button,  

and check "Shell with a raft foundation" option, then click "Next" button to go to the next Form. 

After clicking "Next" button, the "Calculation Methods" Form appears, Figure 12.4. 
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To define the calculation method: 

 

- Select the calculation method "7-Modulus of Compressibility (Elimination)" 

- Click "Next" button to go to the next Form 

 

 
Figure 12.4 "Calculation Methods" Form 

The last Form in the wizard is the "Options" Form, Figure 12.5. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Since no option will be considered in the analysis, click the "Save" button. 

 

 

 



Analyzing Axisymmetric Structures and Tanks by ELPLA 

 
 

 -12.8- 

 
Figure 12.5 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 12.6. In this dialog box 

type a file name for the current project in "File name" edit box. For example, type "Container on 

layered soil". ELPLA will use automatically this file name in all reading and writing processes. 
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Figure 12.6 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project  

[Container on layered soil] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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3.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely 

entered. To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 12.7 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a container resting on different soil layers" 

- Type the date of the project in the "Date" edit box 

- Type the word "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 12.7 "Project Identification" dialog box 
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3.3 FE-Net data 

For the given problem, the container has a base radius of a = 5 [m], and a height of H = 14 [m].  

The height of the container is divided into two main segments, the first one is divided  

into 30 subsegments (30×0.3 [m]), while the second is divided into 20 subsegments (20×0.2 [m]), 

and the roof segment is divided into 15 subsegments. ELPLA has different procedures for defining 

the FE-Net. To define the FE-Net for this container, choose "FE-Net Data" command from the 

“Data” Tab. "Analysis of rotational shell" wizard appears as shown in Figure 12.8. This wizard will 

guide you through the steps required to generate a FE-Net. As shown in Figure 12.8, the first Form 

of the wizard is the "Shell type" Form, which contains a group of templates of different shapes  

of shells. These net templates are used to generate standard nets. 

 

 
Figure 12.8 "Analysis of rotational shell" wizard with "Shell type" Form 
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To generate the FE-Net of the container which has an irregular wall shape: 

 

- In the "Shell type" options choose "Irregular shell" button 

To define the base of the container: 

• Type 5 in the "Tank base radius Rb" edit box 

  To define the first segment of the height of the container: 

• Choose "Curved segments" option 

• Type 10 in the "height Hw" edit box  

• Type 7 in the "middle radius Rm" edit box  

• Type 15 in the "Upper radius Ro" edit box, as the upper radius is the same as  

the base radius 

• Type 30 in the "Number of segments Ns" edit box 

 

 

To define the second segment of the height of the container: 

• Type 4 in the "height Hw" edit box  

• Type 5 in the "middle radius Rm" edit box  

• Type 5 in the "Upper radius Ro" edit box, as the upper radius is the same  

as the base radius 

• Type 20 in the "Number of segments Ns" edit box 

To define the roof of the container: 

• Check the "Shell with covered roof" check box 

• Choose "Flat roof" option 

• Type 15 in the "Number of roof segments" edit box 

- Click "Next" button to go to the next Form 
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After clicking "Next" in "Analysis of rotational shell" wizard, the following "Irregular shell" Form 

containing the data of the segments appears in Figure 12.9, the user can edit the data of each 

segment individually or all of them by using "In Table" button, if it is necessary.  

Click "Next" button to go to the next Form. 

 

 
Figure 12.9 "Irregular shell" Form 
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The next Form of the "Analysis of rotational shell" wizard is the "Net of Base" Form Figure 12.10.  

In this Form, the default values of the grid intervals appear, to edit the grid spacing in x-direction of the 

base, do the following steps in "Grid in x-direction" frame: 

 

- Choose "Constant ring area" check box  

- Type 10 in the "No. of grid intervals" 

- Click "Finish" button to return to "FE-Net Data" window 

 

 
Figure 12.10 "Net of Base" Form 
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ELPLA will generate the FE-Net of the container with a sector from the base with 10 circular 

intervals. The following window in Figure 12.11 appears with the generated net. 

 
Figure 12.11 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 12.11 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 12.11 to close the "FE-Net" window 

and return to ELPLA main window 
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3.4 Soil Properties 

In ELPLA, there are three different soil models with several calculation methods. Therefore,  

the soil properties for each method are required to be defined according to the used soil model.  

In the current example, the soil model, which is used in the analysis, is "Layered Soil Model".  

This model requires that the subsoil have to be defined by boring logs. In the example, the boring 

log has multi-layers with different soil materials. The geotechnical data for each layer is unit weight 

of the soil γs and modulus of Elasticity for loading E and reloading W and Poisson's ratio νs. 

 

To define the soil properties, choose "Soil Properties" command from “Data” Tab. The following 

"Soil Properties" Window in Figure 12.12 appears with a default-boring log. 

 

 
Figure 12.12 "Soil Properties" window with a default-boring log 

In Figure 12.12, soil properties are defined through the "Data" menu, which contains  

the following two commands: 

 

- "Soil Data" command defines the individual boring logs 

- "Main Soil Data" command defines the general data for all soil layers 

 

To enter the soil properties for the boring log of the current example 

 

- Choose "Soil Data" command from "Data" menu in the window of Figure 12.12 

The following dialog box in Figure 12.13 with default-boring log data appears,  

Define the data of the boring log as the following  
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Figure 12.13 "Soil data" dialog box  

In the "Geotechnical data of the layer" dialog group box in Figure 12.13, Soil properties are defined 

by Modulus of elasticity, define the geotechnical data of the first soil layer of the boring log  

as follows: 

  

E   = 35000  [kN/m2] 

W   = 105000 [kN/m2] 

Gam  = 18   [kN/m3] 

C  = 10   [kN/m2] 

φ = 20   [º] 

 

In order to draw the soil layers by different symbols according to the German Standard DIN 4023, 

the soil type and color for each layer must be defined. 

 

To define the soil type and color for the first layer, select "T, Clay" as the soil type in "Main soil type 1" 

combo box, and "S, Sand" as the submain soil type in "Submain soil 1" combo box in "Soil and rock 

symbols" dialog group box in Figure 12.13. The color of the layer according to the German 

Standard DIN 4023 will be automatically created. The user can change this color.  
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To enter the second layer of the boring log 

 

- Click "Copy Layer" button in Figure 12.13. A layer with the same properties of the first layer 

will be copied 

- Use the vertical scrollbar to move to the second soil layer. Layer No. will be typed 

automatically at the upper-left corner of the main dialog box of soil layers as a head title 

- In "Geotechnical data of the layer" dialog group box in Figure 12.13, define the geotechnical 

data of the sand with gravel layer as follows: 

• E   = 80000  [kN/m2] 

• W   = 240000 [kN/m2] 

• Gam  = 18   [kN/m3] 

• C  = 0   [kN/m2] 

• φ = 35   [º] 

- Change the value of the layer depth under the ground surface from 4.5 [m] to 19.8 [m] 

- From "Soil and rock symbols" dialog group box, choose "S, Sand" and "G, Gravel" in 

"Main soil type 1" and "Main soil type 2" combo boxes, as the main soil type of the second 

layer is sand with gravel   

 

Note that: as the analysis is nonlinear, the unit weight of the soil, cohesion and angle of internal 

friction play no roles in the analysis.  
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Now all data and parameters for the boring log (Figure 12.14) have been entered.  

 

 
Figure 12.14 boring log 

To enter the main soil data for all layers, choose "Main Soil Data" command from "Data" menu 

in Figure 12.12. The following dialog box in Figure 12.15 appears with default main soil data.  

The main soil data for the current example, which are required to be defined, are the settlement 

reduction factor α [-] and the groundwater depth under the ground surface Gw [m]. Any other data 

corresponding to main soil data are not required in this example. Therefore, the user can take these 

data from the default soil properties. 

 

In the dialog box of Figure 12.15, enter the settlement reduction factor α [-] and the groundwater 

depth under the ground surface Gw [m]. Then click "OK" button. 
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Figure 12.15 "Main Soil Data" dialog box 
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Figure 12.16 "Calculation parameters of flexibility coefficients" dialog box 

After entering all data and parameters of the boring log, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 12.12 to save the data of boring log 

- Choose "Close" command from "File" menu in Figure 12.12 to close "Soil properties 

window and return to ELPLA main window. 
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3.5 Shell properties 

To define the container properties, choose "Shell Properties" command from “Data” Tab.  

The following window in Figure 12.17 appears with default shell properties. The data of shell 

properties for the current example, which is required to be defined, are element groups,  

group regions, the unit weight of the container, and the filled material properties. Any other data 

corresponding to shell properties in the program menus are not required for this example.  

 

 
Figure 12.17 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 12.18 

appears. In this list box, enter E-Modulus, Poisson’s ratio and slab thickness for the container base, 

wall and roof as they differ in thickness. Then click "OK" button to go to the next step. 
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Figure 12.18 "Defining element groups" list box 

Defining the slab thickness for materials on the net may be carried out either graphically or numerically 

(in a table). In the current example, the user will define the slab thickness on the net graphically. 

 

To define the slab thickness for the container roof  

 

- Choose "Select Elements" command from "Graphically" menu in the window  

of Figure 12.17.  

- When "Select Elements" command is chosen, the cursor will change from an arrow to  

a cross hair. A group of elements can be selected by holding the left mouse button down at 

the corner of the region. Then, drag the mouse until a rectangle encompasses  

the required group of elements. When the left mouse button is released,  

all elements in the rectangle are selected 

- Select the elements that include the container roof as Figure 12.19 

- Choose "Elements Groups" command from "Graphically" menu in the window  

of Figure 12.17, "Group Regions" dialog box Figure 12.20 appears 

- Define the "Group No." of the roof elements as type "3" 

- Repeat the previous steps to define the "Group No." of the container wall as type "2",  

while "Group No." of the wall elements will be as type "1", where type "1" is the  

default "Group No.", then click "OK" button 
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Figure 12.19 Selecting the elements that include the container roof 

 
Figure 12.20 "Group Regions" dialog box 

To enter the unit weight of the container, choose "Unit weight" command from "Shell Properties" 

menu in the window of Figure 12.17. The following dialog box in Figure 12.21 with a default unit 

weight of 25 [kN/m3] appears. Click "OK" button. 

 

 
Figure 12.21 "Unit weight" dialog box 
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To define the filled material properties of the container, choose "Filled material type/Element size" 

command from "Shell Properties" menu in Figure 12.17. The following form in Figure 12.22 

appears. 

 

 
Figure 12.22 "Filled material type/Element size" Form 

To define the filled material properties of the container: 

 

- Select "Liquid container" option 

- Type 14 in the "Height of the liquid" edit box 

- Type 9.81 in the "Unit weight of the liquid" edit box 

 

To define the element size of the container: 

 

- Check the "Constant element sizes in z-direction" check box 

- Type 1 in the "Element size in each shell segment" edit box. The element size is chosen  

to be 1 [m] larger than the segment size in order to ignore further subdivision of the 

segments into smaller elements. In some cases, it is necessary to divide the segment into 

smaller elements in order to make the analysis more precise. Nevertheless, the final results 

of the internal forces appear only at nodes of segments 

- Click "OK" button 
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Figure 12.23 "Shell Properties" window after defining the container properties 

After entering the shell properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 12.23 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 12.23 to close the "Shell 

properties" window and return to ELPLA main window 
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3.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 12.24 appears. 
 
In ELPLA, entering loads may be carried out either numerically (in a table) or graphically using the 
commands of "Loads" Tab in Figure 12.24. In this example, there is not applied load, as the load has 
been already defined by the unit weight of the container material, while the hydrostatic pressure on 
the container is defined by the unit weight of water. 
 

 
Figure 12.24 "Loads" Window 

Do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 12.24 to save the load data 

- Choose "Close" command from "File" menu in Figure 12.24 to close the "Loads" Window 

and return to ELPLA main window  

 

Creating the project is now complete. It is time to analyze this project. In the next section, you will 

learn how to use ELPLA for analyzing projects. 
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4 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 12.25. 

 

 
Figure 12.25 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Determining flexibility coefficients of the soil 

- Assembling the soil stiffness matrix 

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (unsymmetrical matrix) 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

Carrying out all computations 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab window.  

- The progress of all computations according to the defined method will be carried out 

automatically with displaying information through menus and messages. 
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Analysis progress 

 

Analysis progress menu in Figure 12.26 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. In addition, a status bar down of the 

"Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 12.26 Analysis progress menu 

Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 12.27. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 12.27 Menu "Check of the solution" 

Click "OK" button to finish analyzing the problem. 
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5 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through the 

"Results" Tab. To view the data and results of a problem that has already been defined and analyzed 

graphically, switch to "Results" Tab (Figure 12.28).  

 

 
Figure 12.28 "Results" Tab 

The "Result" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Rotational shell results 

- Boring logs and limit depth 

- Sections in the shell wall 

- Sections in the shell base 

- Display tables of data 

- Display tables of results 

 

To view sections in shell base 

 

- Choose "Sections in shell base" command from "Section" menu. The following option box 

in Figure 12.29 appears 

- In the "Sections in shell base" option box, select "Base contact pressures q" as an example 

for the results to be displayed 

- Click "OK" button 

 

The base contact pressures are now displayed as shown in Figure 12.30. 

 

 
Figure 12.29 "Sections in shell base" option box 
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Figure 12.30 Base contact pressures in shell base 

To view the base settlements  

 

- Choose "Sections in shell base" command from "Section" menu. The following option box 

in Figure 12.31 appears 

- In the "Sections in shell base" option box, select "Base settlements w" as an example for the 

results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 12.32. 

 

 
Figure 12.31 "Sections in shell base" option box 
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Figure 12.32 Base settlements  

To view element groups of the container 

 

- Choose "Element groups" from "In Plan" command in "Data" menu. The following option 

box in Figure 12.33 appears 

- In the "Data – In Plan" option box, select "Element groups" as an example for the results  

to be displayed 

- Click "OK" button 

 

 
Figure 12.33 "Data – In Plan" option box 
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To view the internal forces on the FE-Net and any other data 

 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command.  

The "View Grouping" check group box in Figure 12.34 appears 

- In this check group box, the user can choose any data to be viewed  

- Click "OK" button 

 

 
Figure 12.34 "View Grouping" check group box 

 
Figure 12.35 Element groups of the container 

 

 

 

 

 


