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Analysis of a chimney
with a hyperbolic shell wall
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1

Description of the problem

An example of an axi-symmetrically chimney with hyperbolic shell wall under a uniform external
pressure is selected to illustrate some features of ELPLA for analyzing shell elements.
2

Chimney geometry and properties

Consider a hyperbolic shell of revolution with the following geometry:
Throat radius
Throat height
Lower radius
Total height
Thickness of the wall

Ro
Hl
Ru
H
t

= 18
= 45
= 36
= 72
=0.24

[m]
[m]
[m]
[m]
[m]

Meridian equation of the hyperbolic shell of revolution is given by:
r 2 (ξ ) =

Ru2 − Ro2
(ξ - H l )2 + Ro2
H l2

36 2 − 182
(ξ - 45)2 + 182
2
45
2
2
r (ξ ) = 0.48(ξ - 45) + 324
r 2 (ξ ) =

where r [m] is the radius at height ξ [m].
Figure 11.1 shows the geometry the chimney with its hyperbolic shell wall with dimensions and
supports, while the shell material are listed in Table 11.1.
Table 11.1 hyperboloid shell material
Modulus of Elasticity of the chimney material
Poisson's ratio of the chimney material

Ec
νc

= 3×107
= 0.3

[kN/m2]
[-]
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51.92 [m]

2Ro = 36 [m]

Hl = 45 [m]

H = 72 [m]

0.24 [m]

Ec
νc
γw

= 3×107 [kN/ m2]
= 0.17 [-]
= 10 [kN/ m3]
ξ
r

Figure 11.1

-11.4-

2Ru = 72 [m]
Geometry of the chimney with dimensions and supports
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3

Numerical Analysis

In the analysis, the height of the chimney is divided into 7 main segments; each segment is divided
into a number of elements. Segment dimensions and number of elements of each segment are shown
in Figure 11.2.

ξ
Height H

Segment No.

No. of elements

Radius R
25.960 [m]

9 [m]

1

18
21.898 [m]

9 [m]

2

12
19.049 [m]

9 [m]

3

12
18.000 [m]

9 [m]
12 [m]

4

12

5

12

19.049 [m]
23.145 [m]

12 [m]

6

12
29.098 [m]

12 [m]

7

12
r

Figure 11.2

36.000 [m]

Segment dimensions and no. of elements in each segment
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The chimney is exposed to a uniform external pressure of ps = -10 [kN/m2] as shown in Figure 11.3

ps = -10 [kN/m2]

Figure 11.3
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chimney with uniform external pressure of ps = -10 [kN/m2]
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4

Creating the project

In this section, the user will learn how to create a project for analyzing a chimney with hyperbolic
shell wall under a uniform external pressure. The project will be processed gradually to show the
possibilities and abilities of the program. To enter the data of the example, follow the instructions
and steps in the next paragraphs.
4.1

Calculation method

Choose "New Project" command from the "File" menu. The following "Calculation Methods"
wizard appears, Figure 11.4. This wizard will help the user to define the analysis type
and the calculation method of the problem through a series of forms. The first form of "Calculation
Methods" wizard is the "Analysis Type" Form (Figure 11.4).

Figure 11.4

"Analysis Type" Form

In the "Analysis Type" Form in Figure 11.4, define the analysis type of the problem.
As the analysis type is a hyperbolic shell problem, select "Analysis of rotational Shell" button, and
check "Shell with an opening base" option, then click "Next" button to go to the next Form.
After clicking "Next" button, the "Options" Form appears, Figure 11.5.
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The last Form in the wizard is the "Options" Form, Figure 11.5. In this Form, ELPLA displays some
available options corresponding to the chosen numerical model, which differ from model to other.
Select "Supports/ Boundary Conditions", then click the "Save" button.

Figure 11.5

"Options" Form

After clicking "Save" button, the "Save as" dialog box appears, Figure 11.6. In this dialog box
type a file name for the current project in "File name" edit box. For example,
type "Hyperbolic Chimney". ELPLA will use automatically this file name in all reading and writing
processes.
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Figure 11.6

"Save as" dialog box

ELPLA will activate the “Data” Tab. In addition, the file name of the current project
[Hyperbolic Chimney] will be displayed instead of the word [Untitled] in the ELPLA title bar.

-11.9-

Analyzing Axisymmetric Structures and Tanks by ELPLA

4.2

Project identification

The user can enter three lines of texts to describe the problem and the basic information about the task.
These texts are required only for printing and plotting the data and results. Project identification
does not play any role in the analysis. The three lines are optionally and maybe not completely
entered. To identify the project, choose "Project Identification" command from the “Data” Tab.
The dialog box in Figure 11.7 appears.
In this dialog box
-

-

Type the following line to describe the problem in the "Title" edit box:
"Analysis of a chimney with hyperbolic shell wall"
Type the date of the project in the "Date" edit box
Type the word "Axisymmetric Structures and Tanks" in the "Project" edit box
Click "Save" button

Figure 11.7
4.3

"Project Identification" dialog box

FE-Net data

For the given problem, the chimney has a lower radius of Ru = 36 [m] and a total height of H = 72 [m].
the wall height is divided into 7 main segments, each segment is divided into a number of elements.
To define the FE-Net for this tank, choose "FE-Net Data" command from the “Data” Tab.
"Analysis of rotational shell" wizard appears as shown in Figure 11.8. This wizard will guide you
through the steps required to generate a FE-Net. As shown in Figure 11.8, the first Form of the
wizard is the "Shell type" Form, which contains a group of templates of different shapes of nets.
These net templates are used to generate standard nets.
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Figure 11.8

"Analysis of rotational shell" wizard with "Shell type" Form

To generate the FE-Net
-

In the "Shell type" options choose "Hyperbolic shell" button
Type 18 in the "Throat radius" edit box
Type 72 in the "Total height" edit box
Type 36 in the "Lower radius" edit box
Type 45 in the "Throat height" edit box
Type 7 in the "Number of segments" edit box
Click "Next" button to go to the next Form
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After clicking "Next" in "Analysis of rotational shell" wizard, the following "Hyperbolic shell"
Form appears Figure 11.9, ELPLA divides the height of the chimney wall into 7 equal segments,
The user can edit the data of the segments individually by using "Modify" button, or all of them
using "In Table" button.

Figure 11.9
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"Hyperbolic shell" Form
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Figure 11.10 "Segment data" Table
After modifying the coordinates of the segments, click "Finish" button, the FE-Net of the chimney
appears in Figure 11.11
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Figure 11.11 Generated FE-Net
After finishing the generation of the FE-Net, do the following two steps:
-
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Choose "Save" command from "File" menu in Figure 11.11 to save the data of the FE-Net
Choose "Close" command from "File" menu in Figure 11.11 to close the "FE-Net" window
and return to ELPLA main window
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4.4

Shell properties

To define the chimney properties, choose "Shell Properties" command from “Data” Tab.
The following window in Figure 11.12 appears with default shell properties. The data of shell
properties for the current example, which are required to be defined, are element groups, unit weight
of the chimney, and element size.

Figure 11.12 "Shell Properties" Window
Choose "Element groups" command from "In table" menu. The following list box in Figure 11.13
appears. In this list box, enter E-Modulus, Poisson’s ratio and slab thickness. Then click "OK" button.
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Figure 11.13 "Defining element groups" list box
To enter the unit weight of the chimney, choose "Unit weight" command from "Shell Properties"
menu in Figure 11.12. The following dialog box in Figure 11.14 with a default unit weight
of 25 [kN/m3] appears, type 0 in the "Unit weight" edit box to neglect the self-weight of the chimney,
then click "OK" button.

Figure 11.14 "Unit weight" dialog box
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To define the element size of the chimney, choose "Filled material type/Element size" command
from "Shell Properties" menu in Figure 11.12. The following form in Figure 11.15 appears, then:
-

-

Select "Empty container" option
uncheck the "Constant element sizes in z-direction" check box
Click "Element size in each segment" button, the following list box in Figure 11.16 appears
Define the size of the element in each segment as in the following list box in Figure 11.16,
to keep the same number of elements in each segment
Click "OK" button

Figure 11.15 "Filled material type/Element size" Form
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Figure 11.16 "Element size in each segment" list box
After defining the chimney properties, do the following two steps:
-
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Choose "Save" command from "File" menu in Figure 11.12 to save the shell properties
Choose "Close" command from "File" menu in Figure 11.12 to close the "Shell properties"
window and return to ELPLA main window
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4.5

Supports/ Boundary Conditions

To define the hinged support, choose "Supports/ Boundary Conditions" command from “Data” Tab.
The following window in Figure 11.17 appears.

Figure 11.17 "Supports/ Boundary Conditions" Window
To define the support on the net:
-

-

Choose "Select Nodes" command from "Graphically" menu in Figure 11.17. When "Select
Nodes" command is chosen, the cursor will change from an arrow to a cross hair
Click the left mouse button on the node that has the support as shown in Figure 11.18
After selecting the node, choose "Add Supports/ Boundary Conditions" command
from "Graphically" menu (Figure 11.17). The "Supports/ Boundary Conditions" dialog box
in Figure 11.19 appears.
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Figure 11.18 Selection of the node that has a hinged support
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In this dialog box
-

Type 0 in the "Displacement u" edit box to define the horizontal fixed support
Type 0 in the "Displacement w" edit box to define the vertical fixed support
Click "OK" button

Figure 11.19 "Supports/ Boundary Conditions" dialog box
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Figure 11.20 Supports on the screen
After defining the supports, do the following two steps
-
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Choose "Save " command from "File" menu in Figure 11.17 to save the data of supports
Choose "Close" command from "File" menu in Figure 11.17 to close the "Supports/
Boundary conditions" window and return to the main window.
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4.6

Loads

To define the loads, choose "Loads" command from “Data” Tab. The following window
in Figure 11.21 appears.
In ELPLA, entering loads may be carried out either numerically (in a table) or graphically using
the commands of "Loads" Tab in Figure 11.21. In this example, the hyperbolic chimney is exposed
to a uniform external pressure of ps = -10 [kN/m2].

Figure 11.21 "Loads" Window
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To define the uniform distributed load:
-

-

choose "Edit Member Load" command from "Graphically" menu in Figure 11.21. When "Edit
Member Load" command is chosen, the cursor will change from an arrow to a cross hair
Double click on the element which is exposed to the uniform distributed load
"Edit Member Load" dialog box in Figure 11.22 appears, type "-10" in "Member loads" edit box
Click "OK" button

Figure 11.22 "Edit Member Load" dialog box
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Figure 11.23 "Loads" window after defining the uniform distributed load
After finishing the definition of load data, do the following two steps:
-

Choose "Save" command from "File" menu in Figure 11.21 to save the load data
Choose "Close" command from "File" menu in Figure 11.21 to close the "Loads" window
and return to ELPLA main window.

Creating the project of the chimney with a hyperbolic shell wall is now complete. It is time to
analyze this project. In the next section, you will learn how to use ELPLA for analyzing projects.
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5

Carrying out the calculations

To analyze the problem, switch to "Solver" Tab, Figure 11.24.

Figure 11.24 "Solver" Tab
ELPLA will active the "Individual Calculations" list, which contains commands of all calculations.
Commands of calculation depend on the used calculation method in the analysis. For this project,
the items that are required to be calculated are:
-

Assembling the load vector
Assembling the slab stiffness matrix
Solving the system of linear equations (band matrix)
Determining deformation, internal forces, contact pressures

These calculation items can be carried out individually or in one time
To carry out all computations in one time
-

Choose "Computation of all" command from "Solver" Tab window.

The progress of all computations according to the defined method will be carried out automatically
with displaying Information through menus and messages.
Analysis progress
Analysis progress menu in Figure 11.25 appears in which various phases of calculation
are progressively reported as the program analyzes the problem. In addition, a status bar down
of the "Solver" Tab window displays Information about the progress of calculation.

Figure 11.25 Analysis progress menu
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Check of the solution
Once the analysis is carried out, a check menu of the solution appears, Figure 11.26. This menu
compares between the values of actions and reactions. Through this comparative examination,
the user can assess the calculation accuracy.

Figure 11.26 Menu "Check of the solution"
Click "OK" button to finish analyzing the problem.
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6

Viewing data and results

ELPLA can display and print a wide variety of results in graphics, diagrams or tables
through the "Results" Tab. To view the data and results of a problem that has already been defined
and analyzed graphically, switch to "Results" Tab (Figure 11.27).

Figure 11.27 "Results" Tab
The "Results" Tab contains the commands of drawing. These commands depend on the used
calculation method in the analysis. For the current example, the commands for presenting the data
and results are:
-

Data in the plan
Rotational shell results
Supports reactions
Sections in shell wall
Display tables of data
Display tables of results

To view the radial forces in the shell wall
-

-

-

From "Rotational shell results" command in the "Results" menu, choose "In Plan" command.
The following option box in Figure 11.28 appears
In the "Distribution of Internal Forces" option box, select "Radial forces Nr" as an example
for the results to be displayed
Click "OK" button

The Results are now displayed as shown in Figure 11.29.

Figure 11.28 "Distribution of internal forces" option box

-11.28-

Example 11

Figure 11.29 Radial forces in shell wall
To view the vertical deformations of the chimney wall
-

-

-

From "Rotational shell results" command in the "Results" menu, choose "In Plan" command.
The following option box in Figure 11.30 appears
In the "Distribution of Internal Forces" option box, select "Vertical deformations Vv" as an
example for the results to be displayed
Click "OK" button

The Results are now displayed as shown in Figure 11.31.
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Figure 11.30 "Distribution of internal forces" option box

Figure 11.31 Vertical deformations of the chimney wall
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To view the slab thickness of the chimney
-

-

Choose "Slab thickness" from "In Plan" command in "Data" menu. The following option
box in Figure 11.32 appears
Click "OK" button

Figure 11.32 "Data – In Plan" option box
To view the supports / boundary conditions on the FE-Net and any other data
-

-

From "Options" menu in the "Graphic" tab, choose "View Grouping" command.
The "View Grouping" check group box in Figure 11.33 appears
In this check group box, check "Supports /Boundary Conditions" check box
The user can choose any other data to be viewed
Click "OK" button

Figure 11.33 "View Grouping" check group box
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Figure 11.34 Slab thickness with the load system
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