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1 Description of the problem 

An example of a loaded area resting on different soil layers is selected to illustrate some features  

of ELPLA for analyzing shell elements using circular and annular elements. 

2 Geometry and properties 

A circular loaded area of a radius a=5 [m] acting on three different soil layers as shown  

in Figure 1.1. 

 
Figure 1.1 Soil profile under the circular loaded area 

 

 

 

 

q=100 [kN/m 2 ] 

GW 

2.0 [m] 

Impervious layer (Rock) 

4.0 [m] 

c 

2.0 [m] 

Normally consolidated clay: 

Cc=0.0425  [-] 

eo=0.85   [-] 

γc2 =8.69 [kN/ m3] 

Soft clay: 

mv=2×10-4   [m2/kN] 

γc1 =8      [kN/ m3] 

Fine sand: 

Es=8000   [kN/m2] 

γs =17.5    [kN/ m3] 
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3 Creating the project 

In this section, the user will learn how to create a project for analyzing a circular loaded area resting 

on different soil layers. The project will be processed gradually to show the possibilities  

and abilities of the program. To enter the data of the example, follow the instructions and  

steps in the next paragraphs. 

3.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 1.2. This wizard will help the user to define the analysis type  

and the calculation method of the problem through a series of Forms. The first Form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 1.2). 

 

 
Figure 1.2 "Analysis Type" Form 

As the analysis type is a circular loaded area problem, select "Analysis of rotational shell" button, 

and check "Shell with a raft foundation" option, then click "Next" button to go to the next Form. 

After clicking "Next" button, the "Calculation Methods" Form appears, Figure 1.3. 
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To define the calculation method: 

 

- Select the calculation method "9-Flexible Foundation" 

- Select the subsoil model as "Layered soil model" 

- Click "Next" button to go to the next Form 

 

 
Figure 1.3 "Calculation Methods" Form 

The last Form in the wizard is the "Options" Form, Figure 1.4. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Since no option will be considered in the analysis, click the "Save" button. 
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Figure 1.4 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 1.5. In this dialog box 

type a file name for the current project in "File name" edit box. For example, type "Circular loaded area ". 

ELPLA will use automatically this file name in all reading and writing processes. 
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Figure 1.5 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project [Circular 

loaded area] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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3.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely 

entered. To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 1.6 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a circular loaded area resting on different soil layers" 

- Type the date of the project in the "Date" edit box 

- Type the word "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 1.6 "Project Identification" dialog box 
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3.3 FE-Net data 

For the given problem, the shell has a circular shape with a radius of a=5 [m] and is divided  

into 10 segments. ELPLA has different procedures for defining the FE-Net.  

 

To define the FE-Net for this shell, choose "FE-Net Data" command from the “Data” Tab. 

"Analysis of rotational shell" wizard appears as shown in Figure 1.7. This wizard will guide you 

through the steps required to generate a FE-Net. The first Form of the wizard is the "Shell type" 

Form, which contains a group of templates of different shapes of shells. These net templates are 

used to generate standard nets. 

 

 
Figure 1.7 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 

 

- In the "Shell type" options choose "Cylindrical shell" button 

- Type 0 in the "Height" edit box, as the example is a circular plate 

- Type 5 in the "Radius" edit box 

- Click "Next" button to go to the next Form 
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After clicking "Next" in "Analysis of rotational shell" wizard, the following "Net of Base" Form 

appears Figure 1.8.  

 

To edit the grid spacing in x-direction, do the following steps in "Grid in x-direction" frame: 

 

- Choose "Constant grid interval" check box 

- Type 10 in the "No. of grid intervals" edit box 

 

 
Figure 1.8 "Net of Base" Form 

ELPLA will generate a sector from the circular area with 10 circular elements. The following 

window in Figure 1.9 appears with the generated net. 
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Figure 1.9 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 1.9 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 1.9 to close the "FE-Net" window and 

return to ELPLA main window 
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3.4 Soil Properties 

In ELPLA, there are three different soil models with several calculation methods. Therefore,  

the soil properties for each method are required to be defined according to the used soil model.  

In the current example, the soil model, which is used in the analysis, is a "Layered Soil Model".  

This model requires that the subsoil have to be defined by boring logs. In the example, the boring 

log has multi-layers with different soil materials. The geotechnical data for each layer is unit weight 

of the soil γs and modulus of Elasticity for loading Es and reloading Ws or Compression index Cc 

and recompression index Cr. 

 

To define the soil properties, choose "Soil Properties" command from “Data” Tab. The following 

"Soil Properties" Window in Figure 1.10 appears with a default-boring log. 

 

 
Figure 1.10 "Soil Properties" window with a default-boring log 

In Figure 1.10, soil properties are defined through the "Data" menu, which contains  

the following two commands: 

 

- "Soil Data" command defines the individual boring logs 

- "Main Soil Data" command defines the general data for all soil layers 

 

To enter the soil properties for the boring log of the current example 

 

- Choose "Soil Data" command from "Data" menu in the window of Figure 1.10. 

The following dialog box in Figure 1.11 with default-boring log data appears 
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Figure 1.11 "Soil data" dialog box with default-boring log data 

In the "Geotechnical data of the layer" dialog group box in Figure 1.11, Soil properties are defined 

by Modulus of compressibility, define the geotechnical data of the first soil layer of the boring log 

as follows: 

  

Es   = 8 000  [kN/m2] 

Ws   = 8 000 [kN/m2] 

Gam  = 18   [kN/m3] 

C  = 10   [kN/m2] 

φ = 0   [º] 

 

Due to the presence of the ground water, the soil above the ground water level has a differential unit 

weight from the soil under that level. Therefore, the layer depth of the first layer is taken to be 2 [m], 

which is equal to the ground water level. Now, type this value in "Layer depth under the ground 

surface" edit box. 

 

In order to draw the soil layers by different symbols according to the German Standard DIN 4023, 

the soil type and color for each layer must be defined. 

 

To define the soil type and color for the first layer, select "fS, Fine sand" as the soil type in "Main soil 

type 1" combo box in "Soil and rock symbols" dialog group box in Figure 1.11. The color of the fine 

sand layer according to the German Standard DIN 4023 will be automatically created. The user can 

change this color. In addition, a short text "fS" will be automatically created for the fine sand. 
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To enter the second layer of the boring log 

 

- Click "Copy Layer" button in Figure 1.11. A layer that has the same properties of the first 

layer will be copied 

- Use the vertical scrollbar to move to the second soil layer. Layer No. will be typed 

automatically at the upper-left corner of the main dialog box of soil layers as a head title 

- Change the value of the unit weight of the soil for the second soil layer from 18 [kN/m3]  

to 8 [kN/m3] 

- Change the value "ES" and "Ws" from 8000 [kN/m2] to 5000 [kN/m2] 

- Change the value of the layer depth under the ground surface from 2 [m] to 4 [m] 

- From "Soil and rock symbols" dialog group box, Change "fS, Fine sand" into "T, Clay"  

as the soil type of the second layer is clay   

 

To enter the third layer 

 

- Click "Insert Layer" button in Figure 1.11, then a layer will be inserted 

- Use the vertical scrollbar to move to the third soil layer 

- In "Geotechnical data of the layer" dialog group box in Figure 1.11, Soil properties are 

defined by Compression Index Cc, define the geotechnical data of the clay layer as follows: 

  

Cc   = 0.04   

Cr   = 0.04  

 Gam  = 8   [kN/m3] 

Phi   = 30  [°] 

c   = 10  [kN/m2] 

eo   = 0.85    

 

 

- Select "T, Clay" as the soil type in "Main soil type 1" combo box in "Soil and rock symbols" 

dialog group box 

- Type 8 in the "Layer depth under the ground surface" edit box 

 

Note that the unit weight of the soil is used to determine the uniform load q [kN/m2] on the circular 

area, which is equal to γs × df.  
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Now all data and parameters for the boring log (Figure 1.12) have been entered.  

 

 
Figure 1.12 boring log 

To enter the main soil data for all layers, choose "Main Soil Data" command from "Data" menu 

in Figure 1.10. The following dialog box in Figure 1.13 appears with default main soil data.  

The main soil data for the current example, which are required to be defined, are the settlement 

reduction factor α [-] and the groundwater depth under the ground surface Gw [m]. Any other data 

corresponding to main soil data are not required for this example. Therefore, the user can use the 

default values. 

 

In the dialog box of Figure 1.13, enter the settlement reduction factor α [-] and the groundwater 

depth under the ground surface Gw [m]. Then click "OK" button. 
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Figure 1.13 "Main Soil Data" dialog box 

After entering all data and parameters of the boring log, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 1.10 to save the data of boring logs 

- Choose "Close" command from "File" menu in Figure 1.10 to close "Soil properties" 

window and return to ELPLA main window 
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3.5 Shell properties 

To define the shell properties, choose "Shell Properties" command from “Data” Tab.  

The following window in Figure 1.14 appears with default shell properties. The data of shell 

properties for the current example, which are required to be defined, are element groups, and the 

unit weight of the shell. Any other data corresponding to shell properties in the program menus are 

not required for this example.  

 

 
Figure 1.14 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 1.15 

appears. In this list box, enter E-Modulus, Poisson’s ratio and slab thickness. Then click "OK" 

button. 
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Figure 1.15 "Defining element groups" list box 

To enter the unit weight of the shell, choose "Unit weight" command from "Shell Properties" menu 

in the window of Figure 1.14. The following dialog box in Figure 1.16 with a default unit weight 

of 25 [kN/m3] appears. Type 400 in the "Unit weight" edit box, to define the uniform load on the 

circular area. Then click "OK" button. 

 

 
Figure 1.16 "Unit weight" dialog box 

After entering the Shell Properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 1.14 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 1.14 to close the "Shell 

Properties" window and return to ELPLA main window 
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3.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 1.17 appears. In ELPLA, entering loads may be carried out either numerically (in a table) 
or graphically using the commands of "Loads" Tab in Figure 1.17. In this example, there is not 
applied load, as the load has been already defined by the unit weight of the plate. 
 

 
Figure 1.17 "Loads" Window 

Do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 1.17 to save the load data 

- Choose "Close" command from "File" menu in Figure 1.17 to close the "Loads" window 

and return to ELPLA main window  

 

Creating the project is now complete. It is time to analyze this project. In the next section,  

you will learn how to use ELPLA for analyzing projects. 
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4 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 1.18. 

 

 
Figure 1.18 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Determining flexibility coefficients of the soil 

- Analysis of the flexible foundation 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

Carrying out all computations 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab window.  

- The progress of all computations according to the defined method will be carried out 

automatically with displaying Information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 1.19 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. In addition, a status bar down of the 

"Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 1.19 Analysis progress menu 
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Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 1.20. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 1.20 Menu "Check of the solution" 

Click "OK" button to finish analyzing the problem. 
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5 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through the 

"Results" Tab. 

5.1 Viewing data and result graphics 

To view the data and results of a problem that has already been defined and analyzed graphically, 

switch to "Results" Tab (Figure 1.21).  

 

 
Figure 1.21 "Results" Tab 

The "Result" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Boring logs and limit depth 

- Sections in the shell base 

 

To view sections in shell base 

 

- Choose "Sections in shell base" command from "Section" menu. The following option box 

in Figure 1.22 appears 

- In the "Sections in shell base" option box, select "Base settlements w" as an example for the 

results to be displayed 

- Click "OK" button 

 

The Settlements are now displayed as shown in Figure 1.23. 

 

 
Figure 1.22 "Sections in shell base" option box 
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Figure 1.23 Base settlements Sections in shell base 

5.2 Listing data and results in tables 

The "Result" Tab contains the commands of listing data and results. The commands for listing data 

and results in tables are: 

 

- Display tables of data 

- List tables of data through Text-

 Editor 

- Display tables of results 

- List tables of results through Text-

 Editor 

 

To list results in a table 

 

- Choose "Display tables of Results" command from "List" menu. The following option box  

in Figure 1.24 appears 

- In the "Display Tables of Results" option box, select "Settlements/Contact pressures"  

as an example for the result to be listed in a table 

- Click "OK" button. The loading results are now listed (Figure 1.25) 

- Choose "Send to Excel" from "Sending" menu if you wish to export the table to a MS Excel 

application, Figure 1.26 
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Figure 1.24 "Display Tables of Results" option box 

 
Figure 1.25 List of loading data 
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Figure 1.26 Exported data in MS Word 

 

 

 

 

 

 

 

 

 

 


