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1. Introduction 

This Tutorial Manual contains an overview of dealing with analyzing circular cylindrical shells 

structures. It is also considered, circular cylindrical tank resting on layered soil as one unit taking 

into account the soil-structure interaction effect. It describes the processes of modeling the 

problems, carrying out the analyses, viewing and printing the results. It provides the user skills, 

which he needs to use ELPLA. It also takes the user gradually through some simple examples. 

Carrying out these examples will help the user to become familiar with the most important functions 

of ELPLA for analyzing shell structures. Before attempting a real project with ELPLA,  

it is recommended that the user tries to carry out the given problems. 

 

This Tutorial Manual will not present the theoretical background of modeling the problems.  

For more information concerning the methods of analysis, a complete reference for calculation 

methods and numerical models is well documented in the books: 

 

1- Analysis of Axisymmetric Structures and Tanks by the Program ELPLA, 

Part I: Numerical models 

 

2- Analysis of Axisymmetric Structures and Tanks by the Program ELPLA, 

Part II: Verification Examples 

 

 

In addition, a complete reference for all menus and dialog boxes of the program is to be found in the 

User’s Guide or in the online help system. 

 

ELPLA General Features  

 

ELPLA general features are common features that may be repeated under different menus 

or command groups. They are listed in ELPLA user’s guide. Common features are similar 

those of Windows CAD and Rendering programs. If you are familiar with Windows CAD 

and Rendering programs, you can certainly get a head start from Tutorial Examples. 

2. Starting ELPLA 

After installing ELPLA, a new program group and program items will be created automatically for 

ELPLA in the Windows-Start-Menu. In addition, a program icon will be created on the Windows 

desktop. The usage of the program is typically such that first data files are created describing 

a certain problem through the "Data" Tab. Then the project problem is analyzed by calculation 

commands through "Solver" Tab. Finally, results can be presented as graphical drawings, graphs 

and tables through "Result" Tab. Names and short descriptions of the function of the main program 

Tabs are given in Table 1. 
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Table 1 Names and descriptions of ELPLA Tabs 

Tab name                     Description of the tab function 

"Data" Tab                             Editing project data 

 

"Solver" Tab                         Analyzing the project problem 

 

"Result" Tab                           Displaying data and results graphically, 

                                listing project data and calculated results, 

                          displaying results in diagrams at specified sections 

                           and displaying boring logs graphically 

 

"Setting" Tab                         Setting options, formats, main data of ELPLA 

 

"View" Tab                           Appearance or disappearance "Tree View" and "Status bar" 

 

Start the ELPLA by double clicking on its icon on the Windows desktop. After starting ELPLA  

for the first time, the window in Figure 1 appears. 

 

 
Figure 1 Main window of ELPLA 

In the following section, the user will find a brief description of some of the essential interface 

commands. This section will help the user to be familiar with some of the commands,  

which will be used in this Tutorial. 
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3. Toolbar Buttons and Keyboard Shortcuts 

Many of ELPLA commands can be accessed by clicking buttons on the toolbars, or by pressing 

shortcut keys on the keyboard. When you select a menu, the available toolbar buttons and keyboard 

shortcuts for that menu are shown next to their corresponding commands as shown in Figure 2.  

You can also directly see what command is associated with a toolbar button by holding the mouse 

cursor over the button. After a brief pause a legend (Screen Tip) will appear next to the cursor 

showing the menu command associated with the button. 

 

 
Figure 2 Available toolbar buttons and keyboard shortcuts for the file menu 
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Switching between individual tabs  

 

The program's tabs appear at the top of the program window. The user can go to a specific tab  

by clicking the name of that tab. The "Data" tab, which is used for entering the project data, appears 

in the upper left corner of this window. 

 

Mouse Cursor Modes 

 

ELPLA has two modes of mouse cursor operation in "Data" window: View mode and Edit mode. 

The program can only be in one mode at a time. By default, the program is in view mode  

and the mouse cursor is an arrow. For edit mode, the cursor will change from an arrow to a cross 

hair indicating the mode in which is being operated. Press "Esc" key to exit the edit mode and return 

to the view mode. 

 

Node Selection 

 

In edit mode, nodes are selected by clicking on each node individually or selecting a group of nodes. 

A group of nodes can be selected by holding the left mouse button down at the corner of the region. 

Then, dragging the mouse until a rectangle encompasses the desired group of nodes. When the left 

mouse button is released, all nodes in the rectangle are selected. 

 

Undo and Redo Commands 

 

ELPLA allows you to go back up to 12 steps at a time when defining project process. Therefore, 

it is possible to undo a series of actions previously performed. If you go too far in the undo process, 

you may redo those actions. You can undo/ redo most drawing, editing and assignment operations. 

To undo/ redo a certain action, choose the "Undo/ Redo" command from "Edit" menu. 

 

Snap Tools 

 

The snap tools are essentially a fast and accurate way to draw and edit objects. Snap tools find 

the closest snap location to your pointer as you move it over your model. The snap tools can be 

turned on and off as you draw, so you can snap to different locations for every point. More than one 

snap tool can also be set at the same time giving you a choice of snap locations. The snap options 

are set by the data located in the "Plot Parameters" dialog box under the "Options" menu  

in "Setting" Tab. 

 

Defining Data 

 

Most of ELPLA data can be defined either graphically or numerically (in tables). In this tutorial,  

the user will learn how to carry out the data using one method depending on the specified example. 

By completing the all examples, the user will learn to define most of the data both graphically  

and numerically. 
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Project identification 

 

The user can define three lines of texts to identify a project and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely 

entered. 

 

Reinforcement data 

 

The design code parameters such as partial safety factors for concrete strength, steel strength  

and internal stresses are defined by choosing the "Design code parameters" command from 

the "Main data" menu in "Setting" Tab.  

 

Reinforcement data such as design code, concrete grade, steel grade and concrete covers are defined 

by choosing the "Reinforcement" command from “Slab” menu in "Data" Tab. Design code 

parameters are standard data for all projects, while reinforcement data may be varied from project to 

another. 

 

Edit List Box 

 

Some ELPLA data are defined by list box dialog as shown in Figure 3. In this list box the "Insert", 

"Copy" and "Delete" commands are applied for the selected row. To define or modify a value in this 

table, type that value in the corresponding cell, then press "Enter" key. 

 

 
Figure 3 List box used by ELPLA 
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Analysis progress 

 

During the analysis of problems, all computations and analysis progression according to the defined 

method are progressively reported. As shown in Figure 4, the analysis progress menu reports the 

various phases of calculations. In addition, the status bar of "Solver" Tab displays information about 

the progress of calculation as the program analyzes problems. 

 

 
Figure 4 Analysis progress menu 
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4. Description of the examples 

This Tutorial contains 13 examples. These examples are presented in order to illustrate how to use 

ELPLA for analyzing axisymmetric structures and tanks. For each example discussed in this 

Tutorial, data files and some computed files are included in ELPLA software package. The file 

names and contents of the examples are given as follows. Besides, a key figure of each problem is 

shown that contains the main data concerning the structure shape and loads. Examples can be run 

again by ELPLA to examine the details of the analysis or to see how the problem was defined or 

computed and to display, print or plot the results. 

 

Example 1 Analysis of a circular loaded area resting on different soil layers 

File                    Soil profile under the circular loaded area 

Circular loaded area  

 
 

An example of a loaded area resting on different soil layers is selected to illustrate some features of 

ELPLA for analyzing shell elements using circular and annular elements 

 

 

q=100 [kN/m 2 ] 

GW 

2.0 [m] 

Impervious layer (Rock) 

4.0 [m] 

c 

2.0 [m] 

Normally consolidated clay: 

Cc=0.0425  [-] 

eo=0.85   [-] 

γc2 =8.69 [kN/ m3] 

Soft clay: 

mv=2×10-4   [m2/kN] 

γc1 =8      [kN/ m3] 

Fine sand: 

Es=8000   [kN/m2] 

γs =17.5    [kN/ m3] 
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Example 2 Analysis of an annular plate resting on Winkler's medium 

File                       Annular plate subjected to a uniform load 

Annular plate   

 
 

 

An example of an annular plate resting on Winkler's medium is selected, to illustrate some features 

of ELPLA for analyzing shell elements using circular and annular elements 
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Example 3 Analysis of a tank with a fixed base  

File                        Cylindrical circular tank 

Tank with fixed base  

 
An example of an axi-symmetrically circular cylindrical tank with a fixed base is selected to 

illustrate some features of ELPLA for analyzing shell elements 

 

 

 

 

t = 0.25 [m] 

a = 7 [m] a = 7 [m] 

H
 =

 5
 [

m
] 

p0 = 50 [kN/ m2] 

Ec = 2×107 [kN/ m2] 

νc = 0.15    [-] 

γw = 10       [kN/ m3] 
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Example 4 Analysis of a reservoir wall with a variable wall thickness 

File                                 Reservoir wall 

Reservoir wall   

 
An example of a cylindrical shell with a variable wall thickness using the finite difference method is 

selected to illustrate some features of ELPLA for analyzing shell elements 
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Example 5 Analysis of a tank covered with a spherical dome 

File                       Tank covered with a spherical dome roof 

Tank with covered roof  

 
An example of an axi-symmetrically circular cylindrical tank covered with a spherical dome roof is 

selected illustrate some features of ELPLA for analyzing shell elements 

 

 

 

 

 

 

 

 

 

 

Ec = 3×107 [kN/ m2] 

νc = 0.16    [-] 

γc = 25       [kN/ m3] 

a = 15 [m] 

tw = 0.25 [m] 

R = 30.1 [m] 

tr = 0.15 [m] 
H

w
 =

 1
0
 [

m
] 

H
r 

=
 4

 [
m

] 
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Example 6 Analysis of a tank resting on Winkler's medium 

File      Circular cylindrical tank resting on isolated springs 

Tank on Winkler's medium   

 
An example of an axi-symmetrically circular cylindrical tank resting on elastic foundation  

using Winkler’s model is selected to illustrate some features of ELPLA for analyzing shell elements 

 

 

d = 13 [m] 

a = 6.5 [m] H
 =

 3
.5

 [
m

] 

t = 0.175 [m] 

ks = 100 000 [kN/ m3] 

Ec = 2×107 [kN/ m2] 

νc = 0.20    [-] 

γc = 25       [kN/ m3] 

γw = 10       [kN/ m3] 
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Example 7 Analysis of a tank with a conical base resting on Winkler's medium 

File       Circular cylindrical tank on isolated springs 

Conical Tank   

 
 

An example of a circular cylindrical tank with a conical base resting on elastic foundation using 

Winkler’s model is selected to illustrate some features of ELPLA for analyzing circular cylindrical 

shell elements 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Ec = 2×107 [kN/ m2] 

νc = 0.20    [-] 

γc = 25       [kN/ m3] 

γw = 10       [kN/ m3] H
 =

 6
 [

m
] 

t = 0.5 [m] 

a = 7.5 [m] 

ks = 100 000 [kN/ m3] 

0.85 [m] 
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Example 8 Analysis of a tank resting on half space soil medium 

File         Circular cylindrical tank resting on an isotropic elastic soil medium 

Tank resting on half space soil medium   

 
 

An example of a circular cylindrical tank resting on an isotropic elastic half space soil medium is 

selected to illustrate some features of ELPLA for analyzing shell elements 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H
 =

 7
.5

 [
m

] 

d = 18 [m] 

Ec = 1.4×107[kN/ m2] 

νc = 0.0     [-] 

γw = 9.81      [kN/ m3] 

Isotropic elastic soil medium 

E = 20000 [kN/ m2] 

νs = 0.4      [-] 

a = 9 [m] 

t = 0.36 [m] 
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Example 9 Analysis of a tank with a different base thickness resting on half space soil medium 

File         Circular cylindrical tank resting on an isotropic elastic soil medium 

Tank with different base thickness 

 
 

An example of a circular cylindrical storage tank resting on an isotropic elastic half space soil 

medium is selected to and illustrate some features of ELPLA for analyzing circular cylindrical shell 

elements 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Ec = 2 ×107 [kN/ m2] 

νc = 0.16  [-] 

γb = 24  [kN/ m3] 

γw = 10.19 [kN/ m3] 

 

H
 =

 1
0
 [

m
] 

d = 20 [m] 

a = 10 [m] 

Isotropic elastic soil medium 

E = 20000 [kN/ m2] 

νs = 0.2      [-] 

tw = 0.2 [m] 

tb = 0.5 [m] 
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Example 10 Analysis of a cylindrical water container with a conical base 

File                      Cylindrical water container 

Water container   

 
 

An example of a cylindrical water container with a conical base is selected to illustrate some 

features of ELPLA for analyzing circular cylindrical shell elements 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

0.3 [m] 

6 [m] 

9
.0

 [
m

] Ec = 3×107 [kN/ m2] 

νc = 0.17    [-] 

γw = 10 [kN/ m3] 

 

3
.0

 [
m

] 

0.2 [m] 
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Example 11 Analysis of a chimney with a hyperbolic shell wall 

File        Geometry of the chimney 

Hyperbolic chimney   

 
 

An example of an axi-symmetrically chimney with hyperbolic shell wall under a uniform external 

pressure is selected to illustrate some features of ELPLA for analyzing shell elements 

 

 

 

 

 

 

 

 

 

 

 

 

 

2Ro   = 36 [m] 

r 

ξ 

H
l =

 4
5
 [

m
] H

 =
 7

2
 [

m
] 

51.92 [m] 

2Ru = 72 [m] 

Ec = 3×107 [kN/ m2] 

νc = 0.17    [-] 

γw = 10 [kN/ m3] 

 

0.24 [m] 
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Example 12 Analysis of an irregular container resting on a layered soil 

File                    Irregular container 

Container on layered soil   

 
 

An example of an axi-symmetrically container with irregular shape resting on a layered soil is 

selected to illustrate some features of ELPLA for analyzing shell elements 

 

 

 

 

 

 

 

 

 

 

Rm = 7.00 [m] 

Ec = 2×107 [kN/ m2] 

νc = 0.20    [-] 

γc = 25       [kN/ m3] 

γw = 9.81    [kN/ m3] 

a = 5 [m] 

H
 =

 1
4

 [
m

] 
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Example 13 Analysis of a circular silo for storing bulk materials 

File            Geometry of the silo 

Silo 

 
An example of a circular concrete silo is selected to illustrate some features of ELPLA for analyzing 

circular silos for storing bulk materials 

 

 

r=2 [m] 

H=14 [m] 

pt=0.25[m

] 

pt=0.28[m

] 

3 [m] 

3 [m] 

0.25 

[m] 

Conical hopper 

Conical roof 

Cylindrical shell 
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1 Description of the problem 

An example of a loaded area resting on different soil layers is selected to illustrate some features  

of ELPLA for analyzing shell elements using circular and annular elements. 

2 Geometry and properties 

A circular loaded area of a radius a=5 [m] acting on three different soil layers as shown  

in Figure 1.1. 

 
Figure 1.1 Soil profile under the circular loaded area 

 

 

 

 

q=100 [kN/m 2 ] 

GW 

2.0 [m] 

Impervious layer (Rock) 

4.0 [m] 

c 

2.0 [m] 

Normally consolidated clay: 

Cc=0.0425  [-] 

eo=0.85   [-] 

γc2 =8.69 [kN/ m3] 

Soft clay: 

mv=2×10-4   [m2/kN] 

γc1 =8      [kN/ m3] 

Fine sand: 

Es=8000   [kN/m2] 

γs =17.5    [kN/ m3] 
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3 Creating the project 

In this section, the user will learn how to create a project for analyzing a circular loaded area resting 

on different soil layers. The project will be processed gradually to show the possibilities  

and abilities of the program. To enter the data of the example, follow the instructions and  

steps in the next paragraphs. 

3.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 1.2. This wizard will help the user to define the analysis type  

and the calculation method of the problem through a series of Forms. The first Form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 1.2). 

 

 
Figure 1.2 "Analysis Type" Form 

As the analysis type is a circular loaded area problem, select "Analysis of rotational shell" button, 

and check "Shell with a raft foundation" option, then click "Next" button to go to the next Form. 

After clicking "Next" button, the "Calculation Methods" Form appears, Figure 1.3. 
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To define the calculation method: 

 

- Select the calculation method "9-Flexible Foundation" 

- Select the subsoil model as "Layered soil model" 

- Click "Next" button to go to the next Form 

 

 
Figure 1.3 "Calculation Methods" Form 

The last Form in the wizard is the "Options" Form, Figure 1.4. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Since no option will be considered in the analysis, click the "Save" button. 
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Figure 1.4 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 1.5. In this dialog box 

type a file name for the current project in "File name" edit box. For example, type "Circular loaded area ". 

ELPLA will use automatically this file name in all reading and writing processes. 
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Figure 1.5 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project [Circular 

loaded area] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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3.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely 

entered. To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 1.6 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a circular loaded area resting on different soil layers" 

- Type the date of the project in the "Date" edit box 

- Type the word "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 1.6 "Project Identification" dialog box 
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3.3 FE-Net data 

For the given problem, the shell has a circular shape with a radius of a=5 [m] and is divided  

into 10 segments. ELPLA has different procedures for defining the FE-Net.  

 

To define the FE-Net for this shell, choose "FE-Net Data" command from the “Data” Tab. 

"Analysis of rotational shell" wizard appears as shown in Figure 1.7. This wizard will guide you 

through the steps required to generate a FE-Net. The first Form of the wizard is the "Shell type" 

Form, which contains a group of templates of different shapes of shells. These net templates are 

used to generate standard nets. 

 

 
Figure 1.7 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 

 

- In the "Shell type" options choose "Cylindrical shell" button 

- Type 0 in the "Height" edit box, as the example is a circular plate 

- Type 5 in the "Radius" edit box 

- Click "Next" button to go to the next Form 
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After clicking "Next" in "Analysis of rotational shell" wizard, the following "Net of Base" Form 

appears Figure 1.8.  

 

To edit the grid spacing in x-direction, do the following steps in "Grid in x-direction" frame: 

 

- Choose "Constant grid interval" check box 

- Type 10 in the "No. of grid intervals" edit box 

 

 
Figure 1.8 "Net of Base" Form 

ELPLA will generate a sector from the circular area with 10 circular elements. The following 

window in Figure 1.9 appears with the generated net. 
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Figure 1.9 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 1.9 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 1.9 to close the "FE-Net" window and 

return to ELPLA main window 
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3.4 Soil Properties 

In ELPLA, there are three different soil models with several calculation methods. Therefore,  

the soil properties for each method are required to be defined according to the used soil model.  

In the current example, the soil model, which is used in the analysis, is a "Layered Soil Model".  

This model requires that the subsoil have to be defined by boring logs. In the example, the boring 

log has multi-layers with different soil materials. The geotechnical data for each layer is unit weight 

of the soil γs and modulus of Elasticity for loading Es and reloading Ws or Compression index Cc 

and recompression index Cr. 

 

To define the soil properties, choose "Soil Properties" command from “Data” Tab. The following 

"Soil Properties" Window in Figure 1.10 appears with a default-boring log. 

 

 
Figure 1.10 "Soil Properties" window with a default-boring log 

In Figure 1.10, soil properties are defined through the "Data" menu, which contains  

the following two commands: 

 

- "Soil Data" command defines the individual boring logs 

- "Main Soil Data" command defines the general data for all soil layers 

 

To enter the soil properties for the boring log of the current example 

 

- Choose "Soil Data" command from "Data" menu in the window of Figure 1.10. 

The following dialog box in Figure 1.11 with default-boring log data appears 
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Figure 1.11 "Soil data" dialog box with default-boring log data 

In the "Geotechnical data of the layer" dialog group box in Figure 1.11, Soil properties are defined 

by Modulus of compressibility, define the geotechnical data of the first soil layer of the boring log 

as follows: 

  

Es   = 8 000  [kN/m2] 

Ws   = 8 000 [kN/m2] 

Gam  = 18   [kN/m3] 

C  = 10   [kN/m2] 

φ = 0   [º] 

 

Due to the presence of the ground water, the soil above the ground water level has a differential unit 

weight from the soil under that level. Therefore, the layer depth of the first layer is taken to be 2 [m], 

which is equal to the ground water level. Now, type this value in "Layer depth under the ground 

surface" edit box. 

 

In order to draw the soil layers by different symbols according to the German Standard DIN 4023, 

the soil type and color for each layer must be defined. 

 

To define the soil type and color for the first layer, select "fS, Fine sand" as the soil type in "Main soil 

type 1" combo box in "Soil and rock symbols" dialog group box in Figure 1.11. The color of the fine 

sand layer according to the German Standard DIN 4023 will be automatically created. The user can 

change this color. In addition, a short text "fS" will be automatically created for the fine sand. 
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To enter the second layer of the boring log 

 

- Click "Copy Layer" button in Figure 1.11. A layer that has the same properties of the first 

layer will be copied 

- Use the vertical scrollbar to move to the second soil layer. Layer No. will be typed 

automatically at the upper-left corner of the main dialog box of soil layers as a head title 

- Change the value of the unit weight of the soil for the second soil layer from 18 [kN/m3]  

to 8 [kN/m3] 

- Change the value "ES" and "Ws" from 8000 [kN/m2] to 5000 [kN/m2] 

- Change the value of the layer depth under the ground surface from 2 [m] to 4 [m] 

- From "Soil and rock symbols" dialog group box, Change "fS, Fine sand" into "T, Clay"  

as the soil type of the second layer is clay   

 

To enter the third layer 

 

- Click "Insert Layer" button in Figure 1.11, then a layer will be inserted 

- Use the vertical scrollbar to move to the third soil layer 

- In "Geotechnical data of the layer" dialog group box in Figure 1.11, Soil properties are 

defined by Compression Index Cc, define the geotechnical data of the clay layer as follows: 

  

Cc   = 0.04   

Cr   = 0.04  

 Gam  = 8   [kN/m3] 

Phi   = 30  [°] 

c   = 10  [kN/m2] 

eo   = 0.85    

 

 

- Select "T, Clay" as the soil type in "Main soil type 1" combo box in "Soil and rock symbols" 

dialog group box 

- Type 8 in the "Layer depth under the ground surface" edit box 

 

Note that the unit weight of the soil is used to determine the uniform load q [kN/m2] on the circular 

area, which is equal to γs × df.  
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Now all data and parameters for the boring log (Figure 1.12) have been entered.  

 

 
Figure 1.12 boring log 

To enter the main soil data for all layers, choose "Main Soil Data" command from "Data" menu 

in Figure 1.10. The following dialog box in Figure 1.13 appears with default main soil data.  

The main soil data for the current example, which are required to be defined, are the settlement 

reduction factor α [-] and the groundwater depth under the ground surface Gw [m]. Any other data 

corresponding to main soil data are not required for this example. Therefore, the user can use the 

default values. 

 

In the dialog box of Figure 1.13, enter the settlement reduction factor α [-] and the groundwater 

depth under the ground surface Gw [m]. Then click "OK" button. 
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Figure 1.13 "Main Soil Data" dialog box 

After entering all data and parameters of the boring log, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 1.10 to save the data of boring logs 

- Choose "Close" command from "File" menu in Figure 1.10 to close "Soil properties" 

window and return to ELPLA main window 
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3.5 Shell properties 

To define the shell properties, choose "Shell Properties" command from “Data” Tab.  

The following window in Figure 1.14 appears with default shell properties. The data of shell 

properties for the current example, which are required to be defined, are element groups, and the 

unit weight of the shell. Any other data corresponding to shell properties in the program menus are 

not required for this example.  

 

 
Figure 1.14 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 1.15 

appears. In this list box, enter E-Modulus, Poisson’s ratio and slab thickness. Then click "OK" 

button. 
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Figure 1.15 "Defining element groups" list box 

To enter the unit weight of the shell, choose "Unit weight" command from "Shell Properties" menu 

in the window of Figure 1.14. The following dialog box in Figure 1.16 with a default unit weight 

of 25 [kN/m3] appears. Type 400 in the "Unit weight" edit box, to define the uniform load on the 

circular area. Then click "OK" button. 

 

 
Figure 1.16 "Unit weight" dialog box 

After entering the Shell Properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 1.14 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 1.14 to close the "Shell 

Properties" window and return to ELPLA main window 
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3.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 1.17 appears. In ELPLA, entering loads may be carried out either numerically (in a table) 
or graphically using the commands of "Loads" Tab in Figure 1.17. In this example, there is not 
applied load, as the load has been already defined by the unit weight of the plate. 
 

 
Figure 1.17 "Loads" Window 

Do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 1.17 to save the load data 

- Choose "Close" command from "File" menu in Figure 1.17 to close the "Loads" window 

and return to ELPLA main window  

 

Creating the project is now complete. It is time to analyze this project. In the next section,  

you will learn how to use ELPLA for analyzing projects. 
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4 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 1.18. 

 

 
Figure 1.18 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Determining flexibility coefficients of the soil 

- Analysis of the flexible foundation 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

Carrying out all computations 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab window.  

- The progress of all computations according to the defined method will be carried out 

automatically with displaying Information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 1.19 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. In addition, a status bar down of the 

"Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 1.19 Analysis progress menu 
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Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 1.20. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 1.20 Menu "Check of the solution" 

Click "OK" button to finish analyzing the problem. 
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5 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through the 

"Results" Tab. 

5.1 Viewing data and result graphics 

To view the data and results of a problem that has already been defined and analyzed graphically, 

switch to "Results" Tab (Figure 1.21).  

 

 
Figure 1.21 "Results" Tab 

The "Result" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Boring logs and limit depth 

- Sections in the shell base 

 

To view sections in shell base 

 

- Choose "Sections in shell base" command from "Section" menu. The following option box 

in Figure 1.22 appears 

- In the "Sections in shell base" option box, select "Base settlements w" as an example for the 

results to be displayed 

- Click "OK" button 

 

The Settlements are now displayed as shown in Figure 1.23. 

 

 
Figure 1.22 "Sections in shell base" option box 
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Figure 1.23 Base settlements Sections in shell base 

5.2 Listing data and results in tables 

The "Result" Tab contains the commands of listing data and results. The commands for listing data 

and results in tables are: 

 

- Display tables of data 

- List tables of data through Text-

 Editor 

- Display tables of results 

- List tables of results through Text-

 Editor 

 

To list results in a table 

 

- Choose "Display tables of Results" command from "List" menu. The following option box  

in Figure 1.24 appears 

- In the "Display Tables of Results" option box, select "Settlements/Contact pressures"  

as an example for the result to be listed in a table 

- Click "OK" button. The loading results are now listed (Figure 1.25) 

- Choose "Send to Excel" from "Sending" menu if you wish to export the table to a MS Excel 

application, Figure 1.26 
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Figure 1.24 "Display Tables of Results" option box 

 
Figure 1.25 List of loading data 
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Figure 1.26 Exported data in MS Word 
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1 Description of the problem 

An example of an annular plate resting on Winkler's medium is selected, to illustrate some features 

of ELPLA for analyzing shell elements using circular and annular elements. 

2 Geometry and properties 

A simply supported annular plate subjected to a uniform load resting on Winkler's medium is chosen 

as shown in Figure 2.1. Load on the plate, plate radii, elastic properties of the soil and the plate are: 

 

Inner radius of the plate   r1 = 2.5   [m] 

Outer radius of the plate   r2 = 5   [m] 

Thickness of the plate    t = 0.25   [m] 

Uniform load on the raft    p = 200   [kN/m2] 

Modulus of sub grade reaction of the soil ks  = 10000  [kN/m3] 

Young’s modulus of the plate material Ec  = 2.7×107  [kN/m2] 

Poisson's ratio of the plate material  νc  = 0.2  [-] 

 
Figure 2.1 Annular plate subjected to a uniform load  
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3 Analysis of the plate 

The available method "Constant Modulus of Subgrade Reaction /2" in ELPLA is used here to 

determine the vertical displacement and moment of the plate on Winkler's medium.  

Figure 2.2 shows the annular plate with 10 annular regions and supports. 

 

 

11111111112

 
 

Figure 2.2 Annular plate with 10 annular regions and supports 
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4 Creating the project 

In this section, the user will learn how to create a project for analyzing an annular plate  

resting on Winkler's medium. The project will be processed gradually to show the possibilities  

and abilities of the program. To enter the data of the example, follow the instructions and steps 

in the next paragraphs. 

4.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 2.3. This wizard will help the user to define the analysis type and the 

calculation method of the problem through a series of Forms. The first Form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 2.3). 

 

 
Figure 2.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 2.3, define the analysis type of the problem. As the analysis 

type is an annular plate, select "Analysis of rotational shell" button, and check "Shell with a raft 

foundation" option, then click "Next" button to go to the next Form. After clicking "Next" button, 

the "Calculation Methods" Form appears, Figure 2.4. 
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To define the calculation method: 

 

- Select the calculation method "2/3 Constant/ Variable Modulus of Subgrade Reaction" 

- To determine the modulus of subgrade reaction, select "Modulus is defined by the user" option 

- Click "Next" button to go to the next Form 

 

 
Figure 2.4 "Calculation Methods" Form 

The last Form in the wizard is the "Options" Form, Figure 2.5. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Select "Supports/ Boundary Conditions", then click the "Save" button. 
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Figure 2.5 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 2.6. In this dialog box 

type a file name for the current project in "File name" edit box. For example, type "annular plate". 

ELPLA will use automatically this file name in all reading and writing processes. 
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Figure 2.6 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project [annular plate] 

will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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4.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely 

entered. To identify the project, choose "Project Identification" command from the “Data” Tab. The 

dialog box in Figure 2.7 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of an annular plate resting on Winkler's medium" 

- Type the date of the project in the "Date" edit box 

- Type the word "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 2.7 "Project Identification" dialog box 

4.3 FE-Net data 

For the given problem, the shell has an annular shape with an outer radius of b = 5 [m]  

and an inner radius of a = 2.5 m. To define the FE-Net for this plate, choose "FE-Net Data" 

command from the “Data” Tab. "Analysis of rotational shell" wizard appears as shown  

in Figure 2.8. This wizard will guide you through the steps required to generate a FE-Net. 

 

The first Form of the wizard is the "Shell type" Form, which contains a group of templates of 

different shapes of shells. These net templates are used to generate standard nets. 
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Figure 2.8 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 

 

- In the "Shell type" options choose "Cylindrical shell" button 

- Type 0 in the "Height" edit box, as the example is an annular plate 

- Type 5 in the "Radius" edit box, as the outer radius is b = 5 m 

- Click "Next" button to go to the next Form 

 

 

 

 

 

 

 

 

-   
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Figure 2.9 "Net of Base" Form 

The next Form of the "Analysis of rotational shell" wizard is the "Net of Base" Form Figure 2.9.  

 

To edit the grid spacing in x-direction, do the following steps in "Grid in x-direction" frame: 

 

- Choose "Variable grid interval" check box.  

- Click "Grid Intervals" button, the following "Grid intervals in x-direction" form appears 

Figure 2.10 

- Define the grid intervals as the following  
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Figure 2.10 "Grid intervals in x-direction" Form 

ELPLA will generate a sector from the annular area with 11 circular elements. The following 

Window in Figure 2.11 appears with the generated net. 
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Figure 2.11 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 2.11 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 2.11 to close the "FE-Net" window 

and return to ELPLA main window 
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4.4 Soil Properties 

To define the soil properties, choose "Soil Properties" command from “Data” Tab. The following 

"Soil Properties" form in Figure 2.12 appears, enter the modulus of subgrade reaction of the soil and  

the ground water depth under the ground surface. Other data for this example is not required. 

 

Soil data 

Modulus of subgrade reaction    ks  = 10 000 [kN/ m3] 

Ground water depth under the surface   Gw  = 1  [m] 

 

 
Figure 2.12 "Soil Properties" form 
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4.5 Shell properties 

To define the annular plate properties, choose "Shell Properties" command from “Data” Tab.  

The following window in Figure 2.13 appears with default shell properties. The data of shell 

properties for the current example, which are required to be defined, are element groups and 

unit weight of the plate. Any other data corresponding to the shell properties in the program menus 

are not required for this example. 

 

 
Figure 2.13 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 2.14 

appears. In this list box, enter E-Modulus, Poisson’s ratio and slab thickness, the thickness of the 

inner ring is eliminated by defining its slab thickness by zero. Then click "OK" button. 
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Figure 2.14 "Defining element groups" list box 

Choose "Group Regions" command from "In table" menu. The following list box in Figure 2.15 

appears. As the inner radius is a = 2.5m, and the elements of the plate differ in thickness,  

Edit the "Group no" value for each element as the following. Then click "OK" button. 

 

 
Figure 2.15 "Group Regions" Form 
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To enter the unit weight of the plate, choose "Unit weight" command from "Shell Properties" menu 

in the window of Figure 2.13. The following dialog box in Figure 2.16 with a default unit weight 

of 25 [kN/m3] appears. Type 800 in the "Unit weight" edit box, note that the unit weight of the plate 

material is used to determine the uniform load q [kN/m2] on the annular area, which is equal to γb × d. 

Click "OK" button. 

 

 
Figure 2.16 "Unit weight" dialog box 

Now the shell properties have been entered and the sector of the plate appears as follows in Figure 2.17. 

 

 
Figure 2.17 "Shell Properties" Window 

After entering the shell properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 2.17 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 2.17 to close the "Shell Properties" 

window and return to ELPLA main window 
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4.6 Supports/ boundary conditions 

To define supports choose "Supports/ Boundary Conditions" command from “Data” Tab.  

The following Tab in Figure 2.18 appears. 

 

 
Figure 2.18 "Supports/ Boundary Conditions" Window 

To define the supports 

- Choose "Select Nodes" command from "Graphically" menu in Figure 2.18. When "Select 

Nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on nodes that have supports as shown in Figure 2.19 

- After selecting nodes of supports, choose "Add Supports/ Boundary Conditions" command 

from "Graphically" menu (Figure 2.18). The "Supports/ Boundary Conditions" dialog box  

in Figure 2.20 appears 
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Figure 2.19 Selection of nodes that have supports 

In this dialog box 

 

- Type 0 in the "Displacement w" edit box to define the vertical supports, as the annular plate 

is prevented from moving in the vertical direction at its ends 

- Click "OK" button 

 

 
Figure 2.20 "Supports/ Boundary Conditions" dialog box 
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Figure 2.21 Supports on the screen 

After entering supports, do the following two steps 

 

- Choose "Save " command from "File" menu in Figure 2.21 to save the data of supports 

- Choose "Close" command from "File" menu in Figure 2.21 to close the "Supports/ Boundary 

conditions" window and return to the main window 
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4.7 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following Window  
in Figure 2.22 appears. In ELPLA, entering loads may be carried out either numerically (in a table) 
or graphically using the commands of "Loads" Tab in Figure 2.22. For this example, there is not 
applied load, as the load has been already defined by the unit weight of the plate. 
 

 
Figure 2.22 "Loads" Window 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 2.22 to save the load data 

- Choose "Close" command from "File" menu in Figure 2.22 to close the "Loads" window 

and return to ELPLA main window  

 

 

Creating the project of the plate is now complete. It is time to analyze this project. In the next 

section, you will learn how to use ELPLA for analyzing projects. 
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5 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 2.23. 

 

 
Figure 2.23 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Determining the modulus of subgrade reaction 

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (band matrix) 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

Carrying out all computations 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab Window.  

 

Analysis progress 

 

Analysis progress menu in Figure 2.24 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. In addition, a status bar down of the 

"Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 2.24 Analysis progress menu 
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Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 2.25. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 2.25 Menu "Check of the solution" 

Ignore the elimination of the negative contact pressure which appears at the inner ring. 

 
Figure 2.26 Menu "Check of the solution" 

Click "OK" button to finish analyzing the problem. 
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6 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through the 

"Results" Tab. To view the data and results of a problem that has already been defined and analyzed 

graphically, switch to "Results" Tab (Figure 2.27).  

 

 
Figure 2.27 "Results" Tab 

The "Result" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Support reactions 

- Rotational shell results 

- Sections in shell wall 

- Sections in shell base 

- Display tables of data 

- Display tables of results 

 

To view the meridional moments in the shell base  

 

- Choose "Sections in shell base" command from "Section" menu. The following option box 

in Figure 2.28 appears 

- In the "Sections in shell base" option box, select "Meridional moments My" as an example 

for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 2.29. 

 

 
Figure 2.28 "Sections in shell base" option box 
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Figure 2.29 Meridional moments in shell base 

To view element groups of the plate 

 

- Choose "Element groups" from "In Plan" command in "Data" menu. The following option 

box in Figure 2.30 appears 

- In the "Data – In Plan" option box, select "Element groups" as an example for the results  

to be displayed 

- Click "OK" button 

 

 
Figure 2.30 "Data – In Plan" option box 
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To draw the thickness of the annular plate  

 

- Choose "Plot Parameters" command from "Setting" Tab. The "Plot Parameters" dialog box 

in Figure 2.31 appears 

- In the "FE-Net" Tab, check the "Draw girder thickness" check box in the "Rotational shell 

system" dialog box 

- Click "OK" button 

 

 
Figure 2.31 "Plot Parameters" dialog box 

To view the reactions of the supports on the FE-Net and any other data 

 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command.  

The "View Grouping" check group box in Figure 2.32 appears 

- In this check group box, check "Supports /Boundary Conditions" and "Supports Reactions RV" 

check boxes 

- The user can choose any other data to be displayed 

- Click "OK" button 
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Figure 2.32 "View Grouping" check group box 

 
Figure 2.33 Element groups of the annular plate 
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1 Description of the problem 

An example of an axi-symmetrically circular cylindrical tank with a fixed base is selected  

to illustrate some features of ELPLA for analyzing shell elements. 

2 Tank geometry and properties 

A circular cylindrical tank of a radius of a = 7 [m] and a height of H = 5 [m] is considered as shown 

in Figure 3.1. Thickness of the tank wall is t = 0.25 [m]. The tank is filled with water. The lower 

edge of the tank is clamped. Figure 3.1 shows the circular cylindrical tank with its dimensions,  

while the tank material and unit weight of the water are listed in Table 3.1.  

Table 3.1 Tank material and water unit weight  

Modulus of Elasticity of the tank material  Ec = 2×107 [kN/m2] 

Poisson's ratio of the tank material    νc = 0.15    [-] 

Unit weight of the water    γw  = 10    [kN/m3] 

 

 
Figure 3.1 Cylindrical circular tank with dimensions 

 

 

 

 

 

 

t = 0.25 [m] 

a = 7 [m] a = 7 [m] 

H
 =

 5
 [

m
] 

p0 = 50 [kN/ m2] 

Ec = 2×107 [kN/ m2] 

νc = 0.15    [-] 

γw = 10       [kN/ m3] 
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3 Numerical Analysis 

The analysis of circular cylindrical shell tank is carried out using the finite element method. 

In the analysis, the height of the tank is divided into 50 equal segments. In each segment,  

element size is 0.1 [cm] as shown in Figure 3.2. 

 
Figure 3.2 Finite element mesh of the tank 

4 Creating the project 

In this section, the user will learn how to create a project for analyzing a tank with a fixed base.  

The project will be processed gradually to show the possibilities and abilities of the program. 

To enter the data of the example, follow the instructions and steps in the next paragraphs. 

4.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 3.3. This wizard will help the user to define the analysis type  

and the calculation method of the problem through a series of Forms. The first Form  

of "Calculation Methods" wizard is the "Analysis Type" Form (Figure 3.3). 
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Figure 3.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 3.3, define the analysis type of the problem. As the analysis 

type is a tank with a fixed base problem, select "Analysis of rotational shell" button, and check 

"Shell with an opening base" option then click "Next" button to go to the next Form.  
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The last Form in the wizard is the "Options" Form, Figure 3.4. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Select "Supports/ Boundary Conditions", then click the "Save" button. 

 

 
Figure 3.4 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 3.5. In this dialog box 

type a file name for the current project in "File name" edit box. For example, type "Tank with fixed base". 

ELPLA will use automatically this file name in all reading and writing processes. 
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Figure 3.5 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project [Tank with 

fixed base] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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4.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely 

entered. To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 3.6 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a tank with a fixed base" 

- Type the date of the project in the "Date" edit box 

- Type the word "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 3.6 "Project Identification" dialog box 

4.3 FE-Net data 

For the given problem, the tank has a radius of a = 7 [m] and a height of H = 5 [m], the height of the 

tank is divided into 50 equal segments. Each segment is 10 [cm] size. To define the FE-Net for this 

tank, choose "FE-Net Data" command from the “Data” Tab. "Analysis of rotational shell" wizard 

appears as shown in Figure 3.7. This wizard will guide you through the steps required to generate  

a FE-Net, the first Form of the wizard is the "Shell type" Form, which contains a group of templates 

of different shapes of shells. These net templates are used to generate standard nets. 
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Figure 3.7 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 

 

- In the "Shell type" options choose "Cylindrical shell" button 

- Type 5 in the "Height" edit box,  

- Type 7 in the "Radius" edit box,  

- Type 50 in the "Number of segments" edit box 

- Click "Next" button to go to the next Form 

 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Cylindrical shell" 

Form appears, Figure 3.8. ELPLA divides the height of the tank into 50 equal segments, the user can 

edit the data of the segments individually by using "Modify" button, or all of them by using  

"In Table" button, if it is necessary. 
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Figure 3.8 "Cylindrical shell" Form 

Click "Finish" button, the generated FE-Net appears in Figure 3.9. 
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Figure 3.9 Generated FE-Net 

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 3.9 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 3.9 to close the "FE-Net" window  

and return to ELPLA main window 
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4.4 Shell properties 

To define the tank properties, choose "Shell Properties" command from “Data” Tab. The following 

window in Figure 3.10 appears with default shell properties. The data of shell properties for the 

current example, which are required to be defined, are element groups, unit weight of the shell and 

the filled material properties.  

 

 
Figure 3.10 "Shell Properties" Window 
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Choose "Element groups" command from "In table" menu. The following list box in Figure 3.11 appears. 

In this list box, enter E-Modulus, Poisson’s ratio and slab thickness. Then click "OK" button. 

 

 
Figure 3.11 "Defining element groups" list box 

To enter the unit weight of the shell, choose "Unit weight" command from "Shell Properties" menu 

in the window of Figure 3.10. The following dialog box in Figure 3.12 with a default unit weight 

of 25 [kN/m3] appears, Click "OK" button. 

 

 
Figure 3.12 "Unit weight" dialog box 
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To define the liquid properties of the shell, choose "Filled material type/Element size" command 

from "Shell Properties" menu in the window of Figure 3.10. The following form in Figure 3.13. 

 

To define the filled material type of the tank: 

 

- Select the "Liquid container" check box, 

- Type 5 in the "Height of the liquid" edit box, 

- Type 10 in the "Unit weight of the liquid" edit box, 

 

To define the element size of the tank: 

 

- Check the "Constant element sizes in z-direction" check box, 

- Type 0.2 in the "Element size in each shell segment" edit box, 

- Click "OK" button  

 

 
Figure 3.13 "Filled material type/Element size" Form 

After entering the shell properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 3.10 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 3.10 to close the "Shell 

properties" window and return to ELPLA main window 
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4.5 Supports/ boundary conditions 

To define the fixed support, choose "Supports/ Boundary Conditions" command from “Data” Tab.  

The following window in Figure 3.14 appears. 

 

 
Figure 3.14 "Supports/ Boundary Conditions" Window 

To define supports on the net: 

 

- Choose "Select Nodes" command from "Graphically" menu in Figure 3.14. When "Select 

Nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the node that have the fixed support as shown in Figure 3.15 

- After selecting the node, choose "Add Supports/ Boundary Conditions" command from 

"Graphically" menu (Figure 3.14). The "Supports/ Boundary Conditions" dialog box  

in Figure 3.16 appears. 

 

 

-  
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Figure 3.15 Selection of node that has a fixed support 
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In this dialog box 

 

- Type 0 in the "Displacement u" edit box to define the horizontal fixed support 

- Type 0 in the "Displacement w" edit box to define the vertical fixed support 

- Type 0 in the "Rotation Theta" edit box to define the rotational fixed support 

- Click "OK" button 

 

 
Figure 3.16 "Supports/ Boundary Conditions" dialog box 
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Figure 3.17 Supports on the screen 

After defining the supports, do the following two steps 

 

- Choose "Save " command from "File" menu in Figure 3.17 to save the data of supports 

- Choose "Close" command from "File" menu in Figure 3.17 to close the "Supports/ Boundary 

conditions" window and return to the main window 
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4.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 3.18 appears. In ELPLA, entering loads may be carried out either numerically (in a table) 
or graphically using the commands of "Loads" Tab in Figure 3.18. In this example, there is not 
applied load, as the vertical load has been already defined by the unit weight of the tank material, 
while the hydrostatic pressure on the tank is defined by the unit weight of water. 
 

 
Figure 3.18 "Loads" Window 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 3.18 to save the load data 

- Choose "Close" command from "File" menu in Figure 3.18 to close the "Loads" window 

and return to ELPLA main window 

 

Creating the project of the tank is now complete. It is time to analyze this project. In the next 

section, you will learn how to use ELPLA for analyzing projects. 
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5 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 3.19. 

 

 
Figure 3.19 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (band matrix) 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab Window.  

 

The progress of all computations according to the defined method will be carried out automatically 

with displaying Information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 3.20 appears in which various phases of calculation  

are progressively reported as the program analyzes the problem. In addition, a status bar down  

of the "Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 3.20 Analysis progress menu 
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Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 3.21. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 3.21 Menu "Check of the solution" 

Click "OK" button to finish analyzing the problem. 
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6 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through the 

"Results" Tab. 

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

switch to "Results" Tab (Figure 3.22).  

 

 
Figure 3.22 "Results" Tab 

The "Result" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Rotational shell results 

- Support Reactions 

- Sections in shell wall 

- Display tables of data 

- Display tables of results 

 

To view the meridional moments in the shell wall  

 

- Choose "Sections in shell wall" command from "Section" menu. The following option box 

in Figure 3.23 appears 

- In the "Sections in shell wall" option box, select "Meridional moments My" as an example 

for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 3.24. 
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Figure 3.23 "Sections in shell wall" option box 

 
Figure 3.24 Meridional moments sections in shell wall 
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To view the radial forces on the shell wall  

 

- From "Rotational shell results" command in the "Results" menu, choose "In Plan" command, 

the following option box in Figure 3.25 appears 

- In the "Distribution of Internal Forces" option box, select "Radial forces Nr" as an example  

for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 3.26. 

 

 
Figure 3.25 "Distribution of Internal Forces" option box 

 
Figure 3.26 Radial forces on the shell wall 

 

 



Example 3  

 
 

   -3.25- 

To view element groups of the tank  

 

- Choose "Element groups" from "In Plan" command in "Data" menu. The following option 

box in Figure 3.27 appears 

- In the "Data – In Plan" option box, select "Element groups" as an example for the results  

to be displayed 

- Click "OK" button 

 

 
Figure 3.27 "Data – In Plan" option box 

To view the supports / boundary conditions on the FE-Net and any other data 

 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command. The "View 

Grouping" check group box in Figure 3.28 appears 

- In this check group box, check "Supports Reactions RV" check box 

- The user can choose any other data to be displayed 

- Click "OK" button 

 

 
Figure 3.28 "View Grouping" check group box 
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Figure 3.29 Element groups 
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Analysis of a reservoir wall  

with a variable wall thickness 
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1 Description of the problem 

An example of a reservoir with a variable wall thickness is selected to illustrate some features of 

ELPLA for analyzing shell elements. 

2 Geometry and properties 

A reservoir wall of a radius a = 100 [m] and a height H = 100.1 [m] is considered as shown  

in Figure 4.1. The wall of the reservoir has a variable thickness, at the base the thickness is h11 = 13.3 

[m], while at the top the thickness is h0 = 4 [m], thickness in between h [m] can be obtained from 

the following equation:  

 

where x is the distance from the top in [m]. 

 

 
Figure 4.1 reservoir wall with dimensions  

 

The reservoir wall is exposed to a hydrostatic water pressure and is fixed at the base. The wall 

material and unit weight of the water are listed in Table 4.1.  
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Table 4.1 Wall material and water unit weight  

Modulus of Elasticity of the reservoir wall material  Ec = 2.1×107 [kN/m2] 

Poisson's ratio of the reservoir wall material   νc = 0     [-] 

Unit weight of the water     γw  = 10     [kN/m3] 

3 Analysis of the reservoir wall 

In the analysis, the total height of the wall is divided into 11 segments with a constant length; each 

is (Figure 4.2): 
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Figure 4.2 Finite element mesh of the reservoir wall with wall thickness 
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4 Creating the project 

In this section, the user will learn how to create a project for analyzing cylindrical shells  

with variable wall thickness. The project will be processed gradually to show the possibilities and 

abilities of the program. To enter the data of the example, follow the instructions and steps  

in the next paragraphs. 

4.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 4.3. This wizard will help the user to define the analysis type  

and the calculation method of the problem through a series of Forms. The first Form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 4.3). 

 

 
Figure 4.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 4.3, define the analysis type of the problem. As the analysis 

type is a cylindrical shell with a variable wall thickness problem, select "Analysis of rotational 

Shell" button, and check "Shell with an opening base" option, then click "Next" button to go to the 

next Form.  
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The last Form in the wizard is the "Options" Form, Figure 4.4. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Select "Supports/ Boundary Conditions", then click the "Save" button. 

 

 
Figure 4.4 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 4.5. In this dialog box 

type a file name for the current project in "File name" edit box. For example, type "Reservoir wall". 

ELPLA will use automatically this file name in all reading and writing processes. 
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Figure 4.5 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project [Reservoir 

wall] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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4.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely 

entered. To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 4.6 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a reservoir wall with a variable wall thickness" 

- Type the date of the project in the "Date" edit box 

- Type the word "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 4.6 "Project Identification" dialog box 

4.3 FE-Net data 

A reservoir wall of a radius a = 100 [m] and a height H = 100.1 [m] is considered as shown  

in Figure 4.1. The wall of the reservoir has a variable thickness, at the base the thickness is h11 = 13.3 [m], 

while at the top the thickness is h0 = 4 [m], the total height of the wall is divided into 11 segments 

with a constant length, each 9.10 [m]. To define the FE-Net for this shell, choose "FE-Net Data" 

command from the “Data” Tab. "Analysis of rotational shell" wizard appears as shown in Figure 4.7. 

This wizard will guide you through the steps required to generate a FE-Net.  

 

The first Form of the wizard is the "Shell type" Form, which contains a group of templates of 

different shapes of nets. These net templates are used to generate standard nets. 
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Figure 4.7 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 

 

- In the "Shell type" options choose "Cylindrical shell" button 

- Type 100.1 in the "Height" edit box,  

- Type 100 in the "Radius" edit box,  

- Type 11 in the "Number of segments" edit box 

- Click "Next" button to go to the next Form 

 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Cylindrical shell" 

Form appears, Figure 4.8. ELPLA divides the height of the reservoir wall into 11 equal segments,  

the user can edit the data of the segments individually by using "Modify" button, or all of them  

by using "In Table" button, if it is necessary. 
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Figure 4.8 "Cylindrical shell" Form 

Click "Finish" button, the FE-Net appears in Figure 4.9 
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Figure 4.9 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 4.9 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 4.9 to close the "FE-Net" window and 

return to ELPLA main window 
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4.4 Shell properties 

To define the reservoir properties, choose "Shell Properties" command from “Data” Tab.  

The following window in Figure 4.10 appears with default shell properties. The data of reservoir 

properties for the current example, which are required to be defined, are element groups, group 

regions, unit weight of the reservoir and liquid properties. 

 

 
Figure 4.10 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 4.11 appears. 

In this list box, enter E-Modulus, Poisson’s ratio and slab thicknesses of the segments as the following list. 

Then click "OK" button. 
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Figure 4.11 "Defining element groups" list box 
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Choose "Group Regions " command from "In table" menu. The following list box in Figure 4.12 appears. 

In this list box, edit the "Group No." value for each segment. Then click "OK" button. 

 

 
Figure 4.12 "Group Regions" list box 

To enter the unit weight of the reservoir, choose "Unit weight" command from "Shell Properties" 

menu in the window of Figure 4.10. The following dialog box in Figure 4.13 with a default unit 

weight of 25 [kN/m3] appears, type 0 in the "Unit weight" edit box to neglect the wall weight in the 

analysis, then click "OK" button. 

 

 
Figure 4.13 "Unit weight" dialog box 

 

 

 

 

 

 

 



Example 4  

 

 

   -4.15- 

To define the liquid properties of the reservoir, choose "Filled material type/Element size" command 

from "Shell Properties" menu in the window of Figure 4.10. The following form in Figure 4.14. 

 

To define the filled material properties of the reservoir wall: 

 

- Select the "Liquid container" check box, 

- Type 100.1 in the "Height of the liquid" edit box, 

- Type 9.81 in the "Unit weight of the liquid" edit box, 

 

To define the element size of the ring wall: 

 

- Check the "Constant element sizes in z-direction" check box, 

- Type 9.1 in the "Element size in each shell segment" edit box, 

- Click "OK" button 

 

 
Figure 4.14 "Liquid properties/Element size" Form 
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Figure 4.15 "Shell Properties" window after entering the data 

After entering the shell properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 4.15 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 4.15 to close the "Shell 

properties" window and return to ELPLA main window 
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4.5 Supports/ boundary conditions 

To define the fixed support, choose "Supports/ Boundary Conditions" command from “Data” Tab.  

The following window in Figure 4.16 appears. 

 

 
Figure 4.16 "Supports/ Boundary Conditions" Window 

To define supports on the net: 

 

- Choose "Select Nodes" command from "Graphically" menu in Figure 4.16. When "Select 

Nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the node that has the fixed support as shown in Figure 4.17 

- After selecting the node, choose "Add Supports/ Boundary Conditions" command  

from "Graphically" menu Figure 4.16. The "Supports/ Boundary Conditions" dialog box  

in Figure 4.18 appears. 
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Figure 4.17 Selection of node that has a fixed support 
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In this dialog box 

 

- Type 0 in the "Displacement u" edit box to define the horizontal fixed support 

- Type 0 in the "Displacement w" edit box to define the vertical fixed support 

- Type 0 in the "Rotation Theta" edit box to define the rotational fixed support 

- Click "OK" button 

 

 
Figure 4.18 "Supports/ Boundary Conditions" dialog box 
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Figure 4.19 Supports on the screen 

After entering supports, do the following two steps 

 

- Choose "Save " command from "File" menu in Figure 4.19 to save the data of supports 

- Choose "Close" command from "File" menu in Figure 4.19 to close the "Supports/ Boundary 

conditions" window and return to the main window 
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4.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 4.20 appears. In ELPLA, entering loads may be carried out either numerically (in a table) 
or graphically using the commands of "Loads" Tab in Figure 4.20. In this example, there is not 
applied load, as the vertical load has been already defined by the unit weight of the reservoir wall 
material, while the hydrostatic pressure on the reservoir wall is defined by the unit weight of water. 
 

 
Figure 4.20 "Loads" Window 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 4.20 to save the load data 

- Choose "Close" command from "File" menu in Figure 4.20 to close the "Loads" window 

and return to ELPLA main window  

 

 

Creating the project is now complete. It is time to analyze this project. In the next section, you will 

learn how to use ELPLA for analyzing projects. 
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5 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 4.21. 

 

 
Figure 4.21 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (band matrix) 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab Window.  

 

The progress of all computations according to the defined method will be carried out automatically 

with displaying Information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 4.22 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. In addition, a status bar down of the 

"Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 4.22 Analysis progress menu 
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Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 4.23. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 4.23 Menu "Check of the solution" 

 

Click "OK" button to finish analyzing the problem. 
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6 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through  

the "Results" Tab. To view the data and results of a problem that has already been defined and 

analyzed graphically, switch to "Results" Tab (Figure 4.24).  

 

 
Figure 4.24 "Results" Tab 

The "Results" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan  

- Supports Reactions 

- Rotational shell Results 

- Sections in shell wall 

- Display tables of data 

- Display tables of results 

 

To view the meridional moments in the shell wall  

 

- Choose "Sections in shell wall" command from "Section" menu. The following option box 

in Figure 4.25 appears 

- In the "Sections in shell wall" option box, select "Meridional moments My" as an example 

for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 4.26. 

 

 
Figure 4.25 "Sections in shell base" option box 
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Figure 4.26 Meridional moments in shell wall 
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To view element groups of the reservoir  

 

- Choose "Element groups" from "In Plan" command in "Data" menu. The following option 

box in Figure 4.27 appears 

- In the "Data – In Plan" option box, select "Element groups" as an example for the results  

to be displayed 

- Click "OK" button 

 

 
Figure 4.27 "Data – In Plan" option box 

To view the supports / boundary conditions on the FE-Net and any other data 
 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command.  

The "View Grouping" check group box in Figure 4.28 appears 

- In this check group box, check both "Supports Reactions RV", "Supports Reactions M" and 

"Supports /Boundary Conditions" check box  

- The user can choose any other data to be viewed 

- Click "OK" button 

 

 
Figure 4.28 "View Grouping" check group box 
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Figure 4.29 Element groups of the reservoir 
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1 Description of the problem 

An example of an axi-symmetrically circular cylindrical tank covered with a spherical dome roof is 

selected illustrate some features of ELPLA for analyzing shell elements. 

2 Tank geometry and properties 

Figure 5.1 shows half of an axial section of a large-diameter reinforced concrete circular cylindrical 

tank covered with a dome roof. The wall connection with the roof is monolithic, while the end of 

the wall is fixed at the base. Details concerning the geometry of the structure are  

shown in Figure 5.1. The elastic properties of the tank material are shown in Table 5.1.  

Only the self-weight is considered in this analysis. 

 

 
Figure 5.1 Radial section through the tank 

Table 5.1 Tank material 

Modulus of Elasticity of the tank material   Ec = 3×107 [kN/ m2] 

Poisson's ratio of the tank material    νc = 0.16             [-] 

Unit weight of the tank material                                      γc = 25  [kN/ m3] 
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3 Numerical Analysis 

In order to analyze the tank, the height of the wall is divided into 50 equal elements,  

each of 0.20 [m], while the roof shell (dome) is divided into 40 equal arcs each of 0.75 [°]  

as shown in Figure 5.2.  

 

 
Figure 5.2 Finite element mesh of the tank 

4 Creating the project 

In this section, the user will learn how to create a project for analyzing an axi-symmetrically circular 

cylindrical tank covered with a spherical dome roof. The project will be processed gradually  

to show the possibilities and abilities of the program. To enter the data of the example,  

follow the instructions and steps in the next paragraphs. 

4.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 5.3. This wizard will help the user to define the analysis type and the 

calculation method of the problem through a series of Forms. The first Form of  

"Calculation Methods" wizard is the "Analysis Type" Form (Figure 5.3). 
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Figure 5.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 5.3, define the analysis type of the problem.  

As the analysis type is a circular cylindrical covered with a spherical dome roof problem,  

select "Analysis of rotational Shell" button, and check "Shell with an opening base" option,  

then click "Next" button to go to the next Form.  
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The last Form in the wizard is the "Options" Form, Figure 5.4. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Select "Supports/ Boundary Conditions", then click the "Save" button. 

 

 
Figure 5.4 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 5.5. In this dialog box 

type a file name for the current project in "File name" edit box. For example, type "Tank with 

covered roof". ELPLA will use automatically this file name in all reading and writing processes. 
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Figure 5.5 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project [Tank with 

covered roof] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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4.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely 

entered. To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 5.6 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a tank covered with a spherical dome" 

- Type the date of the project in the "Date" edit box 

- Type the word "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 5.6 "Project Identification" dialog box 
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4.3 FE-Net data 

For the given problem, a tank covered with a dome roof has a lower radius of a = 15 [m],  

a clear height of Hw = 10 [m], and the radius of the spherical roof is R = 30.1 [m]. the height of the wall 

is divided into 50 equal elements, each of 0.20 [m], while the roof shell (dome) of 30[°] is divided 

into 40 equal arcs each of 0.75 [°] (gives also 40 elements). To define the FE-Net for this tank, 

choose "FE-Net Data" command from the “Data” Tab. "Analysis of rotational shell" wizard appears  

as shown in Figure 5.7. This wizard will guide you through the steps required to generate a FE-Net.  

 

The first Form of the wizard is the "Shell type" Form, which contains a group of templates of 

different shapes of nets. These net templates are used to generate standard nets. 

 

 
Figure 5.7 "Analysis of rotational shell" wizard with "Shell type" Form 
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To generate the FE-Net of the tank: 

 

- In the "Shell type" options choose "Irregular shell" button 

To define the base of the tank: 

• Type 15 in the "Tank base radius Rb" edit box 

  To define the height of the tank: 

• Choose "Linear segments" option 

• Type 10 in the "height Hw" edit box  

• Type 15 in the "Upper radius Ro" edit box, as the upper radius is the same as  

the base radius 

• Type 50 in the "Number of segments Ns" edit box 

To define the roof of the tank: 

• Check the "Shell with covered roof" check box 

• Choose "Spherical roof" option 

• Type 30.10 in the "Radius of the spherical roof" edit box  

• Type 30 in the "Angle of the spherical roof" edit box 

• Type 40 in the "Number of roof segments" edit box 

- Click "Next" button to go to the next Form 

 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Irregular shell" Form 

appears Figure 5.8, ELPLA divides the height of the wall into 50 equal elements, each of 0.20 [m], 

while the roof shell (dome) is divided into 40 equal arcs each of 0.75 [°], the user can edit the data 

of the segments individually by using "Modify" button, or all of them by using "In Table" button,  

if it is necessary. 
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Figure 5.8 "Irregular shell" Form 

Click "Finish" in "Analysis of rotational shell" wizard, to generate the FE-Net.  

The generated FE-Net appears Figure 5.9. 
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Figure 5.9 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 5.9 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 5.9 to close the "FE-Net" window and 

return to ELPLA main window 
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4.4 Shell properties 

To define the tank properties, choose "Shell Properties" command from “Data” Tab. The following 

window in Figure 5.10 appears with default shell properties. The data of shell properties for the 

current example, which are required to be defined, are element groups, group regions, unit weight  

of the tank, and filled material properties. 

 

 
Figure 5.10 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 5.11 appears. 

In this list box, define E-Modulus, Poisson’s ratio and slab thickness for both the tank wall  

and the tank roof as they differ in thickness. Then click "OK" button. 
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Figure 5.11 "Defining element groups" list box 

Defining the slab thickness for materials on the net may be carried out either graphically or numerically 

(in a table). In the current example, the user will define the slab thickness on the net graphically. 

 

To define the slab thickness for the tank roof  

 

- Choose "Select Elements" command from "Graphically" menu in the window  

of Figure 5.10.  

- When "Select Elements" command is chosen, the cursor will change from an arrow to  

a cross hair. A group of elements can be selected by holding the left mouse button down at 

the corner of the region. Then, drag the mouse until a rectangle encompasses the required group 

of elements. When the left mouse button is released, all elements in the rectangle are selected 

- Select the elements that include the tank roof as Figure 5.12 

- Choose "Elements Groups" command from "Graphically" menu in the window  

of Figure 5.10, "Group Regions" dialog box Figure 5.13 appears 

- Define the "Group No." as type "2", while "Group No." of the wall elements will be as  

type "1", where type "1" is the default "Group No." then click "OK" button 

 



Example 5  

 

 

   -5.15- 

 
Figure 5.12 Selecting the nodes that include the tank roof 

 

 
Figure 5.13 "Group Regions" dialog box 

To enter the unit weight of the tank, choose "Unit weight" command from "Shell Properties" menu 

in Figure 5.10. The following dialog box in Figure 5.14 with a default unit weight of 25 [kN/m3] appears, 

click "OK" button. 

 

 
Figure 5.14 "Unit weight" dialog box 
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To define the element size of the shell, choose "Filled material type/Element size" command from 

"Shell Properties" menu in Figure 5.10. The following form in Figure 5.15 appears. 

 

To define the element size of the ring wall: 

 

- Select "Empty container" option 

- Check the "Constant element sizes in z-direction" check box 

- Type 1 in the "Element size in each shell segment" edit box. The element size is chosen  

to be 1 [m] larger than the segment size in order to ignore further subdivision of the 

segments into smaller elements. In some cases, it is necessary to divide the segment into 

smaller elements in order to make the analysis more precise. Nevertheless, the final results 

of the internal forces appear only at nodes of segments 

- Click "OK" button 

 

 
Figure 5.15 "Liquid Properties/Element size" dialog box 
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Figure 5.16 "Shell Properties" window after defining the shell data 

After entering the tank properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 5.16 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 5.16 to close the "Shell properties" 

window and return to ELPLA main window 
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4.5 Supports/ boundary conditions 

To define the support, choose "Supports/ Boundary Conditions" command from “Data” Tab.  

The following window in Figure 5.17 appears. 

 

 
Figure 5.17 "Supports/ Boundary Conditions" Window 

To define the support on the net: 

 

- Choose "Select Nodes" command from "Graphically" menu in Figure 5.17. When "Select 

Nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the node that has the fixed support as shown in Figure 5.18 

- After selecting the node, choose "Add Supports/ Boundary Conditions" command  

from "Graphically" menu (Figure 5.17). The "Supports/ Boundary Conditions" dialog box  

in Figure 5.19 appears. 
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Figure 5.18 Selection of the node that has the fixed support 
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In this dialog box 

 

- Type 0 in the "Displacement u" edit box to define the horizontal fixed support 

- Type 0 in the "Displacement w" edit box to define the vertical fixed support 

- Type 0 in the "Rotation Theta" edit box to define the rotational fixed support 

- Click "OK" button 

 

 
Figure 5.19 "Supports/ Boundary Conditions" dialog box 
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Figure 5.20 "Supports/ Boundary Conditions" window after defining the support 

After defining the supports, do the following two steps 

 

- Choose "Save " command from "File" menu in Figure 5.20 to save the data of supports 

- Choose "Close" command from "File" menu in Figure 5.20 to close the "Supports/ Boundary 

conditions" window and return to the main window 
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4.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 5.21 appears. In ELPLA, entering loads may be carried out either numerically (in a table) 
or graphically using the commands of "Loads" Tab in Figure 5.21. In this example, there is not 
applied load, as the vertical load has been already defined by the unit weight of the tank. 
 

 
Figure 5.21 "Loads" Window 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 5.21 to save the load data 

- Choose "Close" command from "File" menu in Figure 5.21 to close the "Loads" window 

and return to ELPLA main window 

 

Creating the project of the tank is now complete. It is time to analyze this project.  

In the next section, you will learn how to use ELPLA for analyzing projects. 
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5 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 5.22. 

 

 
Figure 5.22 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (band matrix) 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab window.  

 

The progress of all computations according to the defined method will be carried out automatically 

with displaying Information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 5.23 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. In addition, a status bar down of the 

"Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 5.23 Analysis progress menu 
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Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 5.24. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 5.24 Menu "Check of the solution" 

Click "OK" button to finish analyzing the problem. 
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6 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through  

the "Results" Tab. To view the data and results of a problem that has already been defined  

and analyzed graphically, switch to "Results" Tab (Figure 5.25).  

 

 
Figure 5.25 "Results" Tab 

The "Result" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Rotational shell results 

- Support Reactions 

- Sections in shell wall 

- Display tables of data 

- Display tables of results 

 

To view element groups of the tank  

 

- Choose "Element groups" from "In Plan" command in "Data" menu. The following option 

box in Figure 5.25 appears 

- In the "Data – In Plan" option box, select "Element groups" as an example for the results  

to be displayed 

- Click "OK" button 

 

 
Figure 5.26 "Data – In Plan" option box 
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To view the supports / boundary conditions on the FE-Net and any other data 

 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command.  

The "View Grouping" check group box in Figure 5.27 appears 

- In this check group box, check "Supports Reactions Rv", "Supports Reactions Rh", "Supports 

Reactions Rm", "Supports /Boundary Conditions", "Meridional moments My" check boxes  

- The user can choose any other data to be viewed 

- Click "OK" button 

 

 
Figure 5.27 "View Grouping" check group box 

 
Figure 5.28 Element groups of the tank 
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1 Description of the problem 

An example of an axi-symmetrically circular cylindrical tank resting on elastic foundation  

using Winkler’s model is selected to illustrate some features of ELPLA for analyzing shell elements. 

2 Tank geometry and properties 

A circular cylindrical tank of an inner diameter of d = 13 [m] and a height of H = 3.5 [m]  

is considered as shown in Figure 6.1. Thickness of the tank wall is t = 0.175 [m]. The tank is filled 

with water. The soil under the base of the tank is represented by isolated springs of stiffness ks, 

which represent modulus of subgrade reaction. The tank material, unit weight of the water  

and the modulus of subgrade reaction are listed in Table 6.1.  

 

 
Figure 6.1 Circular cylindrical tank resting on isolated springs with dimensions 

Table 6.1 Tank material, water unit weight and modulus of subgrade reaction 

Modulus of Elasticity of the tank material   Ec = 2×107 [kN/ m2] 

Poisson's ratio of the tank material     νc = 0.2             [-] 

Unit weight of the tank material                           γc = 25  [kN/ m3] 

Unit weight of the water     γw  = 10  [kN/ m3] 

Modulus of subgrade reaction    ks  = 100 000 [kN/ m3] 
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t = 0.175 [m] 

ks = 100 000 [kN/ m3] 

Ec = 2×107 [kN/ m2] 

νc = 0.20    [-] 

γc = 25       [kN/ m3] 

γw = 10       [kN/ m3] 
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3 Numerical Analysis 

In order to analyze the tank, the height of the tank is divided into 35 equal segments, each of 0.10 [m],  

as shown in Figure 6.2. The base of the tank is divided into 50 equal segments, each of 0.13 [m].  

 

 
Figure 6.2 Finite element mesh of the tank 

4 Creating the project 

In this section, the user will learn how to create a project for analyzing an axi-symmetrically circular 

cylindrical tank resting on elastic foundation using Winkler’s model. The project will be processed 

gradually to show the possibilities and abilities of the program. To enter the data of the example, 

follow the instructions and steps in the next paragraphs. 

4.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 6.3. This wizard will help the user to define the analysis type and the 

calculation method of the problem through a series of Forms. The first Form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 6.3). 
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Figure 6.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 6.3, define the analysis type of the problem. As the analysis 

type is a circular cylindrical tank problem, select "Analysis of rotational Shell" button, and check 

"Shell with a raft foundation" option, then click "Next" button to go to the next Form. After clicking 

"Next" button, the "Calculation Methods" Form appears, Figure 6.4. 
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To define the calculation method: 

 

- Select the calculation method "2/3 Constant/ Variable Modulus of Subgrade Reaction" 

- To determine the modulus of subgrade reaction, select "Modulus is defined by the user"  

- Click "Next" button to go to the next Form 

 

 
Figure 6.4 "Calculation Method" Form 

The last Form in the wizard is the "Options" Form, Figure 6.5. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Since no option will be considered in the analysis, click the "Save" button. 
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Figure 6.5 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 6.6. In this dialog box 

type a file name for the current project in "File name" edit box. For example,  

type "Tank on Winkler's medium". ELPLA will use automatically this file name in all reading  

and writing processes. 

 

 

 



Analyzing Axisymmetric Structures and Tanks by ELPLA 

 
 

 -6.8- 

 
Figure 6.6 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project  

[Tank on Winkler's medium] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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4.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely 

entered. To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 6.7 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a tank resting on Winkler's medium" 

- Type the date of the project in the "Date" edit box 

- Type the word "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 6.7 "Project Identification" dialog box 

4.3 FE-Net data 

For the given problem, the tank has an inner diameter of d = 13 [m] and a height of H = 3.5 [m].  

the tank height is divided into 35 equal segments, each of 0.10 [m], where the base of the tank  

is divided into 50 equal segments, each of 0.13 [m]. To define the FE-Net for this tank,  

choose "FE-Net Data" command from the “Data” Tab. "Analysis of rotational shell" wizard appears 

as shown in Figure 6.8. This wizard will guide you through the steps required to generate a FE-Net.  

 

The first Form of the wizard is the "Shell type" Form, which contains a group of templates of 

different shapes of nets. These net templates are used to generate standard nets. 
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Figure 6.8 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 

 

- In the "Shell type" options choose "Cylindrical shell" button 

- Type 3.5 in the "Height" edit box  

- Type 6.5 in the "Radius" edit box  

- Type 35 in the "Number of segments" edit box 

- Click "Next" button to go to the next Form 

 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Cylindrical shell" 

Form appears Figure 6.9, ELPLA divides the height of the tank into 35 equal segments,  

the user can edit the data of the segments individually by using "Modify" button, or all of them  

by using "In Table" button, if it is necessary. 
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Figure 6.9 "Cylindrical shell" Form 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Net of Base" Form 

appears Figure 6.10. 
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To edit the grid spacing in x-direction, do the following steps in "Grid in x-direction" frame: 

- Choose "Constant grid interval" check box  

- Type 50 in the "No. of grid intervals" edit box 

 

 
Figure 6.10 "Net of Base" Form 

Click "Finish" button, the FE-Net of the tank wall and a sector from the base appear in Figure 6.11 
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Figure 6.11 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 6.11 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 6.11 to close the "FE-Net" window 

and return to ELPLA main window 
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4.4 Shell properties 

To define the tank properties, choose "Shell Properties" command from “Data” Tab. The following 

window in Figure 6.12 appears with default shell properties. The data of shell properties for the 

current example, which are required to be defined, are element groups, unit weight of the tank,  

and filled material properties. 

 

 
Figure 6.12 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 6.13 appears. 

In this list box, enter E-Modulus, Poisson’s ratio and slab thickness. Then click "OK" button. 
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Figure 6.13 "Defining element groups" list box 

To enter the unit weight of the tank, choose "Unit weight" command from "Shell Properties" menu 

in Figure 6.12. The following dialog box in Figure 6.14 with a default unit weight of 25 [kN/m3] appears, 

click "OK" button. 

 

 
Figure 6.14 "Unit weight" dialog box 
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To define the liquid properties of the shell, choose "Filled material type/Element size" command 

from "Shell Properties" menu in Figure 6.12. The following form in Figure 6.15 appears. 

 

To define the liquid properties of the tank: 

 

- Select the "Liquid container" option 

- Type 3.5 in the "Height of the liquid" edit box 

- Type 10 in the "Unit weight of the liquid" edit box 

 

To define the element size of the tank: 

 

- Check the "Constant element sizes in z-direction" check box 

- Type 1 in the "Element size in each shell segment" edit box. The element size is chosen  

to be 1 [m] larger than the segment size in order to ignore further subdivision of the 

segments into smaller elements. In some cases, it is necessary to divide the segment into 

smaller elements in order to make the analysis more precise. Nevertheless, the final results 

of the internal forces appear only at nodes of segments 

- Click "OK" button 

 

 
Figure 6.15 "Liquid properties/Element size" Form 

After entering the shell properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 6.12 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 6.12 to close the "Shell properties" 

window and return to ELPLA main window 
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4.5 Soil Properties 

To define the soil properties, choose "Soil Properties" command from “Data” Tab. The following 

"Soil Properties" form in Figure 6.16 appears, enter the modulus of subgrade reaction of the soil and  

the ground water depth under the ground surface. Other data for this example is not required. 

 

Soil data 

Modulus of subgrade reaction    ks  = 100 000 [kN/ m3] 

Ground water depth under the surface   Gw  = 1  [m] 

 

 
Figure 6.16 "Soil Properties" Form 
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4.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 6.17 appears. In ELPLA, entering loads may be carried out either numerically (in a table) 
or graphically using the commands of "Loads" tab in Figure 6.17. In this example, there is not 
applied load, as the vertical load has been already defined by the unit weight of the tank,  
while the hydrostatic pressure on the tank wall is defined by the unit weight of water. 
 

 
Figure 6.17 "Loads" Window 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 6.17 to save the load data 

- Choose "Close" command from "File" menu in Figure 6.17 to close the "Loads" window 

and return to ELPLA main window 

 

Creating the project of the tank is now complete. It is time to analyze this project. In the next 

section, you will learn how to use ELPLA for analyzing projects. 
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5 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 6.18. 

 

 
Figure 6.18 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Determining the modulus of subgrade reaction 

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (band matrix) 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab Window.  

 

The progress of all computations according to the defined method will be carried out automatically 

with displaying Information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 6.19 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. In addition, a status bar down of the 

"Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 6.19 Analysis progress menu 
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Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 6.20. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 6.20 Menu "Check of the solution" 

Click "OK" button to finish analyzing the problem. 
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6 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through the 

"Results" Tab. 

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

switch to "Results" Tab (Figure 6.21).  

 

 
Figure 6.21 "Results" Tab 

The "Results" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Rotational shell results 

- Sections in shell wall 

- Sections in shell base 

- Display tables of data 

- Display tables of results 

 

To view the radial forces in the shell wall  

 

- Choose "Sections in shell wall" command from "Section" menu. The following option box 

in Figure 6.22 appears 

- In the "Sections in shell wall" option box, select "Radial forces Nr" as an example for the 

results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 6.23. 

 

 
Figure 6.22 "Sections in shell wall" option box 
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Figure 6.23 Radial forces in shell wall 

To view the meridional moments on the shell wall  

 

- From "Rotational shell results" command in the "Results" menu, choose "In Plan" command, 

the following option box in Figure 6.24 appears 

- In the "Distribution of Internal Forces" option box, select "Meridional moments My"  

as an example for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 6.23. 

 

 
Figure 6.24 "Distribution of Internal Forces" option box 
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Figure 6.25 Meridional moments on the shell wall 
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1 Description of the problem 

An example of a circular cylindrical tank with a conical base resting on elastic foundation using 

Winkler’s model is selected to illustrate some features of ELPLA for analyzing circular cylindrical 

shell elements. 

2 Loads 

A circular cylindrical tank of an inner diameter of d = 15 [m] and a height of H = 6 [m]  

is considered as shown in Figure 7.1. Thickness of the tank wall is t = 0.5 [m]. The tank is filled 

with water. The soil under the base of the tank is represented by isolated springs of stiffness ks, 

which represent modulus of subgrade reaction. Figure 7.1 shows the tank with dimensions,  

while the tank material, unit weight of the water and the modulus of subgrade reaction are listed  

in Table 7.1. 

 

 
Figure 7.1 Circular cylindrical tank on isolated springs with dimensions 

Table 7.1 Tank material, water unit weight and modulus of subgrade reaction 

Modulus of Elasticity of the tank material   Ec = 2×107 [kN/ m2] 

Poisson's ratio of the tank material     νc = 0.2             [-] 

Unit weight of the tank material                           γc = 25  [kN/ m3] 

Unit weight of the water     γw  = 10  [kN/ m3] 

Modulus of subgrade reaction    ks  = 100 000 [kN/ m3] 

 

 

Ec = 2×107 [kN/ m2] 

νc = 0.20    [-] 

γc = 25       [kN/ m3] 

γw = 10       [kN/ m3] H
 =

 6
 [

m
] 

t = 0.5 [m] 

a = 7.5 [m] 

ks = 100 000 [kN/ m3] 

0.85 [m] 
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3 Numerical Analysis 

In the analysis, the height of the tank is divided into 20 equal elements, each of 0.30 [m], as shown 

in Figure 7.2 . The conical base of the tank is divided into 17 equal elements. 

 

 

 
Figure 7.2 Finite element mesh of the tank 

4 Creating the project 

In this section, the user will learn how to create a project for analyzing an axi-symmetrically circular 

cylindrical tank resting on elastic foundation using Winkler’s model. The project will be processed 

gradually to show the possibilities and abilities of the program. To enter the data of the example, 

follow the instructions and steps in the next paragraphs. 

4.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 7.3. This wizard will help the user to define the analysis type and the 

calculation method of the problem through a series of Forms. The first Form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 7.3). 
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Figure 7.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 7.3, as the analysis type is a circular cylindrical tank problem, 

select "Analysis of rotational Shell" button and check "Shell with a raft foundation" option, then click 

"Next" button to go to the next Form. After clicking "Next" button, the "Calculation Methods" Form 

appears, Figure 7.4. 
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To define the calculation method: 

 

- Select the calculation method "2/3 Constant/ Variable Modulus of Subgrade Reaction" 

- To determine the modulus of subgrade reaction, select "Modulus is defined by the user" 

- Click "Next" button to go to the next Form. 

 

 
Figure 7.4 "Calculation Method" Form 
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The last Form in the wizard is the "Options" Form, Figure 7.5. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Select "Additional Springs", then click the "Save" button. 

 

 
Figure 7.5 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 7.6. In this dialog box 

type a file name for the current project in "File name" edit box. For example, type "Conical Tank". 

ELPLA will use automatically this file name in all reading and writing processes. 
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Figure 7.6 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project  

[Conical Tank] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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4.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely 

entered. To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 7.7 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a tank with conical base resting on Winkler's medium" 

- Type the date of the project in the "Date" edit box 

- Type the word "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 7.7 "Project Identification" dialog box 

4.3 FE-Net data 

For the given problem, a cylindrical water container with a conical base of a radius of a = 7.5 [m]  

and a height of H = 6 [m] is considered, the height of the tank is divided into two main segments, 

the main segment of the wall is divided into 20 elements (20×0.3 [m]), while the conical part is 

divided into 17 elements.  

 

To define the FE-Net for this tank, choose "FE-Net Data" command from the “Data” Tab. "Analysis of 

rotational shell" wizard appears as shown in Figure 7.8. This wizard will guide you through the steps 

required to generate a FE-Net, the first Form of the wizard is the "Shell type" Form, which contains a 

group of templates of different shapes of nets. These net templates are used to generate standard nets. 
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Figure 7.8 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 
 

- In the "Shell type" options choose "Irregular shell" button 
- Type 0.6 in the "Radius of the tank base" edit box,  
 
To identify the foundation segment    

 
• Type 0.6 in the "Height" edit box 
• Type 0.6 in the "Upper radius" edit box 
• Type 3 in the "Number of segments" edit box 
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To identify the segment of the conical part 
 

• Type 0.85 in the "Height" edit box 
• Type 7.5 in the "Upper radius" edit box 
• Type 17 in the "Number of segments" edit box 

 
To identify the segment of the tank height 

 
• Type 6 in the "Height" edit box 
• Type 7.5 in the "Upper radius" edit box 
• Type 20 in the "Number of segments" edit box 

- Click "Next" button to go to the next Form 

 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Irregular shell" Form 

containing the data of the segments appears in Figure 7.9, The user can edit the data of each 

segment individually or all of them by using "In Table" button. 
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Figure 7.9 " Irregular shell" Form 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Net of Base" Form 

appears Figure 7.10. 
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To edit the grid spacing in x-direction of the tank foundation, do the following steps  

in "Grid in x-direction" frame: 

- Choose "Constant grid interval" check box 

- Type 10 in the "No. of grid intervals" edit box 

 

 
Figure 7.10 "Net of Base" Form 

Click "Finish" button, the FE-Net of the wall and a sector from the base appears in Figure 7.11 
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Figure 7.11 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 7.11 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 7.11 to close the "FE-Net" window 

and return to ELPLA main window 
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4.4 Shell properties 

To define the tank properties, choose "Shell Properties" command from “Data” Tab. The following 

window in Figure 7.12 appears with default shell properties. The data of shell properties for the 

current example, which are required to be defined, are element groups, unit weight of the tank,  

and the filled material properties. 

 

 
Figure 7.12 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 7.13 appears. 

In this list box, enter E-Modulus, Poisson’s ratio and slab thickness. Then click "OK" button. 
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Figure 7.13 "Defining element groups" list box 

To enter the unit weight of the tank, choose "Unit weight" command from "Shell Properties" menu 

in Figure 7.12. The following dialog box in Figure 7.14 with a default unit weight of 25 [kN/m3] appears, 

click "OK" button. 

 

 
Figure 7.14 "Unit weight" dialog box 
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To define the filled material properties of the tank, choose "Filled material type/Element size" 

command from "Shell Properties" menu in Figure 7.12. The following form in Figure 7.15 appears. 

 

To define the filled material properties of the Tank: 

 

- Select "Liquid container" option  

- Type 6.85 in the "Height of the liquid" edit box 

- Type 9.81 in the "Unit weight of the liquid" edit box 

 

To define the element size of the tank: 

 

- Check the "Constant element sizes in z-direction" check box 

- Type 0.2 in the "Element size in each shell segment" edit box 

- Click "OK" button 

 

 
Figure 7.15 "Liquid properties/Element size" Form 

After defining the shell properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 7.12 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 7.12 to close the "Shell properties" 

window and return to ELPLA main window 
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4.5 Soil Properties 

To define the soil properties, choose "Soil Properties" command from “Data” Tab. The following 

"Soil Properties" form in Figure 7.16 appears, enter Modulus of subgrade reaction of the soil and  

the ground water under the surface. Other data in the example are not required. 

 

Soil data: 

 

Modulus of subgrade reaction    ks  = 100 000 [kN/ m3] 

Ground water depth under the surface   Gw  = 1  [m] 

 

 
Figure 7.16 "Soil Properties" form 

 

 

 

 

 

 

 

 

 

 

 

 

 



Example 7  

 

 

   -7.19- 

4.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 7.17 appears. 
 
In ELPLA, entering loads may be carried out either numerically (in a table) or graphically using the 
commands of "Loads" Tab in Figure 7.17. In this example, there is not applied load, as the vertical 
load has been already defined by the unit weight of the tank, while the hydrostatic pressure on the 
tank wall is defined by the unit weight of water. 
 

 
Figure 7.17 "Loads" Window 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 7.17 to save the load data 

- Choose "Close" command from "File" menu in Figure 7.17 to close the "Loads" window 

and return to ELPLA main window 
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4.7 Spring Supports 

To define the Spring supports, choose "Spring Supports" command from “Data” Tab. The following 
window in Figure 7.18 appears. 
 

 
Figure 7.18 "Spring Supports" Window 

To define the spring supports on the net: 

 

- Choose "Select Nodes" command from "Graphically" menu in Figure 7.18. When "Select 

Nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the node that has the spring support as shown in Figure 7.19 

- After selecting the nodes, choose "Add Spring Supports" command from "Graphically" 

menu (Figure 7.18). The "Edit Spring Support" dialog box in Figure 7.20 appears. 
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Figure 7.19 Selection of the nodes that have the spring support 

 

 
Figure 7.20 "Edit Spring Support" dialog box 
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Figure 7.21 "Edit Spring Support" dialog box 
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Figure 7.22 "Edit Spring Support" dialog box 
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Figure 7.23 "Spring Supports" window after defining the springs 

After defining the spring supports, do the following two steps 

 

- Choose "Save " command from "File" menu in Figure 7.23 to save the data of the springs 

- Choose "Close" command from "File" menu in Figure 7.23 to close the "Spring Supports" 

window and return to the main window 

 

Creating the project of the tank is now complete. It is time to analyze this project. In the next 

section, you will learn how to use ELPLA for analyzing projects. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Example 7  

 

 

   -7.25- 

5 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 7.24. 

 

 
Figure 7.24 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 
Commands of calculation depend on the used calculation method in the analysis. For this project, 
the items that are required to be calculated are: 
 

- Assembling the load vector 
- Determining the modulus of subgrade reaction 
- Assembling the slab stiffness matrix 
- Solving the system of linear equations (band matrix) 
- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab Window.  

 

The progress of all computations according to the defined method will be carried out automatically 

with displaying Information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 7.25 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. In addition, a status bar down of the 

"Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 7.25 Analysis progress menu 
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Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 7.26. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 7.26 Menu "Check of the solution" 

Click "OK" button to finish analyzing the problem. 
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6 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through the 

"Results" Tab. 

 

To view the data and results of a problem that has already been defined and analyzed graphically, 

switch to "Results" Tab (Figure 7.27).  

 

 
Figure 7.27 "Results" Tab 

The "Results" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Rotational shell results 

- Sections in shell wall 

- Sections in shell base 

 

To view the radial forces in the shell wall:  

 

- Choose "Sections in shell wall" command from "Section" menu. The following option box 

in Figure 7.28 appears 

- In the "Sections in shell wall" option box, select "Radial forces Nr" as an example for the 

results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 7.29. 

 

 
Figure 7.28 "Sections in shell wall" option box 
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Figure 7.29 Radial forces in shell wall 

To view element groups of the tank  

 

- Choose "Element groups" from "In Plan" command in "Data" menu. The following option 

box in Figure 7.30 appears 

- In the "Data – In Plan" option box, select "Element groups" as an example for the results  

to be displayed 

- Click "OK" button 

 

 
Figure 7.30 "Data – In Plan" option box 
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To view the meridional moments on the FE-Net and any other data 

 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command.  

The "View Grouping" check group box in Figure 7.31 appears 

- In this check group box, check "Meridional moments My" check box  

- The user can choose any other data to be viewed 

- Click "OK" button 

 

 
Figure 7.31 "View Grouping" check group box 

 
Figure 7.32 Element groups of the tank 
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1 Description of the problem 

An example of a circular cylindrical tank resting on an isotropic elastic half space soil medium 

is selected to illustrate some features of ELPLA for analyzing shell elements. 

2 Tank geometry and properties 

A circular cylindrical tank of an inner diameter of d = 18 [m] and a height of H = 7.5 [m]  

is considered as shown in Figure 8.1. The thickness of the tank wall and base is t = 0.36 [m].  

The tank is filled with water. Figure 8.1 shows the storage tank with dimensions, while the tank 

material and unit weight of the water are listed in Table 8.1. The data of soil medium under the base 

of the tank are shown in Table 8.2. 

 

 
Figure 8.1 Circular cylindrical tank resting on an isotropic elastic soil medium 

Table 8.1 Tank material and water unit weight  

Modulus of Elasticity of the tank material  Ec = 1.4×107 [kN/ m2] 

Poisson's ratio of the tank material    νc = 0.2             [-] 

Unit weight of the water    γw  = 9.81  [kN/ m3] 

Unit weight of the tank material   γb  = 25  [kN/ m3] 

Table 8.2 Soil data  

Modulus of Elasticity of the soil medium  E = 20000  [kN/m2] 

Poisson's ratio of the soil medium    νs = 0.4      [-] 

 

 

 

H
 =

 7
.5

 [
m

] 

d = 18 [m] 

Ec = 1.4×107[kN/ m2] 

νc = 0.0     [-] 

γw = 9.81      [kN/ m3] 

Isotropic elastic soil medium 

E = 20000 [kN/ m2] 

νs = 0.4      [-] 

a = 9 [m] 

t = 0.36 [m] 
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3 Numerical Analysis 

In order to analyze a water storage tank resting on an isotropic elastic half space soil medium using 

ELPLA. The height of the tank is divided into 30 equal segments, each of 0.25 [m], as shown in 

Figure 8.2, while the base of the tank is divided into 45 equal segments, each of 0.2 [m]. 

 

 
Figure 8.2 Finite element mesh of the tank 

4 Creating the project 

In this section, the user will learn how to create a project for analyzing a circular cylindrical tank 

resting on an isotropic elastic soil medium. The project will be processed gradually to show the 

possibilities and abilities of the program. To enter the data of the example, follow the instructions 

and steps in the next paragraphs. 

4.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 8.3. This wizard will help the user to define the analysis type  

and the calculation method of the problem through a series of forms. The first form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 8.3). 
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m
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Figure 8.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 8.3, define the analysis type of the problem. As the analysis 

type is a circular cylindrical tank resting on an isotropic elastic soil medium problem,  

select "Analysis of rotational Shell" button, and check "Shell with a raft foundation" option then 

click "Next" button to go to the next form. After clicking "Next" button, the "Calculation Method" 

Form appears, Figure 8.4. 
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To define the calculation method: 

 

- Select the calculation method "6-Modulus of Compressibility (Iteration)" 

- To determine the subsoil model, select "Half Space model"  

- Click "Next" button to go to the next form 

 

 
Figure 8.4 "Calculation Method" Form 

The last Form in the wizard is the "Options" Form, Figure 8.5. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Since no option will be considered in the analysis, click the "Save" button. 
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Figure 8.5 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 8.6. In this dialog box 

type a file name for the current project in "File name" edit box. For example,  

type "tank resting on half space soil medium". ELPLA will use automatically this file name in all 

reading and writing processes. 
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Figure 8.6 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project [tank resting on 

half space soil medium] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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4.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely 

entered. To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 8.7 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a tank resting on a half space soil medium" 

- Type the date of the project in the "Date" edit box 

- Type "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 8.7 "Project Identification" dialog box 

4.3 FE-Net data 

For the given problem, the tank has an inner diameter of d = 18 [m] and a height of H = 7.5 [m],  

the height of the tank is divided into 30 equal segments, each of 0.25 [m], and the base of the tank is 

divided into 45 equal segments, each of 0.2 [m]. To define the FE-Net for this tank,  

choose "FE-Net Data" command from the “Data” Tab. "Analysis of rotational shell" wizard appears 

as shown in Figure 8.8. This wizard will guide you through the steps required to generate a FE-Net.  

 

The first form of the wizard is the "Shell type" Form, which contains a group of templates of 

different shapes of nets. These net templates are used to generate standard nets. 
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Figure 8.8 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 

 

- In the "Shell type" options choose "Cylindrical shell" button 

- Type 7.5 in the "Height" edit box 

- Type 9 in the "Radius" edit box 

- Type 30 in the "Number of segments" edit box 

- Click "Next" button to go to the next Form 

-  

 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Cylindrical shell" 

Form appears Figure 8.9, ELPLA divides the height of the tank into 30 equal segments,  

the user can edit the data of the segments individually by using "Modify" button, or all of them  

by using "In Table" button, if it is necessary. 
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Figure 8.9 "Cylindrical shell" Form 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Net of Base" 

Form appears Figure 8.10. 
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To edit the grid spacing in x-direction, do the following steps in "Grid in x-direction" frame: 

- Choose "Constant grid interval" check box  

- Type 45 in the "No. of grid intervals" edit box, the base of the tank is divided into 45 equal 

segments, each of 0.2 [m] 

 

 
Figure 8.10 "Net of Base" Form  

Click "Finish" button, the FE-Net of the tank wall and a sector from the base appears in Figure 8.11. 
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Figure 8.11 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 8.11 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 8.11 to close the "FE-Net" window 

and return to ELPLA main window 
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4.4 Shell properties 

To define the tank properties, choose "Shell Properties" command from “Data” Tab. The following 

window in Figure 8.12 appears with default shell properties. The data of shell properties for the 

current example, which are required to be defined, are element groups, unit weight of the tank,  

and filled material properties. 

 

 
Figure 8.12 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 8.13 appears. 

In this list box, enter E-Modulus, Poisson’s ratio and slab thickness. Then click "OK" button. 
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Figure 8.13 "Defining element groups" list box 

To enter the unit weight of the tank, choose "Unit weight" command from "Shell Properties" menu 

in Figure 8.12. The following dialog box in Figure 8.14 with a default unit weight of 25 [kN/m3] appears, 

click "OK" button. 

 

 
Figure 8.14 "Unit weight" dialog box 
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To define the liquid properties of the shell, choose "Filled material type/Element size" command 

from "Shell Properties" menu in Figure 8.12. The following form in Figure 8.15 appears. 

 

To define the filled material properties of the tank: 

 

- Select the "Liquid container" option 

- Type 7.5 in the "Height of the liquid" edit box 

- Type 9.81 in the "Unit weight of the liquid" edit box 

 

To define the element size of the ring: 

 

- Check the "Constant element sizes in z-direction" check box 

- Type 0.2 in the "Element size in each shell segment" edit box 

- Click "OK" button 

 

 
Figure 8.15 "Liquid Properties/Element size" Form 

After entering the shell properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 8.12 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 8.12 to close the "Shell 

properties" window and return to ELPLA main window 
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4.5 Soil Properties 

To define the soil properties, choose "Soil Properties" command from “Data” Tab. The following 

"Soil Properties" form in Figure 8.16 appears, the soil properties are defined by Modulus of 

Elasticity "E", and is supposed to have the following parameters: 

 

Modulus of Elasticity of the soil E  = 20000  [kN/m2] 

Unit weight of the soil GAM  = 18  [kN/m3] 

Angle of internal friction 

Cohesion of the soil 

Poisson's ratio of the soil medium   

FHI = 30   [˚] 

c  = 0  [kN/m2] 

νs = 0.4       [-] 

 

Other data in the example is not required, the user can use the default values. 

 

 
Figure 8.16 "Soil Properties" Form 

After defining the soil properties, click "Save" button. 
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4.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 8.17 appears. In ELPLA, entering loads may be carried out either numerically (in a table) 
or graphically using the commands of "Loads" Tab in Figure 8.17. In this example, there is not 
applied load, as the vertical load has been already defined by the unit weight of the tank material, 
while the hydrostatic pressure on the tank wall is defined by the unit weight of water. 
 

 
Figure 8.17 "Loads" Window 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 8.17 to save the load data 

- Choose "Close" command from "File" menu in Figure 8.17 to close the "Loads" window 

and return to ELPLA main window 

 

Creating the project of the tank is now complete. It is time to analyze this project.  

In the next section, you will learn how to use ELPLA for analyzing projects. 
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5 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 8.18. 

 

 
Figure 8.18 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Determining flexibility coefficients of the soil 

- Assembling the soil stiffness matrix 

- Assembling the slab stiffness matrix 

- Iteration process 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

Carrying out all computations 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab Window. The following 

"Iteration parameters" option box in Figure 8.19 appears 

- For this example, choose an accuracy of 0.0001 [m] to end the iteration process 

- Click "OK" button 

 

 
Figure 8.19 "Iteration parameters" option box 
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The progress of all computations according to the defined method will be carried out automatically 

with displaying Information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 8.20 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. In addition, a status bar down  

of the "Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 8.20 Analysis progress menu 

"Check of convergence" message Figure 8.21 appears showing that no convergence is reached 

 at the last step, click "Ok" button. 

 

 
Figure 8.21 "Check of convergence" message 
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Click "Stop" button (Figure 8.22), to stop the iteration process as no convergence has reached. 
 

 
Figure 8.22  "Iteration process" list box 

Check of the solution 

Once the analysis is carried out, a check menu of the solution appears, Figure 8.23. This menu 
compares between the values of actions and reactions. Through this comparative examination,  
the user can assess the calculation accuracy.  

 

 
Figure 8.23 Menu "Check of the solution" 

Click "OK" button to finish analyzing the problem. 
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6 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through  

the "Results" Tab. To view the data and results of a problem that has already been defined  

and analyzed graphically, switch to "Results" Tab (Figure 8.24).  

 

 
Figure 8.24 "Results" Tab 

The "Result" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Rotational shell results 

- Sections in shell base 

- Sections in shell wall 

- Display tables of data 

- Display tables of results 

 

To view the radial forces in the shell wall  

 

- Choose "Sections in shell wall" command from "Section" menu. The following option box 

in Figure 8.25 appears 

- In the "Sections in shell wall" option box, select "Radial forces Nr" as an example  

for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 8.26. 

 

 
Figure 8.25 "Sections in shell wall" option box 
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Figure 8.26 Radial forces in shell wall 
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To view the meridional moments in the shell base  

 

- Choose "Sections in shell base" command from "Section" menu. The following option box 

in Figure 8.27 appears 

- In the "Sections in shell base" option box, select "Meridional moments My" as an example  

for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 8.28. 

 

 
Figure 8.27 "Sections in shell base" option box 
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Figure 8.28 Meridional moments in shell base 

To view element groups of the tank  

 

- Choose "Element groups" from "In Plan" command in "Data" menu. The following option 

box in Figure 8.29 appears 

- In the "Data – In Plan" option box, select "Element groups" as an example for the results  

to be displayed 

- Click "OK" button 

 

 
Figure 8.29 "Data – In Plan" option box 
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To view the meridional moments on the FE-Net and any other data 

 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command.  

The "View Grouping" check group box in Figure 8.30 appears 

- In this check group box, check "Meridional moments My" check box 

- The user can choose any other data to be displayed 

- Click "OK" button 

 

 
Figure 8.30 "View Grouping" check group box 

 
Figure 8.31 Element groups 
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1 Description of the problem 

An example of a circular cylindrical storage tank resting on an isotropic elastic half space soil 

medium is selected to and illustrate some features of ELPLA for analyzing circular cylindrical shell 

elements. 

2 Tank geometry and properties 

A circular cylindrical tank of an inner diameter of d = 20 [m] and a height of H = 10 [m]  

is considered as shown in Figure 9.1. Thicknesses of the wall and the base are different.  

The thickness of the tank wall is tw = 0.2 [m] and that of the base is tb = 0.5 [m]. The tank is filled  

with water. Figure 9.1 shows the storage tank, while the tank material and unit weight of the water 

are listed in Table 9.1. The data of soil medium under the base of the tank are shown in Table 9.2. 

 

 
Figure 9.1 Circular cylindrical tank resting on an isotropic elastic soil medium 

Table 9.1 Tank material and water unit weight  

Modulus of Elasticity of the tank material   Ec = 2×107 [kN/ m2] 

Poisson's ratio of the tank material     νb = 0.16  [-] 

Unit weight of the tank material    γb = 24  [kN/ m3] 

Unit weight of the water     γw  = 10.19 [kN/ m3] 

Table 9.2 Soil data  

Modulus of Elasticity of the soil medium   E = 20000 [kN/m2] 

Poisson's ratio of the soil medium     νs = 0.2  [-] 

Ec = 2 ×107 [kN/ m2] 

νc = 0.16  [-] 

γb = 24  [kN/ m3] 

γw = 10.19 [kN/ m3] 

 

H
 =

 1
0
 [

m
] 

d = 20 [m] 

a = 10 [m] 

Isotropic elastic soil medium 

E = 20000 [kN/ m2] 

νs = 0.2      [-] 

tw = 0.2 [m] 

tb = 0.5 [m] 
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3 Numerical Analysis 

In order to analyze a water storage tank resting on an isotropic elastic half space soil medium using 

ELPLA, this example shown in Figure 9.1 is analyzed. The height of the tank is divided  

into 50 equal segments, each of 0.20 [m], as shown in Figure 9.2, while the half base of the tank is 

divided into 50 equal segments, each of 0.20 [m]. 

 

 
Figure 9.2 Finite element mesh of the tank 
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4 Creating the project 

In this section, the user will learn how to create a project for analyzing a tank resting on an isotropic 

elastic half space soil medium. The project will be processed gradually to show the possibilities  

and abilities of the program. To enter the data of the example, follow the instructions and steps  

in the next paragraphs. 

4.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 9.3. This wizard will help the user to define the analysis type  

and the calculation method of the problem through a series of forms. The first form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 9.3). 

 

 
Figure 9.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 9.3, define the analysis type of the problem. As the analysis 

type is a tank resting on an isotropic elastic half space soil medium problem,  

select "Analysis of rotational Shell" button, and check "Shell with a raft foundation" option, 

then click "Next" button to go to the next Form. After clicking "Next" button, the "Calculation 

Method" Form appears, Figure 9.4. 
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To define the calculation method: 

 

- Select the calculation method "4-Modification of Modulus of Subgrade Reaction by Iteration" 

- To determine the subsoil model, select "Half Space model"  

- Click "Next" button to go to the next Form 

 

 
Figure 9.4 "Calculation Method" Form 

The last Form in the wizard is the "Options" Form, Figure 9.5. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Since no option will be considered in the analysis, click the "Save" button. 
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Figure 9.5 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 9.6. In this dialog box 

type a file name for the current project in "File name" edit box. For example,  

type "Tank with different base thickness". ELPLA will use automatically this file name  

in all reading and writing processes. 
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Figure 9.6 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project [Tank with 

different base thickness] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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4.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely entered. 

To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 9.7 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a tank resting on a half space soil medium" 

- Type the date of the project in the "Date" edit box 

- Type "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 9.7 "Project Identification" dialog box 

4.3 FE-Net data 

For the given problem, a circular cylindrical tank of an inner diameter of d = 20 [m]  

and a height of H = 10 [m], the height of the tank is divided into 50 equal segments, each of 0.20 [m], 

while the half base of the tank is divided into 50 equal segments, each of 0.20 [m].  

To define the FE-Net for this tank, choose "FE-Net Data" command from the “Data” Tab.  

"Analysis of rotational shell" wizard appears as shown in Figure 9.8. This wizard will guide you 

through the steps required to generate a FE-Net. 

 

The first Form of the wizard is the "Shell type" Form, which contains a group of templates of 

different shapes of nets. These net templates are used to generate standard nets. 
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Figure 9.8 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 

 

- In the "Shell type" options choose "Cylindrical shell" button 

- Type 10 in the "Height" edit box 

- Type 10 in the "Radius" edit box 

- Type 50 in the "Number of segments" edit box 

- Click "Next" button to go to the next Form 

 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Cylindrical shell" 

Form appears Figure 9.9, ELPLA divides the height of the tank into 50 equal segments,  

the user can edit the data of the segments individually by using "Modify" button, or all of them  

by using "In Table" button, if it is necessary. 
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Figure 9.9 "Cylindrical shell" Form 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Net of Base" 

Form appears Figure 9.10. 
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To edit the grid spacing in x-direction, do the following steps in "Grid in x-direction" frame: 

- Choose "Constant grid interval" check box 

- Type 50 in the "No. of grid intervals" edit box, the base of the tank is divided into 50 equal 

elements, each of 0.2 [m] 

 

 
Figure 9.10 "Net of Base" Form 

Click "Finish" button, the FE-Net of the tank wall and a sector from the base appears in Figure 9.11. 
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Figure 9.11 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 9.11 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 9.11 to close the "FE-Net" window 

and return to ELPLA main window 
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4.4 Shell properties 

To define the tank properties, choose "Shell Properties" command from “Data” Tab. The following 

window in Figure 9.12 appears with default shell properties. The data of shell properties for the 

current example, which are required to be defined, are element groups, group regions, unit weight of 

the tank, and the filled material properties. 

 

 
Figure 9.12 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 9.13 appears. 

In this list box, define E-Modulus, Poisson’s ratio and slab thickness for both the tank wall  

and the tank base, as they differ in thickness. Then click "OK" button. 
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Figure 9.13 "Defining element groups" list box 

Defining the slab thickness for materials on the net may be carried out either graphically or numerically 

(in a table). In the current example, the user will define the slab thickness on the net graphically. 

 

To define the slab thickness for the tank base  

 

- Choose "Select Elements" command from "Graphically" menu in the window  

of Figure 9.12.  

- When "Select Elements" command is chosen, the cursor will change from an arrow to  

a cross hair. A group of elements can be selected by holding the left mouse button down  

at the corner of the region. Then, drag the mouse until a rectangle encompasses the required 

group of elements. When the left mouse button is released, all elements in the rectangle are selected 

- Select the elements that include the tank base as shown in Figure 9.14 

- Choose "Elements Groups" command from "Graphically" menu in the window  

of Figure 9.12, "Group Regions" dialog box Figure 9.15 appears 

- Define the "Group No." as type "2", while "Group No." of the tank wall elements will be  

as type "1", where type "1" is the default "Group No.", then click "OK" button 
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Figure 9.14 Selecting the nodes that include the tank base 

 
Figure 9.15 "Group Regions" dialog box 

To enter the unit weight of the tank, choose "Unit weight" command from "Shell Properties" menu 

in Figure 9.12. The following dialog box in Figure 9.16 with a default unit weight of 25 [kN/m3] appears, 

type 24 in the "Unit Weight" edit box, then click "OK" button. 

 

 
Figure 9.16 "Unit weight" dialog box 
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To define the filled material properties of the shell, choose "Filled material type/Element size" 

command from "Shell Properties" menu in Figure 9.12. The following form in Figure 9.17 appears. 

 

 
Figure 9.17 "Liquid Properties/Element size" dialog box 

To define the filled material properties of the tank: 

 

- Select the "Liquid container" option 

- Type 10 in the "Height of the liquid" edit box 

- Type 10.19 in the "Unit weight of the liquid" edit box 

 

To define the element size of the ring wall: 

 

- Check the "Constant element sizes in z-direction" check box 

- Type 1 in the "Element size in each shell segment" edit box. The element size is chosen  

to be 1 [m] larger than the segment size in order to ignore further subdivision of the 

segments into smaller elements. In some cases, it is necessary to divide the segment into 

smaller elements in order to make the analysis more precise. Nevertheless, the final results 

of the internal forces appear only at nodes of segments 

- Click "OK" button 
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Figure 9.18 "Shell Properties" window after defining the shell data 

After entering the shell properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 9.18 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 9.18 to close the "Shell 

properties" window and return to ELPLA main window 
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4.5 Soil properties 

To define the soil properties, choose "Soil Properties" command from “Data” Tab. The following 

"Soil Properties" form in Figure 9.19 appears, the soil properties are defined by Modulus of 

Elasticity "E", and is supposed to have the following parameters: 

 

Modulus of Elasticity of the soil E  = 20000  [kN/m2] 

Unit weight of the soil GAM  = 18  [kN/m3] 

Angle of internal friction 

Cohesion of the soil 

Poisson's ratio of the soil medium   

FHI = 30   [˚] 

c  = 0  [kN/m2] 

νs = 0.2       [-] 

 

Other data in the example are not required, the user can use the default values. 

 

 
Figure 9.19 "Soil Properties" form 

After defining the soil properties, click "Save" button. 
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4.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 9.20 appears. In ELPLA, entering loads may be carried out either numerically (in a table) 
or graphically using the commands of "Loads" Tab in Figure 9.20. In this example, there is not 
applied load, as the vertical load has been already defined by the unit weight of the tank,  
while the hydrostatic pressure on the tank wall is defined by the unit weight of water. 
 

 
Figure 9.20 "Loads" Window 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 9.20 to save the load data 

- Choose "Close" command from "File" menu in Figure 9.20 to close the "Loads" window 

and return to ELPLA main window 

 

Creating the project of the tank is now complete. It is time to analyze this project. In the next 

section, you will learn how to use ELPLA for analyzing projects. 
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5 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 9.21. 

 

 
Figure 9.21 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Determining flexibility coefficients of the soil  

- Assembling the slab stiffness matrix 

- Iteration process 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

Carrying out all computations 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab Window. The following 

"Iteration parameters" option box in Figure 9.22 appears 

For this example, choose an accuracy of 0.0001 [m] to end the iteration process 

- Click "OK" button 

 

 
Figure 9.22 "Iteration parameters" option box 

The progress of all computations according to the defined method will be carried out automatically 

with displaying Information through menus and messages. 
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Analysis progress 

 

Analysis progress menu in Figure 9.23 appears in which various phases of calculation  

are progressively reported as the program analyzes the problem. In addition, a status bar down  

of the "Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 9.23 Analysis progress menu 

"Check of convergence" message Figure 9.24 appears showing that no convergence is reached 

 at the last step, click "Ok" button. 

 

 
Figure 9.24 "Check of convergence" message 

Click "Stop" button in Figure 9.25, to stop the iteration process as no convergence has reached. 
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Figure 9.25 "Iteration process" list box 

 

Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 9.26. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 9.26 Menu "Check of the solution" 

 

Click "OK" button to finish analyzing the problem. 
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6 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through  

the "Results" Tab. To view the data and results of a problem that has already been defined  

and analyzed graphically, switch to "Results" Tab (Figure 9.27). 

 

 
Figure 9.27 "Results" Tab 

The "Result" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Rotational shell results 

- Sections in shell base 

- Sections in shell wall 

- Display tables of data 

- Display tables of results 

 

To view the radial forces in the shell wall  

 

- Choose "Sections in shell wall" command from "Section" menu. The following option box 

in Figure 9.30 appears 

- In the "Sections in shell wall" option box, select "Radial forces Nr" as an example  

for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 9.29. 
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Figure 9.28 "Sections in shell wall" option box 

 
Figure 9.29 Radial forces in shell wall 
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To view the meridional moments in the shell base  

 

- Choose "Sections in shell base" command from "Section" menu. The following option box 

in Figure 9.30 appears 

- In the "Sections in shell base" option box, select "Meridional moments My" as an example  

for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 9.31. 

 

 
Figure 9.30 "Sections in shell base" option box 

 
Figure 9.31 Meridional moments in shell base 
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To view element groups of the tank  

 

- Choose "Element groups" from "In Plan" command in "Data" menu. The following option 

box in Figure 9.32 appears 

- In the "Data – In Plan" option box, select "Element groups" as an example for the results  

to be displayed 

- Click "OK" button 

 

 
Figure 9.32 "Data – In Plan" option box 

To view the meridional moments on the FE-Net and any other data 

 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command.  

The "View Grouping" check group box in Figure 9.33 appears 

- In this check group box, check "Meridional moments My" check box 

- The user can choose any other data to be displayed 

- Click "OK" button 

 

 
Figure 9.33 "View Grouping" check group box 



Analyzing Axisymmetric Structures and Tanks by ELPLA 

 

 

 -9.28- 

 
Figure 9.34 Element groups of the tank with the meridional moments 
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1 Description of the problem 

An example of a cylindrical water container with a conical base is selected to illustrate some 

features of ELPLA for analyzing circular cylindrical shell elements. 

2 Container geometry and properties 

A cylindrical water container with a conical base of a radius of a = 3.0 [m] and a height  

of H = 12.0 [m] is considered as shown in Figure 10.1. Thickness of the container wall is 0.3 [m], 

while that for the conical base is 0.2 [m]. Figure 10.1 shows the container with dimensions  

and supports, while the container material and unit weight of the water are listed in Table 10.1.  

Table 10.1 Container material and water unit weight  

Modulus of Elasticity of the container material  Ec = 10000    [kN/m2] 

Poisson's ratio of the container material    νc = 0.17        [-] 

Unit weight of the water     γw  = 10        [kN/m3] 

 

 
Figure 10.1 Cylindrical water container with dimensions and supports 
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3 Numerical Analysis 

In the analysis, the height of the tank is divided into two main segments, the first one is divided 

into 30 subsegments (30×0.3 [m]), while the second is divided into 20 subsegments (20×0.15 [m]) 

as shown in Figure 10.2.  

 

 
A = 3.00 [m]

B
 =

 1
2

.0
0

 [m
]

pt=0.2[m]

pt=0.3[m]

 
Figure 10.2 Finite element mesh of the container with boundary condition 
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4 Creating the project 

In this section, the user will learn how to create a project for analyzing a cylindrical water container 

with a conical base. The project will be processed gradually to show the possibilities  

and abilities of the program. To enter the data of the example, follow the instructions and steps  

in the next paragraphs. 

4.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 10.3. This wizard will help the user to define the analysis type  

and the calculation method of the problem through a series of forms. The first form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 10.3). 

 

 
Figure 10.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 10.3, define the analysis type of the problem.  

As the analysis type is a cylindrical water container with a conical base problem,  

select "Analysis of rotational Shell" button, and check "Shell with an opening base" option, 

then click "Next" button to go to the next Form. After clicking "Next" button, the "Options" Form 

appears, Figure 10.4. 
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The last Form in the wizard is the "Options" Form, Figure 10.4. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Select "Supports/ Boundary Conditions", then click the "Save" button. 

 

 
Figure 10.4 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 10.5. In this dialog box 

type a file name for the current project in "File name" edit box. For example,  

type "Water container". ELPLA will use automatically this file name in all reading and writing processes. 
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Figure 10.5 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project  

[Water container] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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4.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely entered. 

To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 10.6 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a cylindrical water container" 

- Type the date of the project in the "Date" edit box 

- Type "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 10.6 "Project Identification" dialog box 

4.3 FE-Net data 

For the given problem, a cylindrical water container with a conical base of a radius of a = 3.0 [m]  

and a height of H = 12.0 [m] is considered, the height of the tank is divided into two main segments, 

the first one is divided into 30 subsegments (30×0.3 [m]), while the second is divided  

into 20 subsegments (20×0.15 [m]). To define the FE-Net for this tank, choose "FE-Net Data" command 

from the “Data” Tab. "Analysis of rotational shell" wizard appears as shown in Figure 10.7.  

This wizard will guide you through the steps required to generate a FE-Net, the first Form of the wizard 

is the "Shell type" Form, which contains a group of templates of different shapes of nets. These net 

templates are used to generate standard nets. 
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Figure 10.7 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 
 

- In the "Shell type" options choose "Irregular shell" button 
- Type 0.01 in the "Tank base radius Rb" edit box, which is approximately zero 

(Note that: from the principles of axis-symmetrical shell elements, radius cannot be exactly 
zero) 

 
To identify the first main segment  

 
• Type 3 in the "Height Hw" edit box 
• Type 3 in the "Upper radius Ro" edit box 
• Type 20 in the "Number of segments Ns" edit box 
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To identify the second main segment  
 

• Type 9 in the "Height Hw" edit box 
• Type 3 in the "Upper radius Ro" edit box 
• Type 30 in the "Number of segments Ns" edit box 

- Click "Next" button to go to the next Form 
 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Irregular shell" Form 

containing the data of the segments appears in Figure 10.8, The user can edit the data of each 

segment individually or all of them by using "In Table" button, If it is necessary. 

 

 
Figure 10.8 "Irregular shell" Form 

Click "Finish" in "Analysis of rotational shell" wizard, the generated FE-Net appears Figure 10.9. 
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Figure 10.9 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 10.9 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 10.9 to close the "FE-Net" window 

and return to ELPLA main window 
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4.4 Shell properties 

To define the tank properties, choose "Shell Properties" command from “Data” Tab. The following 

window in Figure 10.10 appears with default shell properties. The data of shell properties for the 

current example, which are required to be defined, are element groups, group regions, unit weight  

of the tank, and the filled material properties. 

 

 
Figure 10.10 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 10.11 

appears. In this list box, define E-Modulus, Poisson’s ratio and slab thickness for both the wall and  

the base of the tank as they differ in thickness. Then click "OK" button. 
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Figure 10.11 "Defining element groups" list box 

Defining the slab thickness for materials on the net may be carried out either graphically or numerically 

(in a table). In the current example, the user will define the slab thickness on the net graphically. 

 

To define the slab thickness for the tank base  

 

- Choose "Select Elements" command from "Graphically" menu in the window of Figure 10.10 

- When "Select Elements" command is chosen, the cursor will change from an arrow to  

a cross hair. A group of elements can be selected by holding the left mouse button down at the 

corner of the region. Then, drag the mouse until a rectangle encompasses the required group of 

elements. When the left mouse button is released, all elements in the rectangle are selected 

- Select the elements that include the tank base as Figure 10.12 

- Choose "Elements Groups" command from "Graphically" menu in the window of Figure 10.10, 

"Group Regions" dialog box Figure 10.13 appears 

- Define the "Group No." of the base elements as type "2", while "Group No." of the wall 

elements will be as type "1", where type "1" is the default "Group No.", then click "OK" button 
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Figure 10.12 Selecting the elements that include the tank base 

 
Figure 10.13 "Group Regions" dialog box 
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To enter the unit weight of the container, choose "Unit weight" command from "Shell Properties" 

menu in Figure 10.10. The following dialog box in Figure 10.14 with a default unit weight  

of 25 [kN/m3] appears, type 0 in the "Unit weight" edit box to neglect the self-weight of the tank, 

then click "OK" button. 

 

 
Figure 10.14 "Unit weight" dialog box 
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To define the filled material properties of the container, choose "Filled material type/Element size" 

command from "Shell Properties" menu in Figure 10.10. The following form in Figure 10.15 appears. 

 

 
Figure 10.15 "Filled material type/Element size" Form 

To define the filled material properties of the container: 

 

- Select "Liquid container" option 

- Type 12 in the "Height of the liquid" edit box 

- Type 10 in the "Unit weight of the liquid" edit box 

 

To define the element size of the container: 

 

- Check the "Constant element sizes in z-direction" check box 

- Type 1 in the "Element size in each shell segment" edit box. The element size is chosen  

to be 1 [m] larger than the segment size in order to ignore further subdivision of the 

segments into smaller elements. In some cases, it is necessary to divide the segment into 

smaller elements in order to make the analysis more precise. Nevertheless, the final results 

of the internal forces appear only at the nodes of segments 

- Click "OK" button 
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Figure 10.16 "Shell Properties" window after defining the container properties 

After entering the shell properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 10.16 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 10.16 to close the "Shell 

properties" window and return to ELPLA main window 
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4.5 Supports/ boundary conditions 

To define the support, choose "Supports/ Boundary Conditions" command from “Data” Tab.  

The following window in Figure 10.17 appears. 

 

 
Figure 10.17 "Supports/ Boundary Conditions" Window 

To define the support on the net: 

 

- Choose "Select Nodes" command from "Graphically" menu in Figure 10.17. When "Select 

Nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the node that has the support as shown in Figure 10.18 

- After selecting the node, choose "Add Supports/ Boundary Conditions" command  

from "Graphically" menu (Figure 10.17). The "Supports/ Boundary Conditions" dialog box 

in Figure 10.19 appears. 
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Figure 10.18 Selection of the node that has the support 
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In this dialog box 

 

- Type 0 in the "Displacement w" edit box to define the vertical support 

- Click "OK" button 

 

 
Figure 10.19 "Supports/ Boundary Conditions" dialog box 
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Figure 10.20 "Supports/ Boundary Conditions" window after defining the support 

After defining the supports, do the following two steps 

 

- Choose "Save " command from "File" menu in Figure 10.20 to save the data of supports 

- Choose "Close" command from "File" menu in Figure 10.20 to close the "Supports/ 

Boundary conditions" window and return to the main window 
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4.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 10.21 appears. 
 
In ELPLA, entering loads may be carried out either numerically (in a table) or graphically using the 
commands of "Loads" Tab in Figure 10.21. In this example, there is not applied load, as the vertical 
load has been already defined by the unit weight of the tank, while the hydrostatic pressure on the 
tank wall is defined by the unit weight of water. 
 

 
Figure 10.21 "Loads" Window 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 10.21 to save the load data 

- Choose "Close" command from "File" menu in Figure 10.21 to close the "Loads" window 

and return to ELPLA main window 

 

Creating the project of the tank is now complete. It is time to analyze this project.  

In the next section, you will learn how to use ELPLA for analyzing projects. 
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5 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 10.22. 

 

 
Figure 10.22 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (band matrix)  

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab window.  

 

The progress of all computations according to the defined method will be carried out automatically 

with displaying Information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 10.23 appears in which various phases of calculation  

are progressively reported as the program analyzes the problem. In addition, a status bar down  

of the "Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 10.23 Analysis progress menu 
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Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 10.24. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 10.24 Menu "Check of the solution" 

 

Click "OK" button to finish analyzing the problem. 
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6 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through  

the "Results" Tab. To view the data and results of a problem that has already been defined  

and analyzed graphically, switch to "Results" Tab (Figure 10.25). 

 

 
Figure 10.25 "Results" Tab 

The "Result" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Rotational shell results 

- Support Reactions 

- Sections in shell wall 

- Display tables of data 

- Display tables of results 

 

To view the radial forces on the shell wall  

 

- From "Rotational shell results" command in the "Results" menu, choose "In Plan" command, 

the following option box in Figure 10.26 appears 

- In the "Distribution of Internal Forces" option box, select "Radial forces Nr" as an example  

for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 10.27. 
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Figure 10.26 "Distribution of Internal Forces" option box 

 

 
Figure 10.27 Radial forces on the shell wall 
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To view the meridional moments on the shell wall  

 

- From "Rotational shell results" command in the "Results" menu, choose "In Plan" command. 

The following option box in Figure 10.28 appears 

- In the "Distribution of Internal Forces" option box, select "Meridional moments My" as an 

example for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 10.29. 

 

 
Figure 10.28 "Distribution of Internal Forces" option box 

 
Figure 10.29 Meridional moments on the shell wall 
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To view element groups of the tank  

 

- Choose "Element groups" from "In Plan" command in "Data" menu. The following option 

box in Figure 10.30 appears 

- In the "Data – In Plan" option box, select "Element groups" as an example for the results  

to be displayed 

- Click "OK" button 

 

 
Figure 10.30 "Data – In Plan" option box 

To view the supports / boundary conditions on the FE-Net and any other data 

 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command.  

The "View Grouping" check group box in Figure 10.31 appears 

- In this check group box, check both "Supports Reactions RV" and "Supports /Boundary 

Conditions" check box  

- The user can choose any other data to be viewed 

- Click "OK" button 

 

 
Figure 10.31 "View Grouping" check group box 
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Figure 10.32 Element groups of the tank 
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1 Description of the problem 

An example of an axi-symmetrically chimney with hyperbolic shell wall under a uniform external 

pressure is selected to illustrate some features of ELPLA for analyzing shell elements. 

2 Chimney geometry and properties 

Consider a hyperbolic shell of revolution with the following geometry: 

 

Throat radius    Ro = 18  [m] 

Throat height    Hl = 45  [m] 

Lower radius    Ru = 36  [m] 

Total height    H = 72  [m] 

Thickness of the wall  t =0.24  [m] 

 

Meridian equation of the hyperbolic shell of revolution is given by: 
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where r [m] is the radius at height ξ [m]. 

 

Figure 11.1 shows the geometry the chimney with its hyperbolic shell wall with dimensions and 

supports, while the shell material are listed in Table 11.1.  

Table 11.1 hyperboloid shell material  

Modulus of Elasticity of the chimney material  Ec = 3×107    [kN/m2] 

Poisson's ratio of the chimney material    νc = 0.3        [-] 

 

 

 

 

 

 

 

 

 

 

 

 



Analyzing Axisymmetric Structures and Tanks by ELPLA 

 

 

 -11.4- 

 
Figure 11.1 Geometry of the chimney with dimensions and supports 
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3 Numerical Analysis 

In the analysis, the height of the chimney is divided into 7 main segments; each segment is divided 

into a number of elements. Segment dimensions and number of elements of each segment are shown 

in Figure 11.2.  

  

 

 
 

Figure 11.2 Segment dimensions and no. of elements in each segment 
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The chimney is exposed to a uniform external pressure of ps = -10 [kN/m2] as shown in Figure 11.3 

 

 

 
Figure 11.3 chimney with uniform external pressure of ps = -10 [kN/m2] 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

ps = -10 [kN/m2] 



Example 11  

 

 

   -11.7- 

4 Creating the project 

In this section, the user will learn how to create a project for analyzing a chimney with hyperbolic 

shell wall under a uniform external pressure. The project will be processed gradually to show the 

possibilities and abilities of the program. To enter the data of the example, follow the instructions 

and steps in the next paragraphs. 

4.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 11.4. This wizard will help the user to define the analysis type  

and the calculation method of the problem through a series of forms. The first form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 11.4). 

 

 
Figure 11.4 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 11.4, define the analysis type of the problem.  

As the analysis type is a hyperbolic shell problem, select "Analysis of rotational Shell" button, and 

check "Shell with an opening base" option, then click "Next" button to go to the next Form.  

After clicking "Next" button, the "Options" Form appears, Figure 11.5. 
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The last Form in the wizard is the "Options" Form, Figure 11.5. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Select "Supports/ Boundary Conditions", then click the "Save" button. 

 

 
Figure 11.5 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 11.6. In this dialog box 

type a file name for the current project in "File name" edit box. For example,  

type "Hyperbolic Chimney". ELPLA will use automatically this file name in all reading and writing 

processes. 
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Figure 11.6 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project  

[Hyperbolic Chimney] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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4.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely 

entered. To identify the project, choose "Project Identification" command from the “Data” Tab. 

 The dialog box in Figure 11.7 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a chimney with hyperbolic shell wall" 

- Type the date of the project in the "Date" edit box 

- Type the word "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 11.7 "Project Identification" dialog box 

4.3 FE-Net data 

For the given problem, the chimney has a lower radius of Ru = 36 [m] and a total height of H = 72 [m]. 

the wall height is divided into 7 main segments, each segment is divided into a number of elements. 

To define the FE-Net for this tank, choose "FE-Net Data" command from the “Data” Tab.  

"Analysis of rotational shell" wizard appears as shown in Figure 11.8. This wizard will guide you 

through the steps required to generate a FE-Net. As shown in Figure 11.8, the first Form of the 

wizard is the "Shell type" Form, which contains a group of templates of different shapes of nets. 

These net templates are used to generate standard nets. 
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Figure 11.8 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 

 

- In the "Shell type" options choose "Hyperbolic shell" button 

- Type 18 in the "Throat radius" edit box  

- Type 72 in the "Total height" edit box  

- Type 36 in the "Lower radius" edit box 

- Type 45 in the "Throat height" edit box 

- Type 7 in the "Number of segments" edit box 

- Click "Next" button to go to the next Form 

 

 

 

 

 

 

 



Analyzing Axisymmetric Structures and Tanks by ELPLA 

 

 

 -11.12- 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Hyperbolic shell" 

Form appears Figure 11.9, ELPLA divides the height of the chimney wall into 7 equal segments,  

The user can edit the data of the segments individually by using "Modify" button, or all of them 

using "In Table" button.  

 

 
Figure 11.9 "Hyperbolic shell" Form 
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Figure 11.10 "Segment data" Table 

After modifying the coordinates of the segments, click "Finish" button, the FE-Net of the chimney 

appears in Figure 11.11 
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Figure 11.11 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 11.11 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 11.11 to close the "FE-Net" window 

and return to ELPLA main window 
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4.4 Shell properties 

To define the chimney properties, choose "Shell Properties" command from “Data” Tab.  

The following window in Figure 11.12 appears with default shell properties. The data of shell 

properties for the current example, which are required to be defined, are element groups, unit weight 

of the chimney, and element size. 

 

 
Figure 11.12 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 11.13 

appears. In this list box, enter E-Modulus, Poisson’s ratio and slab thickness. Then click "OK" button. 
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Figure 11.13 "Defining element groups" list box 

To enter the unit weight of the chimney, choose "Unit weight" command from "Shell Properties" 

menu in Figure 11.12. The following dialog box in Figure 11.14 with a default unit weight  

of 25 [kN/m3] appears, type 0 in the "Unit weight" edit box to neglect the self-weight of the chimney, 

then click "OK" button. 

 

 
Figure 11.14 "Unit weight" dialog box 
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To define the element size of the chimney, choose "Filled material type/Element size" command 

from "Shell Properties" menu in Figure 11.12. The following form in Figure 11.15 appears, then: 

 

- Select "Empty container" option 

- uncheck the "Constant element sizes in z-direction" check box 

- Click "Element size in each segment" button, the following list box in Figure 11.16 appears 

- Define the size of the element in each segment as in the following list box in Figure 11.16,  

to keep the same number of elements in each segment 

- Click "OK" button 

 

 
Figure 11.15 "Filled material type/Element size" Form 

 



Analyzing Axisymmetric Structures and Tanks by ELPLA 

 

 

 -11.18- 

 
Figure 11.16 "Element size in each segment" list box 

After defining the chimney properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 11.12 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 11.12 to close the "Shell properties" 

window and return to ELPLA main window 
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4.5 Supports/ Boundary Conditions 

To define the hinged support, choose "Supports/ Boundary Conditions" command from “Data” Tab.  

The following window in Figure 11.17 appears. 

 

 
Figure 11.17 "Supports/ Boundary Conditions" Window 

To define the support on the net: 

 

- Choose "Select Nodes" command from "Graphically" menu in Figure 11.17. When "Select 

Nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the node that has the support as shown in Figure 11.18 

- After selecting the node, choose "Add Supports/ Boundary Conditions" command  

from "Graphically" menu (Figure 11.17). The "Supports/ Boundary Conditions" dialog box 

in Figure 11.19 appears. 
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Figure 11.18 Selection of the node that has a hinged support 
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In this dialog box 

 

- Type 0 in the "Displacement u" edit box to define the horizontal fixed support 

- Type 0 in the "Displacement w" edit box to define the vertical fixed support 

- Click "OK" button 

 

 
Figure 11.19 "Supports/ Boundary Conditions" dialog box 
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Figure 11.20 Supports on the screen 

After defining the supports, do the following two steps 

 

- Choose "Save " command from "File" menu in Figure 11.17 to save the data of supports 

- Choose "Close" command from "File" menu in Figure 11.17 to close the "Supports/ 

Boundary conditions" window and return to the main window. 
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4.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 11.21 appears. 
 
In ELPLA, entering loads may be carried out either numerically (in a table) or graphically using  
the commands of "Loads" Tab in Figure 11.21. In this example, the hyperbolic chimney is exposed  
to a uniform external pressure of ps = -10 [kN/m2]. 
 

 
Figure 11.21 "Loads" Window 
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To define the uniform distributed load: 

 

- choose "Edit Member Load" command from "Graphically" menu in Figure 11.21. When "Edit 

Member Load" command is chosen, the cursor will change from an arrow to a cross hair 

- Double click on the element which is exposed to the uniform distributed load 

- "Edit Member Load" dialog box in Figure 11.22 appears, type "-10" in "Member loads" edit box 

- Click "OK" button 

 

 
Figure 11.22 "Edit Member Load" dialog box 
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Figure 11.23 "Loads" window after defining the uniform distributed load 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 11.21 to save the load data 

- Choose "Close" command from "File" menu in Figure 11.21 to close the "Loads" window 

and return to ELPLA main window.  

 

Creating the project of the chimney with a hyperbolic shell wall is now complete. It is time to 

analyze this project. In the next section, you will learn how to use ELPLA for analyzing projects. 
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5 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 11.24. 

 

 
Figure 11.24 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (band matrix) 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab window.  

 

The progress of all computations according to the defined method will be carried out automatically 

with displaying Information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 11.25 appears in which various phases of calculation  

are progressively reported as the program analyzes the problem. In addition, a status bar down  

of the "Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 11.25 Analysis progress menu 

 

 



Example 11  

 

 

   -11.27- 

Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 11.26. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 11.26 Menu "Check of the solution" 

Click "OK" button to finish analyzing the problem. 
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6 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables  

through the "Results" Tab. To view the data and results of a problem that has already been defined 

and analyzed graphically, switch to "Results" Tab (Figure 11.27).  

 

 
Figure 11.27 "Results" Tab 

The "Results" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Rotational shell results 

- Supports reactions 

- Sections in shell wall 

- Display tables of data 

- Display tables of results 

 

To view the radial forces in the shell wall  

 

- From "Rotational shell results" command in the "Results" menu, choose "In Plan" command. 

The following option box in Figure 11.28 appears 

- In the "Distribution of Internal Forces" option box, select "Radial forces Nr" as an example 

for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 11.29. 

 

 
Figure 11.28 "Distribution of internal forces" option box 
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Figure 11.29 Radial forces in shell wall 

To view the vertical deformations of the chimney wall  

 

- From "Rotational shell results" command in the "Results" menu, choose "In Plan" command. 

The following option box in Figure 11.30 appears 

- In the "Distribution of Internal Forces" option box, select "Vertical deformations Vv" as an 

example for the results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 11.31. 
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Figure 11.30 "Distribution of internal forces" option box 

 
Figure 11.31 Vertical deformations of the chimney wall 
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To view the slab thickness of the chimney  

 

- Choose "Slab thickness" from "In Plan" command in "Data" menu. The following option 

box in Figure 11.32 appears 

- Click "OK" button 

 

 
Figure 11.32 "Data – In Plan" option box 

To view the supports / boundary conditions on the FE-Net and any other data 

 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command.  

The "View Grouping" check group box in Figure 11.33 appears 

- In this check group box, check "Supports /Boundary Conditions" check box 

- The user can choose any other data to be viewed 

- Click "OK" button 

 

 
Figure 11.33 "View Grouping" check group box 
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Figure 11.34 Slab thickness with the load system 
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1 Description of the problem 

An example of an axi-symmetrically container with irregular shape resting on a layered soil is 

selected to illustrate some features of ELPLA for analyzing shell elements. 

2 Container geometry and properties 

A container having a base radius of a = 5 [m], middle wall radius of Rm = 7 [m] and a height of  

H = 14 [m] is considered as shown in Figure 12.1. Thicknesses of the container base, wall and roof are 

tb = 0.4 [m], tw = 0.3 [m], tr = 0.2 [m], respectively. The container is filled with water and rests on 

layered soil. The container material and unit weight of the water are listed in Table 12.1. 

 
Figure 12.1 Irregular container with dimensions 

 

Rm = 7.00 [m] 

Ec = 2×107 [kN/ m2] 

νc = 0.20    [-] 

γc = 25       [kN/ m3] 

γw = 9.81    [kN/ m3] 

a = 5 [m] 

H
 =

 1
4
 [

m
] 
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Table 12.1 Container material and water unit weight  

Modulus of Elasticity      Ec = 2×107 [kN/ m2] 

Poisson's ratio       νc = 0.2            [-] 

Unit weight of the container material                          γc = 25  [kN/ m3] 

Unit weight of the water     γw  = 10  [kN/ m3] 

 

The geometry and parameters of the container are: 

 

Base: 

- Base radius     Rb = 5 [m] 

- Base thickness    tb = 0.4 [m] 

Wall: 

- Wall thickness    tw = 0.3 [m] 

- The first main segment parameters are: 

• Height    Hw = 10 [m] 

• Middle radius   Rm = 7 [m] 

• Upper radius    Ro = 5 [m] 

• Number of subsegments  Ns = 30 

- The second main segment parameters are: 

• Height    Hw = 4 [m] 

• Middle radius   Rm = 5 [m] 

• Upper radius    Ro = 5 [m] 

• Number of subsegments  Ns = 20 

Roof: 

- Flat roof type 

- Number of subsegments  Ns = 15 

- Roof thickness   tr = 0.2 [m] 

2.1 Soil properties 

The subsoil under the container consists of two layers, sandy clay and sand with gravel. 

 

The soil properties of the sandy clay layer are: 

Modulus of elasticity for loading E  = 35000  [kN/m2] 

Modulus of elasticity for reloading W  = 105000  [kN/m2] 

Poisson's ratio  νs = 0.3  [-] 

 

while those of the sand with gravel layer are: 

Modulus of elasticity for loading E  = 80000         [kN/m2] 

Modulus of elasticity for reloading W  = 240000        [kN/m2] 

Poisson's ratio 

 

 

νs = 0.3     [-] 
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2.2 Numerical Analysis 

In the analysis, the wall height of the container is divided into two main segments, the first one is 

divided into 30 subsegments (30×0.3 [m]), while the second is divided into 20 subsegments (20×0.2 [m]). 

The flat roof is divided into 15 subsegments. The raft foundation is divided into 10 circular intervals 

as shown in Figure 12.2.  

 

pt=0.2[m]

pt=0.3[m]

pt=0.4[m]

 
Figure 12.2 Finite element mesh of the container with a sector from the base 
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3 Creating the project 

In this section, the user will learn how to create a project for analyzing a container resting on  

a layered soil. The project will be processed gradually to show the possibilities and abilities of the 

program. To enter the data of the example, follow the instructions and steps in the next paragraphs. 

3.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 12.3. This wizard will help the user to define the analysis type  

and the calculation method of the problem through a series of Forms. The first Form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 12.3). 

 

 
Figure 12.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 12.3, define the analysis type of the problem. As the analysis 

type is a container resting on layered soil problem, select "Analysis of rotational shell" button,  

and check "Shell with a raft foundation" option, then click "Next" button to go to the next Form. 

After clicking "Next" button, the "Calculation Methods" Form appears, Figure 12.4. 
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To define the calculation method: 

 

- Select the calculation method "7-Modulus of Compressibility (Elimination)" 

- Click "Next" button to go to the next Form 

 

 
Figure 12.4 "Calculation Methods" Form 

The last Form in the wizard is the "Options" Form, Figure 12.5. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Since no option will be considered in the analysis, click the "Save" button. 
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Figure 12.5 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 12.6. In this dialog box 

type a file name for the current project in "File name" edit box. For example, type "Container on 

layered soil". ELPLA will use automatically this file name in all reading and writing processes. 
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Figure 12.6 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project  

[Container on layered soil] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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3.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely 

entered. To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 12.7 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a container resting on different soil layers" 

- Type the date of the project in the "Date" edit box 

- Type the word "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 12.7 "Project Identification" dialog box 
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3.3 FE-Net data 

For the given problem, the container has a base radius of a = 5 [m], and a height of H = 14 [m].  

The height of the container is divided into two main segments, the first one is divided  

into 30 subsegments (30×0.3 [m]), while the second is divided into 20 subsegments (20×0.2 [m]), 

and the roof segment is divided into 15 subsegments. ELPLA has different procedures for defining 

the FE-Net. To define the FE-Net for this container, choose "FE-Net Data" command from the 

“Data” Tab. "Analysis of rotational shell" wizard appears as shown in Figure 12.8. This wizard will 

guide you through the steps required to generate a FE-Net. As shown in Figure 12.8, the first Form 

of the wizard is the "Shell type" Form, which contains a group of templates of different shapes  

of shells. These net templates are used to generate standard nets. 

 

 
Figure 12.8 "Analysis of rotational shell" wizard with "Shell type" Form 
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To generate the FE-Net of the container which has an irregular wall shape: 

 

- In the "Shell type" options choose "Irregular shell" button 

To define the base of the container: 

• Type 5 in the "Tank base radius Rb" edit box 

  To define the first segment of the height of the container: 

• Choose "Curved segments" option 

• Type 10 in the "height Hw" edit box  

• Type 7 in the "middle radius Rm" edit box  

• Type 15 in the "Upper radius Ro" edit box, as the upper radius is the same as  

the base radius 

• Type 30 in the "Number of segments Ns" edit box 

 

 

To define the second segment of the height of the container: 

• Type 4 in the "height Hw" edit box  

• Type 5 in the "middle radius Rm" edit box  

• Type 5 in the "Upper radius Ro" edit box, as the upper radius is the same  

as the base radius 

• Type 20 in the "Number of segments Ns" edit box 

To define the roof of the container: 

• Check the "Shell with covered roof" check box 

• Choose "Flat roof" option 

• Type 15 in the "Number of roof segments" edit box 

- Click "Next" button to go to the next Form 
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After clicking "Next" in "Analysis of rotational shell" wizard, the following "Irregular shell" Form 

containing the data of the segments appears in Figure 12.9, the user can edit the data of each 

segment individually or all of them by using "In Table" button, if it is necessary.  

Click "Next" button to go to the next Form. 

 

 
Figure 12.9 "Irregular shell" Form 
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The next Form of the "Analysis of rotational shell" wizard is the "Net of Base" Form Figure 12.10.  

In this Form, the default values of the grid intervals appear, to edit the grid spacing in x-direction of the 

base, do the following steps in "Grid in x-direction" frame: 

 

- Choose "Constant ring area" check box  

- Type 10 in the "No. of grid intervals" 

- Click "Finish" button to return to "FE-Net Data" window 

 

 
Figure 12.10 "Net of Base" Form 
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ELPLA will generate the FE-Net of the container with a sector from the base with 10 circular 

intervals. The following window in Figure 12.11 appears with the generated net. 

 
Figure 12.11 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 12.11 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 12.11 to close the "FE-Net" window 

and return to ELPLA main window 
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3.4 Soil Properties 

In ELPLA, there are three different soil models with several calculation methods. Therefore,  

the soil properties for each method are required to be defined according to the used soil model.  

In the current example, the soil model, which is used in the analysis, is "Layered Soil Model".  

This model requires that the subsoil have to be defined by boring logs. In the example, the boring 

log has multi-layers with different soil materials. The geotechnical data for each layer is unit weight 

of the soil γs and modulus of Elasticity for loading E and reloading W and Poisson's ratio νs. 

 

To define the soil properties, choose "Soil Properties" command from “Data” Tab. The following 

"Soil Properties" Window in Figure 12.12 appears with a default-boring log. 

 

 
Figure 12.12 "Soil Properties" window with a default-boring log 

In Figure 12.12, soil properties are defined through the "Data" menu, which contains  

the following two commands: 

 

- "Soil Data" command defines the individual boring logs 

- "Main Soil Data" command defines the general data for all soil layers 

 

To enter the soil properties for the boring log of the current example 

 

- Choose "Soil Data" command from "Data" menu in the window of Figure 12.12 

The following dialog box in Figure 12.13 with default-boring log data appears,  

Define the data of the boring log as the following  
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Figure 12.13 "Soil data" dialog box  

In the "Geotechnical data of the layer" dialog group box in Figure 12.13, Soil properties are defined 

by Modulus of elasticity, define the geotechnical data of the first soil layer of the boring log  

as follows: 

  

E   = 35000  [kN/m2] 

W   = 105000 [kN/m2] 

Gam  = 18   [kN/m3] 

C  = 10   [kN/m2] 

φ = 20   [º] 

 

In order to draw the soil layers by different symbols according to the German Standard DIN 4023, 

the soil type and color for each layer must be defined. 

 

To define the soil type and color for the first layer, select "T, Clay" as the soil type in "Main soil type 1" 

combo box, and "S, Sand" as the submain soil type in "Submain soil 1" combo box in "Soil and rock 

symbols" dialog group box in Figure 12.13. The color of the layer according to the German 

Standard DIN 4023 will be automatically created. The user can change this color.  
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To enter the second layer of the boring log 

 

- Click "Copy Layer" button in Figure 12.13. A layer with the same properties of the first layer 

will be copied 

- Use the vertical scrollbar to move to the second soil layer. Layer No. will be typed 

automatically at the upper-left corner of the main dialog box of soil layers as a head title 

- In "Geotechnical data of the layer" dialog group box in Figure 12.13, define the geotechnical 

data of the sand with gravel layer as follows: 

• E   = 80000  [kN/m2] 

• W   = 240000 [kN/m2] 

• Gam  = 18   [kN/m3] 

• C  = 0   [kN/m2] 

• φ = 35   [º] 

- Change the value of the layer depth under the ground surface from 4.5 [m] to 19.8 [m] 

- From "Soil and rock symbols" dialog group box, choose "S, Sand" and "G, Gravel" in 

"Main soil type 1" and "Main soil type 2" combo boxes, as the main soil type of the second 

layer is sand with gravel   

 

Note that: as the analysis is nonlinear, the unit weight of the soil, cohesion and angle of internal 

friction play no roles in the analysis.  
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Now all data and parameters for the boring log (Figure 12.14) have been entered.  

 

 
Figure 12.14 boring log 

To enter the main soil data for all layers, choose "Main Soil Data" command from "Data" menu 

in Figure 12.12. The following dialog box in Figure 12.15 appears with default main soil data.  

The main soil data for the current example, which are required to be defined, are the settlement 

reduction factor α [-] and the groundwater depth under the ground surface Gw [m]. Any other data 

corresponding to main soil data are not required in this example. Therefore, the user can take these 

data from the default soil properties. 

 

In the dialog box of Figure 12.15, enter the settlement reduction factor α [-] and the groundwater 

depth under the ground surface Gw [m]. Then click "OK" button. 
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Figure 12.15 "Main Soil Data" dialog box 
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Figure 12.16 "Calculation parameters of flexibility coefficients" dialog box 

After entering all data and parameters of the boring log, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 12.12 to save the data of boring log 

- Choose "Close" command from "File" menu in Figure 12.12 to close "Soil properties 

window and return to ELPLA main window. 
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3.5 Shell properties 

To define the container properties, choose "Shell Properties" command from “Data” Tab.  

The following window in Figure 12.17 appears with default shell properties. The data of shell 

properties for the current example, which is required to be defined, are element groups,  

group regions, the unit weight of the container, and the filled material properties. Any other data 

corresponding to shell properties in the program menus are not required for this example.  

 

 
Figure 12.17 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 12.18 

appears. In this list box, enter E-Modulus, Poisson’s ratio and slab thickness for the container base, 

wall and roof as they differ in thickness. Then click "OK" button to go to the next step. 
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Figure 12.18 "Defining element groups" list box 

Defining the slab thickness for materials on the net may be carried out either graphically or numerically 

(in a table). In the current example, the user will define the slab thickness on the net graphically. 

 

To define the slab thickness for the container roof  

 

- Choose "Select Elements" command from "Graphically" menu in the window  

of Figure 12.17.  

- When "Select Elements" command is chosen, the cursor will change from an arrow to  

a cross hair. A group of elements can be selected by holding the left mouse button down at 

the corner of the region. Then, drag the mouse until a rectangle encompasses  

the required group of elements. When the left mouse button is released,  

all elements in the rectangle are selected 

- Select the elements that include the container roof as Figure 12.19 

- Choose "Elements Groups" command from "Graphically" menu in the window  

of Figure 12.17, "Group Regions" dialog box Figure 12.20 appears 

- Define the "Group No." of the roof elements as type "3" 

- Repeat the previous steps to define the "Group No." of the container wall as type "2",  

while "Group No." of the wall elements will be as type "1", where type "1" is the  

default "Group No.", then click "OK" button 
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Figure 12.19 Selecting the elements that include the container roof 

 
Figure 12.20 "Group Regions" dialog box 

To enter the unit weight of the container, choose "Unit weight" command from "Shell Properties" 

menu in the window of Figure 12.17. The following dialog box in Figure 12.21 with a default unit 

weight of 25 [kN/m3] appears. Click "OK" button. 

 

 
Figure 12.21 "Unit weight" dialog box 
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To define the filled material properties of the container, choose "Filled material type/Element size" 

command from "Shell Properties" menu in Figure 12.17. The following form in Figure 12.22 

appears. 

 

 
Figure 12.22 "Filled material type/Element size" Form 

To define the filled material properties of the container: 

 

- Select "Liquid container" option 

- Type 14 in the "Height of the liquid" edit box 

- Type 9.81 in the "Unit weight of the liquid" edit box 

 

To define the element size of the container: 

 

- Check the "Constant element sizes in z-direction" check box 

- Type 1 in the "Element size in each shell segment" edit box. The element size is chosen  

to be 1 [m] larger than the segment size in order to ignore further subdivision of the 

segments into smaller elements. In some cases, it is necessary to divide the segment into 

smaller elements in order to make the analysis more precise. Nevertheless, the final results 

of the internal forces appear only at nodes of segments 

- Click "OK" button 
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Figure 12.23 "Shell Properties" window after defining the container properties 

After entering the shell properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 12.23 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 12.23 to close the "Shell 

properties" window and return to ELPLA main window 
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3.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 12.24 appears. 
 
In ELPLA, entering loads may be carried out either numerically (in a table) or graphically using the 
commands of "Loads" Tab in Figure 12.24. In this example, there is not applied load, as the load has 
been already defined by the unit weight of the container material, while the hydrostatic pressure on 
the container is defined by the unit weight of water. 
 

 
Figure 12.24 "Loads" Window 

Do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 12.24 to save the load data 

- Choose "Close" command from "File" menu in Figure 12.24 to close the "Loads" Window 

and return to ELPLA main window  

 

Creating the project is now complete. It is time to analyze this project. In the next section, you will 

learn how to use ELPLA for analyzing projects. 
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4 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 12.25. 

 

 
Figure 12.25 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Determining flexibility coefficients of the soil 

- Assembling the soil stiffness matrix 

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (unsymmetrical matrix) 

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

Carrying out all computations 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab window.  

- The progress of all computations according to the defined method will be carried out 

automatically with displaying information through menus and messages. 
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Analysis progress 

 

Analysis progress menu in Figure 12.26 appears in which various phases of calculation are 

progressively reported as the program analyzes the problem. In addition, a status bar down of the 

"Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 12.26 Analysis progress menu 

Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 12.27. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 12.27 Menu "Check of the solution" 

Click "OK" button to finish analyzing the problem. 
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5 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through the 

"Results" Tab. To view the data and results of a problem that has already been defined and analyzed 

graphically, switch to "Results" Tab (Figure 12.28).  

 

 
Figure 12.28 "Results" Tab 

The "Result" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Rotational shell results 

- Boring logs and limit depth 

- Sections in the shell wall 

- Sections in the shell base 

- Display tables of data 

- Display tables of results 

 

To view sections in shell base 

 

- Choose "Sections in shell base" command from "Section" menu. The following option box 

in Figure 12.29 appears 

- In the "Sections in shell base" option box, select "Base contact pressures q" as an example 

for the results to be displayed 

- Click "OK" button 

 

The base contact pressures are now displayed as shown in Figure 12.30. 

 

 
Figure 12.29 "Sections in shell base" option box 
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Figure 12.30 Base contact pressures in shell base 

To view the base settlements  

 

- Choose "Sections in shell base" command from "Section" menu. The following option box 

in Figure 12.31 appears 

- In the "Sections in shell base" option box, select "Base settlements w" as an example for the 

results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 12.32. 

 

 
Figure 12.31 "Sections in shell base" option box 
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Figure 12.32 Base settlements  

To view element groups of the container 

 

- Choose "Element groups" from "In Plan" command in "Data" menu. The following option 

box in Figure 12.33 appears 

- In the "Data – In Plan" option box, select "Element groups" as an example for the results  

to be displayed 

- Click "OK" button 

 

 
Figure 12.33 "Data – In Plan" option box 
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To view the internal forces on the FE-Net and any other data 

 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command.  

The "View Grouping" check group box in Figure 12.34 appears 

- In this check group box, the user can choose any data to be viewed  

- Click "OK" button 

 

 
Figure 12.34 "View Grouping" check group box 

 
Figure 12.35 Element groups of the container 
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1 Description of the problem 

An example of a circular concrete silo is selected to illustrate some features of ELPLA for analyzing 

circular silos for storing bulk materials. 

2 Silo geometry and properties 

A circular concrete silo having a conical hopper at the bottom part and a conical roof at the upper 

part is considered. The main height of the silo is 8 [m] and its diameter is 4 [m]. The stored material 

is cement of a unit weight of 15.5 [kN/m3]. The angle of internal friction of cement is 25 [°] 

and the angle of wall friction is 25 [°]. The thickness of the roof and the wall is 0.28 [m], while the 

thickness of the hopper is 0.25 [m]. The conical hopper bottom slope is 45 [°], an opening at the 

bottom with diameter 0.5 [m] and hopper bottom height is 3 [m]. Table 13.1 shows the geometry of 

the silo with dimensions and support, while the silo shell material is listed in Table 13.1.  

 
Figure 13.1 Geometry of the silo with dimensions and support 

Table 13.1 Silo shell material  

Modulus of Elasticity of the shell material  Ec = 2.486×107    [kN/m2] 

Poisson's ratio of the shell material    νc = 0.2         [-] 

Unit weight of the shell material   γc = 23.563     [kN/m3] 

r=2 [m] 

H=14 

[m] 
pt=0.25[m] 

pt=0.28[m] 

3 [m] 

3 [m] 

0.25 [m] 

Conical hopper 

Conical roof 

Cylindrical shell 
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3 Pressure on the silo wall 

According to Janssen’s silo theory, the horizontal pressure Ph [kN/m2] on the silo wall  

at a depth h [m] below the free surface of the stored material is given by: 


















=

R

hkR
P

s

h

μ-
Exp-1

μ

γ
 

in which k is the ratio of horizontal to vertical pressures, usually assumed equal to Rankine’s 

coefficient of active earth pressure 

φsin 1

φsin -1

+
=k  

h   Depth from the material top to the calculation section, [m] 

k  Wall pressure coefficient, [-] 

φ  Angel of internal friction of the stored material, [°] 

γs  Unit weight of the stored material, [kN/m3] 

R=A/U  Hydraulic radius of the net horizontal cross section, [m] 

μ=tan δ  Friction coefficient between the silo wall and the stored material   

δ   Angle of the wall friction, [°]   

A=πD/4 Cross-sectional area of the silo, [m2] 

U=πD  Parameter of the silo, [m] 

D  Diameter of the silo, [m] 

 

Using the above relations and equations, the lateral pressure Ph on the main silo wall various depth 

is determined and presented in Table 13.2. 

Table 13.2 Lateral pressure Ph on the main silo wall  

Height from the top 

h [m] 

Lateral pressure on the silo wall 

Ph [kN/m2] 

0.5 3.00 

1.5 8.22 

2.5 12.53 

3.5 16.10 

4.5 19.06 

5.5 21.50 

6.5 23.53 

7.5 25.20 
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4 Numerical Analysis 

The wall of the silo is divided into three parts: 

1. The roof part where no lateral pressure is applied on it 

2. The main silo part where the lateral pressure ph is applied. 

3. The hopper part where no lateral pressure is applied on it 

 

In the analysis, these three parts are divided into 14 segments; each segment is 1.0 [m]. Then these 

segments are divided into a number of elements, each element is 0.2 [m]. Segment dimensions and 

number of segments are shown in Figure 13.2.  

  

 
Figure 13.2 Segment dimensions 

 

 

 

r=2 [m] 

H=14 [m] 
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5 Creating the project 

In this section, the user will learn how to create a project for analyzing a circular concrete silo.  

The project will be processed gradually to show the possibilities and abilities of the program.  

To enter the data of the example, follow the instructions and steps in the next paragraphs. 

5.1 Calculation method 

Choose "New Project" command from the "File" menu. The following "Calculation Methods" 

wizard appears, Figure 13.3. This wizard will help the user to define the analysis type  

and the calculation method of the problem through a series of forms. The first form of "Calculation 

Methods" wizard is the "Analysis Type" Form (Figure 13.3). 

 

 
Figure 13.3 "Analysis Type" Form 

In the "Analysis Type" Form in Figure 13.3, define the analysis type of the problem.  

As the analysis type is a circular concrete silo problem, select "Analysis of rotational Shell" button, 

and check "Shell with an opening base" option, then click "Next" button to go to the next Form. 

After clicking "Next" button, the "Options" Form appears, Figure 13.4. 
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The last Form in the wizard is the "Options" Form, Figure 13.4. In this Form, ELPLA displays some 

available options corresponding to the chosen numerical model, which differ from model to other. 

Select "Supports/ Boundary Conditions", then click the "Save" button. 

 

 
Figure 13.4 "Options" Form 

After clicking "Save" button, the "Save as" dialog box appears, Figure 13.5. In this dialog box 

type a file name for the current project in "File name" edit box. For example,  

type "Silo". ELPLA will use automatically this file name in all reading and writing processes. 
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Figure 13.5 "Save as" dialog box 

ELPLA will activate the “Data” Tab. In addition, the file name of the current project  

[Silo] will be displayed instead of the word [Untitled] in the ELPLA title bar. 
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5.2 Project identification 

The user can enter three lines of texts to describe the problem and the basic information about the task. 

These texts are required only for printing and plotting the data and results. Project identification 

does not play any role in the analysis. The three lines are optionally and maybe not completely entered. 

To identify the project, choose "Project Identification" command from the “Data” Tab. 

The dialog box in Figure 13.6 appears. 

 

In this dialog box 

 

- Type the following line to describe the problem in the "Title" edit box:  

"Analysis of a circular silo for storing bulk materials" 

- Type the date of the project in the "Date" edit box 

- Type "Axisymmetric Structures and Tanks" in the "Project" edit box 

- Click "Save" button 

 

 
Figure 13.6 "Project Identification" dialog box 

5.3 FE-Net data 

For the given problem, a circular concrete silo having a conical hopper at the bottom part  

and a conical roof at the upper part is considered. The main height of the silo is 8 [m] and its 

diameter is 4 [m], The wall of the silo is divided into three parts, these three parts are divided  

into 14 segments; each segment is 1.0 [m]. Then these segments are divided into a number of 

elements, each element is 0.1 [m]. To define the FE-Net for this silo, choose "FE-Net Data" command 

from the “Data” Tab. "Analysis of rotational shell" wizard appears as shown in Figure 13.7.  

This wizard will guide you through the steps required to generate a FE-Net, the first Form  

of the wizard is the "Shell type" Form, which contains a group of templates of different shapes of nets.  

These net templates are used to generate standard nets. 
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Figure 13.7 "Analysis of rotational shell" wizard with "Shell type" Form 

To generate the FE-Net 

 

- In the "Shell type" options choose "Irregular shell" button 

- Type 0.25 in the "Tank base radius Rb" edit box, as the opening diameter at the bottom is 0.5 [m] 

 

To identify the hopper part  

 

• Type 3 in the "Height Hw" edit box 

• Type 2 in the "Upper radius Ro" edit box 

• Type 3 in the "Number of segments Ns" edit box 
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To identify the main wall  

 

• Type 8 in the "Height Hw" edit box 

• Type 2 in the "Upper radius Ro" edit box 

• Type 8 in the "Number of segments Ns" edit box 

 

To identify the roof part  

 

• Type 3 in the "Height Hw" edit box 

• Type 0.1 in the "Upper radius Ro" edit box, which is approximately zero 

• Type 3 in the "Number of segments Ns" edit box 

 

- Click "Next" button to go to the next Form 

 

After clicking "Next" in "Analysis of rotational shell" wizard, the following "Irregular shell" Form 

containing the data of the segments appears in Figure 13.8, the user can edit the data of each 

segment individually or all of them by using "In Table" button, if it is necessary. 
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Figure 13.8 "Irregular shell" Form 

Click "Finish" in "Analysis of rotational shell" wizard, the generated FE-Net appears Figure 13.9. 
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Figure 13.9 Generated FE-Net  

After finishing the generation of the FE-Net, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 13.9 to save the data of the FE-Net 

- Choose "Close" command from "File" menu in Figure 13.9 to close the "FE-Net" window 

and return to ELPLA main window 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Analyzing Axisymmetric Structures and Tanks by ELPLA 

 
 

 -13.14- 

5.4 Shell properties 

To define the silo properties, choose "Shell Properties" command from “Data” Tab. The following 

window in Figure 13.10 appears with default shell properties. The data of shell properties for the 

current example, which are required to be defined, are element groups, group regions, unit weight  

of the silo material, filled material properties and element size. 

 

 
Figure 13.10 "Shell Properties" Window 

Choose "Element groups" command from "In table" menu. The following list box in Figure 13.11 

appears. In this list box, define E-Modulus, Poisson’s ratio and slab thickness for both the wall and  

the hopper of the silo as they differ in thickness. Then click "OK" button. 
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Figure 13.11 "Defining element groups" list box 

Defining the slab thickness for materials on the net may be carried out either graphically or numerically 

(in a table). In the current example, the user will define the slab thickness on the net graphically. 

 

To define the slab thickness for the silo hopper  

 

- Choose "Select Elements" command from "Graphically" menu in the window of Figure 13.10 

- When "Select Elements" command is chosen, the cursor will change from an arrow to  

a cross hair. A group of elements can be selected by holding the left mouse button down at the 

corner of the region. Then, drag the mouse until a rectangle encompasses the required group of 

elements. When the left mouse button is released, all elements in the rectangle are selected 

- Select the elements that include the silo hopper as Figure 13.12 

- Choose "Elements Groups" command from "Graphically" menu in the window of Figure 13.10, 

"Group Regions" dialog box Figure 13.13 appears 

- Define the "Group No." of the hopper elements as type "2", while "Group No." of the wall 

and the roof elements will be as type "1", where type "1" is the default "Group No.",  

then click "OK" button 
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Figure 13.12 Selecting the elements that include the silo hopper 

 
Figure 13.13 "Group Regions" dialog box 
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To enter the unit weight of the silo material, choose "Unit weight" command from "Shell 

Properties" menu in Figure 13.10. The following dialog box in Figure 13.14 with a default unit 

weight of 25 [kN/m3] appears, type 23.5 in the "Unit weight" edit box, then click "OK" button. 

 

 
Figure 13.14 "Unit weight" dialog box 
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To define the filled material properties: 

 

- Choose "Filled material type/Element size" command from "Shell Properties" menu in Figure 13.10. 

The following form in Figure 13.15 appears 

- Select "Granular material container" option 

- Define the granular material properties as follows in Figure 13.15 

 

To define the element size of the container: 

 

- Check the "Constant element sizes in z-direction" check box 

- Type 0.2 in the "Element size in each shell segment" edit box 

- Click "OK" button 

 

 
Figure 13.15 "Filled material type/Element size" Form 
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Figure 13.16 "Shell Properties" window after defining the silo properties 

After entering the shell properties, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 13.16 to save the shell properties 

- Choose "Close" command from "File" menu in Figure 13.16 to close the "Shell 

properties" window and return to ELPLA main window 
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5.5 Supports/ boundary conditions 

To define the support, choose "Supports/ Boundary Conditions" command from “Data” Tab.  

The following window in Figure 13.17 appears. 

 

 
Figure 13.17 "Supports/ Boundary Conditions" Window 

To define the support on the net: 

 

- Choose "Select Nodes" command from "Graphically" menu in Figure 13.17. When "Select 

Nodes" command is chosen, the cursor will change from an arrow to a cross hair 

- Click the left mouse button on the node that has the support as shown in Figure 13.18 

- After selecting the node, choose "Add Supports/ Boundary Conditions" command  

from "Graphically" menu (Figure 13.17). The "Supports/ Boundary Conditions" dialog box 

in Figure 13.19 appears 
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Figure 13.18 Selection of the node that has the support 
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In this dialog box 

 

- Type 0 in the "Displacement w" edit box to define the vertical fixed support 

- Click "OK" button 

 

 
Figure 13.19 "Supports/ Boundary Conditions" dialog box 
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Figure 13.20 "Supports/ Boundary Conditions" window after defining the supports 

After defining the supports, do the following two steps 

 

- Choose "Save " command from "File" menu in Figure 13.20 to save the data of supports 

- Choose "Close" command from "File" menu in Figure 13.20 to close the "Supports/ 

Boundary conditions" window and return to the main window 
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5.6 Loads 

To define the loads, choose "Loads" command from “Data” Tab. The following window  
in Figure 13.21 appears. 
 
In ELPLA, entering loads may be carried out either numerically (in a table) or graphically using the 
commands of "Loads" Tab in Figure 13.21. In this example, there is not applied load, as the lateral 
load on the main wall has been already defined by Ph. 
 

 
Figure 13.21 "Loads" Window 

After finishing the definition of load data, do the following two steps: 

 

- Choose "Save" command from "File" menu in Figure 13.21 to save the load data 

- Choose "Close" command from "File" menu in Figure 13.21 to close the "Loads" window 

and return to ELPLA main window 

 

Creating the project of the silo is now complete. It is time to analyze this project.  

In the next section, you will learn how to use ELPLA for analyzing projects. 
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6 Carrying out the calculations 

To analyze the problem, switch to "Solver" Tab, Figure 13.22. 

 

 
Figure 13.22 "Solver" Tab 

ELPLA will active the "Individual Calculations" list, which contains commands of all calculations. 

Commands of calculation depend on the used calculation method in the analysis. For this project, 

the items that are required to be calculated are: 

 

- Assembling the load vector 

- Assembling the slab stiffness matrix 

- Solving the system of linear equations (band matrix)  

- Determining deformation, internal forces, contact pressures 

 

These calculation items can be carried out individually or in one time 

 

To carry out all computations in one time 

 

- Choose "Computation of all" command from "Solver" Tab window.  

 

The progress of all computations according to the defined method will be carried out automatically 

with displaying Information through menus and messages. 

 

Analysis progress 

 

Analysis progress menu in Figure 13.23 appears in which various phases of calculation  

are progressively reported as the program analyzes the problem. In addition, a status bar down  

of the "Solver" Tab window displays Information about the progress of calculation. 

 

 
Figure 13.23 Analysis progress menu 
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Check of the solution 

 

Once the analysis is carried out, a check menu of the solution appears, Figure 13.24. This menu 

compares between the values of actions and reactions. Through this comparative examination,  

the user can assess the calculation accuracy.  

 

 
Figure 13.24 Menu "Check of the solution" 

 

Click "OK" button to finish analyzing the problem. 
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7 Viewing data and results 

ELPLA can display and print a wide variety of results in graphics, diagrams or tables through  

the "Results" Tab. To view the data and results of a problem that has already been defined  

and analyzed graphically, switch to "Results" Tab (Figure 13.25). 

 

 
Figure 13.25 "Results" Tab 

The "Result" Tab contains the commands of drawing. These commands depend on the used 

calculation method in the analysis. For the current example, the commands for presenting the data 

and results are: 

 

- Data in the plan 

- Rotational shell results 

- Support Reactions 

- Sections in shell wall 

- Display tables of data 

- Display tables of results 

 

To view the radial forces on the silo wall  

 

- Choose "Sections in shell wall" command from "Section" menu. The following option box 

in Figure 13.26 appears 

- In the "Sections in shell wall" option box, select "Radial forces Nr" as an example for the 

results to be displayed 

- Click "OK" button 

 

The Results are now displayed as shown in Figure 13.27. 
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Figure 13.26 "Sections in shell wall" option box 

 

 
Figure 13.27 Radial forces on the silo wall 
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To view element groups of the silo  

 

- Choose "Element groups" from "In Plan" command in "Data" menu. The following option 

box in Figure 13.28 appears 

- In the "Data – In Plan" option box, select "Element groups" as an example for the results  

to be displayed 

- Click "OK" button 

 

 
Figure 13.28 "Data – In Plan" option box 

To view the supports / boundary conditions on the FE-Net and any other data 

 

- From "Options" menu in the "Graphic" tab, choose "View Grouping" command.  

The "View Grouping" check group box in Figure 13.29 appears 

- In this check group box, check ''Radial forces Nr", "Supports Reactions RV" and "Supports 

/Boundary Conditions" check boxes  

- The user can choose any other data to be viewed 

- Click "OK" button 

 

 
Figure 13.29 "View Grouping" check group box 
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Figure 13.30 Element groups of the silo 
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